Switching - DHCP Lab 2

DHCP Lab 2

In a Switching DHCP Lab 2 scenario, the focus likely extends to more advanced configurations and testing of DHCP (Dynamic Host Configuration Protocol) services within a switching environment. This lab may involve complex network topologies with multiple interconnected switches and routers, requiring participants to implement and troubleshoot DHCP services across various VLANs. The lab might explore features such as DHCP options, reservation configurations, and relay agent setups on the switches to ensure efficient IP address assignment and network management. Participants may also delve into DHCP security measures, such as DHCP snooping, to protect against unauthorized DHCP servers and mitigate potential security threats. By engaging in Switching DHCP Lab 2, participants gain a deeper understanding of DHCP intricacies in switched networks, preparing them for real-world scenarios where robust DHCP configurations are crucial for maintaining a scalable and secure network infrastructure.

Lab 2: Configure DHCP

DHCP Topology

Disclaimer This Configuration Guide is designed to assist members to enhance their skills in particular technology area. While every effort has been made to ensure that all material is as complete and accurate as possible, the eŶĐlosed ŵaterial is preseŶted oŶ aŶ ͞as is͟ ďasis. Neither the authors Ŷor Foruŵ assuŵe aŶy liaďility or responsibility to any person or entity with respect to loss or damages incurred from the information contained in this guide. This configuration guide was developed by Forum. Any similarities between material presented in this configuration guide and any other material is completely coincidental.

Cisco IOS Software, Linux Software (I86BI_LINUX-ADVENTERPRISEK9-M), Version 15.2(4)M1, DEVELOPMENT TEST SOFTWARE

Task 2: Configure IPv4 DHCP

Step 1: In the configuration mode of router configure IPv4 DHCP by following command:

Router1:
interface fastethernet 0/0 
no shutdown 
interface fastethernet 0/0.1 
encapsulation dotlq 100 
ip address 100.0.0.1 255.255.255.0
interface fastethernet 0/0.2 
encapsulation dot1q 200 
ip address 200.0.0.1 255.255.255.0 
exit
ip dhcp pool VLAN100 
network 100.0.0.0 255.255.255.0 
default-router 100.0.0.1 
exit 
ip dhcp excluded-address 100.0.0.1 
ip dhcp pool VLAN200 
network 200.0.0.0 255.255.255.0 
default-router 200.0.0.1 
exit 
ip dhcp excluded-address 200.0.0.1
Switch1:
interface fastethernet 0/1 
switchport mode trunk 
exit 
interface fastethernet 0/2 
switchport access vlan 100 
switchport mode access 
interface fastethernet 0/3 
switchport access vlan 200 
switchport mode access 
exit

Configure the HOST to obtain IP from DHCP.