EIGRP Named - Stub

Stub

EIGRP (Enhanced Interior Gateway Routing Protocol) Named Stub is a configuration feature that allows network administrators to enhance network efficiency and reduce unnecessary routing information in specific areas of an EIGRP-enabled network. Named Stub differs from traditional stub configurations by introducing greater flexibility and granularity in defining the stub behavior. In EIGRP Named Stub, administrators can create named stub definitions, each tailored to specific requirements, and then associate these named stubs with particular interfaces or routers. This fine-grained control allows for more precise customization of EIGRP stub behavior within the network. By configuring Named Stub, administrators can streamline routing updates, optimize network resources, and improve the overall scalability of EIGRP in designated areas, providing a more nuanced and adaptable approach to stub configuration.

Lab:

Disclaimer

This Configuration Guide is designed to assist members to enhance their skills in particular technology area. While every effort has been made to ensure that all material is as complete and accurate as possible, the enclosed material is presented on an Dzas isdz basis. Neither the authors nor Forum assume any liability or responsibility to any person or entity with respect to loss or damages incurred from the information contained in this guide. This configuration guide was developed by Forum. Any similarities between material presented in this configuration guide and any other material is completely coincidental.

Cisco IOS Software, Linux Software (I86BI_LINUX-ADVENTERPRISEK9-M), Version 15.2(4)M1, DEVELOPMENT TEST SOFTWARE

Task 1: Configure EIGRP Stub using named configuration

Step 1: In the configuration mode of router configure IPv4 EIGRP process with a name & enter address-family interface mode

R1:
router eigrp cisco
address-family ipv4 autonomous-system 100 network 12.0.0.1 255.255.255.0
network 11.0.1.1 255.255.255.0
network 11.0.2.1 255.255.255.0
network 11.0.3.1 255.255.255.0
R2:
router eigrp cisco
address-family ipv4 autonomous-system 100 network 12.0.0.2 255.255.255.0
network 23.0.0.2 255.255.255.0
network 22.0.1.2 255.255.255.0
network 22.0.2.2 255.255.255.0
network 22.0.3.2 255.255.255.0
exit
R3:
router eigrp cisco
address-family ipv4 autonomous-system 100 network 34.0.0.3 255.255.255.0
network 23.0.0.3 255.255.255.0
network 33.0.1.3 255.255.255.0
network 33.0.2.3 255.255.255.0
network 33.0.3.3 255.255.255.0
exit
R4:
router eigrp cisco
address-family ipv4 autonomous-system 100 network 34.0.0.4 255.255.255.0
network 44.0.1.4 255.255.255.0
network 44.0.2.4 255.255.255.0
network 44.0.3.4 255.255.255.0
exit

Step 2: Configure EIGRP stub with connected option

R1:
router eigrp cisco
address-family ipv4 autonomous-system 100 eigrp 
stub ?
connected	    Do advertise connected routes
leak-map	    Allow dynamic prefixes based on the leak-map 	
receive-only    Set receive only neighbor
redistributed	Do advertise redistributed routes 
static	        Do advertise static routes 
summary	        Do advertise summary routes
eigrp stub connected 
exit

Step 3: Configure EIGRP stub with connected static option

R1:
router eigrp cisco
address-family ipv4 autonomous-system 100 eigrp stub static
exit

Step 4: Configure EIGRP stub with receive only option

R1:
router eigrp cisco
address-family ipv4 autonomous-system 100 eigrp stub receive-only
exit

Task 2: Verification:

Step 1: Verify route in neighbors router routing table by following command:

R2#show ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP 
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route 
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
/+ - replicated route, % - next hop override

Gateway of last resort is not set

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.0.0.0/24 is directly connected, Serial2/0
L 12.0.0.2/32 is directly connected, Serial2/0
 22.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C 22.0.1.0/24 is directly connected, Loopback1
L 22.0.1.2/32 is directly connected, Loopback1
C 22.0.2.0/24 is directly connected, Loopback2
L 22.0.2.2/32 is directly connected, Loopback2
C 22.0.3.0/24 is directly connected, Loopback3
L 22.0.3.2/32 is directly connected, Loopback3
 23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.0.0.0/24 is directly connected, Ethernet0/0
L 23.0.0.2/32 is directly connected, Ethernet0/0
 33.0.0.0/24 is subnetted, 3 subnets
D 33.0.1.0 [90/1024640] via 23.0.0.3, 00:11:22, Ethernet0/0
D 33.0.2.0 [90/1024640] via 23.0.0.3, 00:11:22, Ethernet0/0
D 33.0.3.0 [90/1024640] via 23.0.0.3, 00:11:22, Ethernet0/0
 34.0.0.0/24 is subnetted, 1 subnets
D 34.0.0.0 [90/14068062] via 23.0.0.3, 00:11:22, Ethernet0/0
 44.0.0.0/24 is subnetted, 3 subnets
D 44.0.1.0 [90/14068702] via 23.0.0.3, 00:11:22, Ethernet0/0
D 44.0.2.0 [90/14068702] via 23.0.0.3, 00:11:22, Ethernet0/0
D 44.0.3.0 [90/14068702] via 23.0.0.3, 00:11:22, Ethernet0/0

Step 2: Configure no auto summary

R1:
router eigrp cisco
address-family ipv4 autonomous-system 100
topology base
no auto-summary

Step 3: Verify routes on neighbor router routing table

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
/+ - replicated route, % - next hop override

Gateway of last resort is not set

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.0.0.0/24 is directly connected, Serial2/0
L 12.0.0.2/32 is directly connected, Serial2/0
 22.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C 22.0.1.0/24 is directly connected, Loopback1
L 22.0.1.2/32 is directly connected, Loopback1
C 22.0.2.0/24 is directly connected, Loopback2
L 22.0.2.2/32 is directly connected, Loopback2
C 22.0.3.0/24 is directly connected, Loopback3
L 22.0.3.2/32 is directly connected, Loopback3
 23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.0.0.0/24 is directly connected, Ethernet0/0
L 23.0.0.2/32 is directly connected, Ethernet0/0
 33.0.0.0/24 is subnetted, 3 subnets
D 33.0.1.0 [90/1024640] via 23.0.0.3, 00:00:58, Ethernet0/0
D 33.0.2.0 [90/1024640] via 23.0.0.3, 00:00:58, Ethernet0/0
D 33.0.3.0 [90/1024640] via 23.0.0.3, 00:00:58, Ethernet0/0
 34.0.0.0/24 is subnetted, 1 subnets
D 34.0.0.0 [90/14068062] via 23.0.0.3, 00:00:58, Ethernet0/0
 44.0.0.0/24 is subnetted, 3 subnets
D 44.0.1.0 [90/14068702] via 23.0.0.3, 00:00:58, Ethernet0/0
D 44.0.2.0 [90/14068702] via 23.0.0.3, 00:00:58, Ethernet0/0
D 44.0.3.0 [90/14068702] via 23.0.0.3, 00:00:58, Ethernet0/0