Lab 4: Configuring BGP within Service Provider

Lab 4: Configuring BGP within Service Provider

Task 1: Verify Pre-Configuration as mentioned below.

The following configuration needs to be verified

  • IP addressing for all nodes including Physical and Software Interfaces.
DeviceHostnameOperating systemInterfaceIP Address & Mask
Provider Edge 1PE1IOSEthernet 0/210.0.23.2/24
Loopback 12.2.2.2/32
Provider 1P1IOS-XRGigabitEthernet 0/0/0/210.0.23.3/24
GigabitEthernet 0/0/0/310.0.34.3/24
Loopback 13.3.3.3/32
Route Reflector 1RR1IOS-XRGigabitEthernet 0/0/0/310.0.34.4/24
GigabitEthernet 0/0/0/210.0.45.4/24
Loopback 14.4.4.4/32
Provider 2P2IOSEthernet 0/210.0.45.5/24
Ethernet 0/310.0.56.5/24
Loopback 15.5.5.5/32
Provider Edge 2PE2IOS-XRGigabitEthernet 0/0/0/4
Loopback 1Area 0

Verify OSPF configured as per table below.

DeviceOSPF ProcessInterfaceArea
Provider Edge 11Ethernet 0/2Area 0
1Loopback 1Area 0
Provider 11GigabitEthernet 0/0/0/2Area 0
1GigabitEthernet 0/0/0/3Area 0
1Loopback 1Area 0
Route Reflector 11GigabitEthernet 0/0/0/3Area 0
1GigabitEthernet 0/0/0/2Area 0
1Loopback 1Area 0
Provider 21Ethernet 0/2Area 0
1Ethernet 0/3Area 0
1Loopback 1Area 0
Provider Edge 21GigabitEthernet 0/0/0/4Area 0
1Loopback 1Area 0

Task 2: Configure BGP in AS 3

Configure BGP as per requirement mentioned below:

  1. BGP AS Number for the Service provider is AS 3.
  2. IBGP neighborship to be formed between PE1 and RR1 using their Loopback 1 interface.
  3. IBGP neighborship to be formed between PE2 and RR1 using their Loopback 1 interface.
  4. Advertise Loopback 0 interfaces for PE1, RR1 & PE2.
  5. Disable all default address-family for Ipv4 and all neighbors must be enabled manually.
PE1#configure terminal
PE1(config)#router bgp 3                                   
PE1(config-router)# no bgp default ipv4-unicast
PE1(config-router)# neighbor 4.4.4.4 remote-as 3
PE1(config-router)# neighbor 4.4.4.4 update-source Loopback1
PE1(config-router)# address-family ipv4
PE1(config-router-af)#  neighbor 4.4.4.4 activate
PE1(config-router-af)#network 2.2.2.2 mask 255.255.255.255
PE1(config-router-af)#end
PE1#write memory
    
RP/0/0/CPU0:RR1#configure
RP/0/0/CPU0:RR1(config)#router bgp 3
RP/0/0/CPU0:RR1(config-bgp)# address-family ipv4 unicast
RP/0/0/CPU0:RR1(config-bgp-af)#  network 4.4.4.4/32
RP/0/0/CPU0:RR1(config-bgp-af)# neighbor 2.2.2.2
RP/0/0/CPU0:RR1(config-bgp-nbr)#  remote-as 3
RP/0/0/CPU0:RR1(config-bgp-nbr)#  update-source Loopback1
RP/0/0/CPU0:RR1(config-bgp-nbr)#  address-family ipv4 unicast
RP/0/0/CPU0:RR1(config-bgp-nbr-af)#   route-reflector-client
RP/0/0/CPU0:RR1(config-bgp-nbr-af)# neighbor 6.6.6.6
RP/0/0/CPU0:RR1(config-bgp-nbr)#  remote-as 3
RP/0/0/CPU0:RR1(config-bgp-nbr)#update-source Loopback1
RP/0/0/CPU0:RR1(config-bgp-nbr)#address-family ipv4 unicast
RP/0/0/CPU0:RR1(config-bgp-nbr-af)#   route-reflector-client
RP/0/0/CPU0:RR1(config-bgp-nbr-af)#commit
RP/0/0/CPU0:RR1(config-bgp-nbr-af)#end
    
RP/0/0/CPU0:PE2#configure 
RP/0/0/CPU0:PE2(config)#router bgp 3
RP/0/0/CPU0:PE2(config-bgp)#address-family ipv4 unicast 
RP/0/0/CPU0:PE2(config-bgp-af)#network 6.6.6.6/32
RP/0/0/CPU0:PE2(config-bgp-af)#exit
RP/0/0/CPU0:PE2(config-bgp)#neighbor 4.4.4.4
RP/0/0/CPU0:PE2(config-bgp-nbr)#remote-as 3
RP/0/0/CPU0:PE2(config-bgp-nbr)#update-source loopback 1
RP/0/0/CPU0:PE2(config-bgp-nbr)#address-family ipv4 unicast 
RP/0/0/CPU0:PE2(config-bgp-nbr-af)#commit
RP/0/0/CPU0:PE2(config-bgp-nbr-af)#end
    

Task 3: Verify BGP Configuration

PE1#show bgp ipv4 unicast summary 
BGP router identifier 2.2.2.2, local AS number 3
Neighbor            V            AS     MsgRcvd      MsgSent         TblVer       InQ  OutQ      Up/Down         State/PfxRcd
4.4.4.4             4            3      12           12              6            0    0         00:06:55        2
    
RP/0/0/CPU0:RR1#show bgp ipv4 unicast summary 
BGP router identifier 4.4.4.4, local AS number 3

Neighbor            Spk          AS     MsgRcvd      MsgSent           TblVer    InQ   OutQ       Up/Down           St/PfxRcd
2.2.2.2             0            3      14           13                5         0     0          00:07:51          1
6.6.6.6             0            3       7            9                5         0     0          00:02:12          1
    
RP/0/0/CPU0:PE2#show bgp ipv4 unicast summary 
BGP router identifier 6.6.6.6, local AS number 3

Neighbor            Spk          AS      MsgRcvd     MsgSent       TblVer        InQ    OutQ     Up/Down           St/PfxRcd
4.4.4.4             0            3       10          8             5             0      0        00:03:43          2
    
PE1#show bgp ipv4 unicast         
Network              Next Hop                 Metric         LocPrf       Weight      Path
*>  2.2.2.2/32       0.0.0.0                  0                           32768       i
r>i 4.4.4.4/32       4.4.4.4                  0              100            0         i
r>i 6.6.6.6/32       6.6.6.6                  0              100            0         i
   
RP/0/0/CPU0:RR1#show bgp ipv4 unicast
Network               Next Hop                 Metric         LocPrf       Weight      Path
*>i2.2.2.2/32         2.2.2.2                  0              100            0         i
*> 4.4.4.4/32         0.0.0.0                  0                           32768       i
*>i6.6.6.6/32         6.6.6.6                  0              100            0         i
    
RP/0/0/CPU0:PE2#show bgp ipv4 unicast         
Network               Next Hop                 Metric         LocPrf       Weight      Path
*>i2.2.2.2/32         2.2.2.2                  0              100            0         i
*>i4.4.4.4/32         4.4.4.4                  0              100            0         i
*> 6.6.6.6/32         0.0.0.0                  0                           32768       i 
    

Task 4: Verify BGP update information.

PE1#show bgp ipv4 unicast summary 
BGP router identifier 2.2.2.2, local AS number 3
BGP table version is 6, main routing table version 6

Neighbor        V         AS 	 MsgRcvd        MsgSent       Up/Down	    State/PfxRcd
4.4.4.4         4         3      14             13            00:08:41      2
 
RP/0/0/CPU0:RR1#show bgp ipv4 unicast summary 
BGP router identifier 4.4.4.4, local AS number 3
BGP scan interval 60 secs

Neighbor           AS     MsgRcvd 	MsgSent         Up/Down	            State/PfxRcd
2.2.2.2            3      16      	17           	00:11:25            1
6.6.6.6            3       8      	11           	00:03:11            1

Task 5: Configure Multi-Protoocl BGP.

Configure MP-BGP between PE1 and RR1 with RR1 being Router-reflector. Configure MP-BGP between PE2 and RR1 with RR1 being Router-reflector.

PE1#configure terminal 
PE1(config)#router bgp 3
PE1(config-router)#address-family vpnv4 unicast 
PE1(config-router-af)#neighbor 4.4.4.4 activate 
PE1(config-router-af)#end
PE1#write memory
    
RP/0/0/CPU0:RR1#configure 
RP/0/0/CPU0:RR1(config)#router bgp 3
RP/0/0/CPU0:RR1(config-bgp)#address-family vpnv4 unicast
RP/0/0/CPU0:RR1(config-bgp)#neighbor 2.2.2.2
RP/0/0/CPU0:RR1(config-bgp-nbr)#address-family vpnv4 unicast 
RP/0/0/CPU0:RR1(config-bgp-nbr-af)#route-reflector-client 
RP/0/0/CPU0:RR1(config-bgp-nbr-af)#neighbor 6.6.6.6             
RP/0/0/CPU0:RR1(config-bgp-nbr)#address-family vpnv4 unicast 
RP/0/0/CPU0:RR1(config-bgp-nbr-af)#route-reflector-client       
RP/0/0/CPU0:RR1(config-bgp-nbr-af)#commit
RP/0/0/CPU0:RR1(config-bgp)#address-family vpnv4 unicast
RP/0/0/CPU0:RR1(config-bgp)#end
    
RP/0/0/CPU0:PE2#configure 
RP/0/0/CPU0:PE2(config)#router bgp 3
RP/0/0/CPU0:PE2(config-bgp)#address-family vpnv4 unicast 
RP/0/0/CPU0:PE2(config-bgp-af)#exit 
RP/0/0/CPU0:PE2(config-bgp)#neighbor 4.4.4.4
RP/0/0/CPU0:PE2(config-bgp-nbr)#address-family vpnv4 unicast 
RP/0/0/CPU0:PE2(config-bgp-nbr-af)#commit
RP/0/0/CPU0:PE2(config-bgp-nbr-af)#end
    

Task 6: Verify Multi-Protoocl BGP.

PE1#show bgp ipv4 unicast neighbors  | inc BGP neighbor|VPNv4
BGP neighbor is 4.4.4.4,  remote AS 3, internal link
    Address family VPNv4 Unicast: advertised and received
    For address family: VPNv4 Unicast
    
RP/0/0/CPU0:RR1#show bgp ipv4 unicast neighbors | inc "BGP neighbor|VPNv4 Uni
Sat Jun 12 02:57:22.841 UTC
BGP neighbor is 2.2.2.2
    Address family VPNv4 Unicast: advertised and received
    BGP neighbor version 15
    For Address Family: VPNv4 Unicast
    BGP neighbor version 9
BGP neighbor is 6.6.6.6
    Address family VPNv4 Unicast: advertised and received
    BGP neighbor version 15
    For Address Family: VPNv4 Unicast
    BGP neighbor version 9
    
RP/0/0/CPU0:PE2#show bgp ipv4 unicast neighbors | inc "BGP neighbor|VPNv4 Uni"
Sat Jun 12 02:57:49.973 UTC
BGP neighbor is 4.4.4.4
    Address family VPNv4 Unicast: advertised and received
    BGP neighbor version 17
    For Address Family: VPNv4 Unicast
    BGP neighbor version 19