Lab 5: Configuring Intra-AS MPLS L3VPN using Static Routing as PE-CE Protocol

Lab 5: Configuring Intra-AS MPLS L3VPN using Static Routing as PE-CE Protocol

Task 1: Configuration of IP Addresses with Service Provider

The following configuration has been pre-configred.

  • IP addressing for all nodes including Physical and Software Interfaces.
DeviceOperating SystemInterfaceIP Address and Mask
Provider Edge 1IOS-XEEthernet 0/2
Loopback 1Area 0
Provider 1GigabitEthernet 0/0/0/2Area 0
GigabitEthernet 0/0/0/3Area 0
Loopback 1Area 0
Route Reflector 1GigabitEthernet 0/0/0/2Area 0
GigabitEthernet 0/0/0/3Area 0
Loopback 1Area 0
Provider 2Ethernet 0/2Area 0
Ethernet 0/3Area 0
Loopback 1Area 0
Provider Edge 2GigabitEthernet 0/0/0/3Area 0
Loopback 1Area 0

Task 2: Configure OSPF within AS 3

Use the following parameters to configure OSPF within the Service Provider

DeviceOSPF ProcessInterfaceArea
Provider Edge 11Ethernet 0/2Area 0
1Loopback 1Area 0
Provider 11GigabitEthernet 0/0/0/2Area 0
1GigabitEthernet 0/0/0/3Area 0
1Loopback 1Area 0
Route Reflector 11GigabitEthernet 0/0/0/3Area 0
1GigabitEthernet 0/0/0/2Area 0
1Loopback 1Area 0
Provider 21Ethernet 0/2Area 0
1Ethernet 0/3Area 0
1Loopback 1Area 0
Provider Edge 21GigabitEthernet 0/0/0/3Area 0
1Loopback 1Area 0

PE1:

PE1#configure terminal 
PE1(config)#router ospf 1
PE1(config-router)#interface loopback 1
PE1(config-if)#ip ospf 1 area 0
PE1(config)#interface Ethernet 0/2
PE1(config-if)#ip ospf 1 area 0           
PE1(config-if)#end
PE1#write memory 

P1:

RP/0/0/CPU0:P1#configure 
RP/0/0/CPU0:P1(config)#router ospf 1
RP/0/0/CPU0:P1(config-ospf)#area 0
RP/0/0/CPU0:P1(config-ospf-ar)#interface GigabitEthernet0/0/0/1
RP/0/0/CPU0:P1(config-ospf-ar-if)#interface GigabitEthernet0/0/0/2
RP/0/0/CPU0:P1(config-ospf-ar-if)#interface loopback 1
RP/0/0/CPU0:P1(config-ospf-ar-if)#commit
RP/0/0/CPU0:P1(config-ospf-ar-if)#end
    

RR1:

RP/0/0/CPU0:RR1#configure
RP/0/0/CPU0:RR1(config)#router ospf 1
RP/0/0/CPU0:RR1(config-ospf)#area 0
RP/0/0/CPU0:RR1(config-ospf-ar)#interface loopback1
RP/0/0/CPU0:RR1(config-ospf-ar-if)#interface g0/0/0/2
RP/0/0/CPU0:RR1(config-ospf-ar-if)#interface g0/0/0/3
RP/0/0/CPU0:RR1(config-ospf-ar-if)#commit
RP/0/0/CPU0:RR1(config-ospf-ar-if)#end
    

P2:

P2#configure terminal 
P2(config)#router ospf 1
P2(config)#interface loopback 1
P2(config-if)#ip ospf 1 area 0  
P2(config)#interface Ethernet 0/2
P2(config-if)#ip ospf 1 area 0           
P2(config-if)#interface Ethernet 0/3
P2(config-if)#ip ospf 1 area 0           
P2(config-if)#end
P2#write memory 
    

PE2:

RP/0/0/CPU0:PE2#configure 
RP/0/0/CPU0:PE2(config)#router ospf 1
RP/0/0/CPU0:PE2(config-ospf)#area 0
RP/0/0/CPU0:PE2(config-ospf-ar)#interface loopback 1
RP/0/0/CPU0:PE2(config-ospf-ar)#interface GigabitEthernet 0/0/0/3
RP/0/0/CPU0:PE2(config-ospf-ar-if)#commit
RP/0/0/CPU0:PE2(config-ospf-ar-if)#end

Task 3: Verify OSPF Configuration.

Verify all routes within the routing table of all Provider devices.

PE1:

PE1#show ip route ospf 
O        3.3.3.3 [110/2] via 10.0.23.3, 00:33:15, Ethernet 0/2
O        4.4.4.4 [110/3] via 10.0.23.3, 00:32:07, Ethernet 0/2
O        5.5.5.5 [110/4] via 10.0.23.3, 00:29:17, Ethernet 0/2
O        10.0.45.0/24 [110/3] via 10.0.23.3, 00:32:07, Ethernet 0/2
O        10.0.56.0/24 [110/4] via 10.0.23.3, 00:29:17, Ethernet 0/2
    

P1:

RP/0/0/CPU0:P1#show route ipv4 unicast ospf
O    2.2.2.2/32 [110/2] via 10.0.23.2, 00:35:52, GigabitEthernet0/0/0/2
O    4.4.4.4/32 [110/2] via 10.0.34.4, 00:34:45, GigabitEthernet0/0/0/3
O    5.5.5.5/32 [110/3] via 10.0.34.4, 00:31:50, GigabitEthernet0/0/0/3
O    6.6.6.6/32 [110/4] via 10.0.34.4, 00:29:12, GigabitEthernet0/0/0/3
O    10.0.45.0/24 [110/2] via 10.0.34.4, 00:34:45, GigabitEthernet0/0/0/3
O    10.0.56.0/24 [110/3] via 10.0.34.4, 00:31:50, GigabitEthernet0/0/0/3

RP/0/0/CPU0:RR1#show route ipv4 unicast ospf
O    2.2.2.2/32 [110/3] via 10.0.34.3, 00:35:35, GigabitEthernet0/0/0/3
O    3.3.3.3/32 [110/2] via 10.0.34.3, 00:35:35, GigabitEthernet0/0/0/3
O    5.5.5.5/32 [110/2] via 10.0.45.5, 00:32:41, GigabitEthernet0/0/0/2
O    6.6.6.6/32 [110/3] via 10.0.45.5, 00:30:03, GigabitEthernet0/0/0/2
O    10.0.23.0/24 [110/2] via 10.0.34.3, 00:35:35, GigabitEthernet0/0/0/3
O    10.0.56.0/24 [110/2] via 10.0.45.5, 00:32:41, GigabitEthernet0/0/0/2
    
P2#show ip route ospf 
O        2.2.2.2 [110/4] via 10.0.45.4, 00:34:24, Ethernet 0/2
O        3.3.3.3 [110/3] via 10.0.45.4, 00:34:24, Ethernet 0/2
O        4.4.4.4 [110/2] via 10.0.45.4, 00:34:24, Ethernet 0/2
O        6.6.6.6 [110/2] via 10.0.56.6, 00:31:51, Ethernet 0/3
O        10.0.23.0/24 [110/3] via 10.0.45.4, 00:34:24, Ethernet 0/2
O        10.0.34.0/24 [110/2] via 10.0.45.4, 00:34:24, Ethernet 0/2
    
RP/0/0/CPU0:PE2#show route ipv4 unicast ospf 
O    2.2.2.2/32 [110/5] via 10.0.56.5, 00:34:50, GigabitEthernet0/0/0/3
O    3.3.3.3/32 [110/4] via 10.0.56.5, 00:34:50, GigabitEthernet0/0/0/3
O    4.4.4.4/32 [110/3] via 10.0.56.5, 00:34:50, GigabitEthernet0/0/0/3
O    5.5.5.5/32 [110/2] via 10.0.56.5, 00:34:50, GigabitEthernet0/0/0/3
O    10.0.23.0/24 [110/4] via 10.0.56.5, 00:34:50, GigabitEthernet0/0/0/3
O    10.0.34.0/24 [110/3] via 10.0.56.5, 00:34:50, GigabitEthernet0/0/0/3
O    10.0.45.0/24 [110/2] via 10.0.56.5, 00:34:50, GigabitEthernet0/0/0/3
    

Task 4: Configure LDP within Service Provider.

DeviceInterfaceProtocol
Provider EdgeEthernet 0/2LDP
Provider 1GigabitEthernet 0/0/0/2LDP
GigabitEthernet 0/0/0/3LDP
Route Reflector 1GigabitEthernet 0/0/0/2LDP
GigabitEthernet 0/0/0/3LDP
Provider 2Ethernet 0/2LDP
Ethernet 0/3LDP
Provider Edge 2GigabitEthernet 0/0/0/3LDP
PE1#configure terminal
PE1(config)#mpls label protocol ldp
PE1(config)#mpls ldp router-id lo1
PE1(config)#interface Ethernet 0/2
PE1(config-if)#mpls ip
PE1(config-if)#end
PE1#write memory
    
RP/0/0/CPU0:P1#configure 
Fri Jun 11 06:46:09.347 UTC
RP/0/0/CPU0:P1(config)#mpls ldp 
RP/0/0/CPU0:P1(config-ldp)#router-id 3.3.3.3
RP/0/0/CPU0:P1(config-ldp)#interface GigabitEthernet 0/0/0/2
RP/0/0/CPU0:P1(config-ldp-if)#interface GigabitEthernet 0/0/0/3
RP/0/0/CPU0:P1(config-ldp-if)#commit
Fri Jun 11 06:46:29.145 UTC
RP/0/0/CPU0:P1(config-ldp-if)#end
    
RP/0/0/CPU0:RR1#configure 
Fri Jun 11 06:53:50.428 UTC
RP/0/0/CPU0:RR1(config)#mpls ldp
RP/0/0/CPU0:RR1(config-ldp)#router-id 4.4.4.4
RP/0/0/CPU0:RR1(config-ldp)#interface GigabitEthernet 0/0/0/2
RP/0/0/CPU0:RR1(config-ldp-if)#interface GigabitEthernet 0/0/0/3
RP/0/0/CPU0:RR1(config-ldp-if)#commit
Fri Jun 11 06:54:19.196 UTC
RP/0/0/CPU0:RR1(config-ldp-if)#end
   
P2#configure terminal 
P2(config)#mpls label protocol ldp
P2(config)#mpls ldp router-id loopback 1
P2(config)#interface Ethernet 0/2
P2(config-if)#mpls ip
P2(config-if)#interface Ethernet 0/3
P2(config-if)#mpls ip                    
P2(config-if)#end
P2#write memory 
   
RP/0/0/CPU0:PE2#configure 
RP/0/0/CPU0:PE2(config)#mpls ldp 
RP/0/0/CPU0:PE2(config-ldp)#router-id 6.6.6.6
RP/0/0/CPU0:PE2(config-ldp)#interface GigabitEthernet 0/0/0/3
RP/0/0/CPU0:PE2(config-ldp-if)#commit 
RP/0/0/CPU0:PE2(config-ldp-if)#end

Task 5: Verification of MPLS LDP Configuration.

PE1#show mpls forwarding-table 
Local      Outgoing           Prefix           	Bytes Label   	Outgoing        Next Hop    
Label       Label             or Tunnel Id      Switched      	Interface              

16         Pop Label          3.3.3.3/32       	0             	Eth0/2        	10.0.23.3   
17         24001              4.4.4.4/32       	0             	Eth0/2        	10.0.23.3   
18         24003              5.5.5.5/32       	0             	Eth0/2        	10.0.23.3   
19         24005              6.6.6.6/32       	0             	Eth0/2        	10.0.23.3   
20         Pop Label          10.0.34.0/24     	0            	Eth0/2        	10.0.23.3   
21         24002              10.0.45.0/24     	0             	Eth0/2        	10.0.23.3   
22         24004              10.0.56.0/24     	0             	Eth0/2        	10.0.23.3   
    
RP/0/0/CPU0:P1#show mpls forwarding
Local 	Outgoing    	Prefix             	Outgoing     	Next Hop        Bytes       
Label	Label       	or ID              	Interface                    	Switched    
------ -----------     	------------------ 	------------ 	--------------- ------------
24000	Pop         	2.2.2.2/32         	Gi0/0/0/2    	10.0.23.2       10878       
24001 	Pop         	4.4.4.4/32         	Gi0/0/0/3    	10.0.34.4       9898        
24002  	Pop         	10.0.45.0/24            Gi0/0/0/3    	10.0.34.4       0           
24003  	24003       	5.5.5.5/32         	Gi0/0/0/3    	10.0.34.4       0           
24004  	24004       	10.0.56.0/         	Gi0/0/0/3    	10.0.34.4       0           
24005  	24005       	6.6.6.6/32         	Gi0/0/0/3    	10.0.34.4       0     
    
RP/0/0/CPU0:RR1#show mpls forwarding 
Local  	Outgoing        Prefix             Outgoing     	Next Hop       	Bytes       
Label  	Label       	or ID              Interface            	       	Switched    
------ -----------     	----------------   ------------ 	--------------- ------------
24000	24000       	2.2.2.2/32         Gi0/0/0/3    	10.0.34.3       0           
24001	Pop         	3.3.3.3/32         Gi0/0/0/3    	10.0.34.3       10192       
24002 	Pop         	10.0.23.0/24       Gi0/0/0/3    	10.0.34.3       0           
24003 	Pop         	5.5.5.5/32         Gi0/0/0/2    	10.0.45.5      	10210       
24004 	Pop         	10.0.56.0/24       Gi0/0/0/2    	10.0.45.5       0           
24005  	19          	6.6.6.6/32         Gi0/0/0/2    	10.0.45.5       0 
    
P2#show mpls forwarding-table 
Local      Outgoing     Prefix           	Bytes Label   	Outgoing        Next Hop    
Label      Label        or Tunnel Id            Switched      	Interface              

16         24000      	2.2.2.2/32       	0             	Eth0/2        	10.0.45.4   
17         24001      	3.3.3.3/32       	0             	Eth0/2        	10.0.45.4   
18         Pop Label  	4.4.4.4/32       	0            	Eth0/2        	10.0.45.4   
19         Pop Label  	6.6.6.6/32       	0             	Eth0/3        	10.0.56.6   
20         24002      	10.0.23.0/24     	0             	Eth0/2        	10.0.45.4   
21         Pop Label  	10.0.34.0/24     	0             	Eth0/2        	10.0.45.4   
    
RP/0/0/CPU0:PE2#show mpls forwarding 
Local  	Outgoing        Prefix             	Outgoing     	Next Hop       	Bytes       
Label  	Label       	or ID              	Interface            	       	Switched    
------ -----------     	------------------ 	------------ 	--------------- ------------

24000  	16          	2.2.2.2/32        	Gi0/0/0/3    	10.0.56.5       0           
24001  	17          	3.3.3.3/32         	Gi0/0/0/3    	10.0.56.5       0           
24002  	18          	4.4.4.4/32         	Gi0/0/0/3    	10.0.56.5       0           
24003  	Pop         	5.5.5.5/32         	Gi0/0/0/3    	10.0.56.5       10366       
24004  	Pop         	10.0.45.0/24      	Gi0/0/0/3    	10.0.56.5       0           
24005  	21          	10.0.34.0/24    	Gi0/0/0/3    	10.0.56.5       0           
24006  	20          	10.0.23.0/24    	Gi0/0/0/3    	10.0.56.5       0
    

Task 6: Configure BGP in AS 3

Configure BGP as per requirement mentioned below

  1. IBGP neighborship to be formed between PE1 and RR1 using their Loopback 1 interface.
  2. IBGP neighborship to be formed between PE2 and RR1 using their Loopback 1 interface.
  3. Advertise Loopback 0 interfaces for PE1, RR1 & PE2.
  4. Disable all default address-family for Ipv4 and all neighbors must be enabled manually.
PE1#configure terminal
PE1(config)#router bgp 3                                   
PE1(config-router)# no bgp default ipv4-unicast
PE1(config-router)# neighbor 4.4.4.4 remote-as 3
PE1(config-router)# neighbor 4.4.4.4 update-source Loopback1
PE1(config-router)# address-family ipv4
PE1(config-router-af)#  neighbor 4.4.4.4 activate
PE1(config-router-af)#network 2.2.2.2 mask 255.255.255.255
PE1(config-router-af)#end
PE1#write memory
RP/0/0/CPU0:RR1#configure
RP/0/0/CPU0:RR1(config)#router bgp 3
RP/0/0/CPU0:RR1(config-bgp)# address-family ipv4 unicast
RP/0/0/CPU0:RR1(config-bgp-af)#  network 4.4.4.4/32
RP/0/0/CPU0:RR1(config-bgp-af)# neighbor 2.2.2.2
RP/0/0/CPU0:RR1(config-bgp-nbr)#  remote-as 3
RP/0/0/CPU0:RR1(config-bgp-nbr)#  update-source Loopback1
RP/0/0/CPU0:RR1(config-bgp-nbr)#  address-family ipv4 unicast
RP/0/0/CPU0:RR1(config-bgp-nbr-af)#   route-reflector-client
RP/0/0/CPU0:RR1(config-bgp-nbr-af)# neighbor 6.6.6.6
RP/0/0/CPU0:RR1(config-bgp-nbr)#  remote-as 3
RP/0/0/CPU0:RR1(config-bgp-nbr)#update-source Loopback1
RP/0/0/CPU0:RR1(config-bgp-nbr)#address-family ipv4 unicast
RP/0/0/CPU0:RR1(config-bgp-nbr-af)#   route-reflector-client
RP/0/0/CPU0:RR1(config-bgp-nbr-af)#commit
RP/0/0/CPU0:RR1(config-bgp-nbr-af)#end
    
RP/0/0/CPU0:PE2#configure 
RP/0/0/CPU0:PE2(config)#router bgp 3
RP/0/0/CPU0:PE2(config-bgp)#address-family ipv4 unicast 
RP/0/0/CPU0:PE2(config-bgp-af)#network 6.6.6.6/32
RP/0/0/CPU0:PE2(config-bgp-af)#exit
RP/0/0/CPU0:PE2(config-bgp)#neighbor 4.4.4.4
RP/0/0/CPU0:PE2(config-bgp-nbr)#remote-as 3
RP/0/0/CPU0:PE2(config-bgp-nbr)#update-source loopback 1
RP/0/0/CPU0:PE2(config-bgp-nbr)#address-family ipv4 unicast 
RP/0/0/CPU0:PE2(config-bgp-nbr-af)#commit
RP/0/0/CPU0:PE2(config-bgp-nbr-af)#end
    

Task 7: Verify BGP Configuration

PE1#show bgp ipv4 unicast summary 
BGP router identifier 2.2.2.2, local AS number 3
Neighbor            V            AS     MsgRcvd      MsgSent         TblVer       InQ  OutQ      Up/Down         State/PfxRcd
4.4.4.4             4            3      12           12              6            0    0         00:06:55        2
    
RP/0/0/CPU0:RR1#show bgp ipv4 unicast summary 
BGP router identifier 4.4.4.4, local AS number 3

Neighbor            Spk        AS     MsgRcvd      MsgSent           TblVer    InQ  OutQ       Up/Down           St/PfxRcd
2.2.2.2             0          3      14           13                5         0    0          00:07:51          1
6.6.6.6             0          3       7            9                5         0    0          00:02:12          1
    
RP/0/0/CPU0:PE2#show bgp ipv4 unicast summary 
BGP router identifier 6.6.6.6, local AS number 3

Neighbor             Spk       AS      MsgRcvd     MsgSent           TblVer     InQ  OutQ     Up/Down           St/PfxRcd
4.4.4.4              0         3       10          8                 5          0    0        00:03:43          2
    
PE1#show bgp ipv4 unicast
Network              Next Hop                 Metric         LocPrf       Weight         Path
*>  2.2.2.2/32       0.0.0.0                  0                           32768          i
r>i 4.4.4.4/32       4.4.4.4                  0              100            0            i
r>i 6.6.6.6/32       6.6.6.6                  0              100            0            i
   
RP/0/0/CPU0:RR1#show bgp ipv4 unicast 
Network               Next Hop                 Metric         LocPrf       Weight        Path
*>i2.2.2.2/32         2.2.2.2                  0              100            0           i
*> 4.4.4.4/32         0.0.0.0                  0                           32768         i
*>i6.6.6.6/32         6.6.6.6                  0              100            0           i
    
RP/0/0/CPU0:PE2#show bgp ipv4 unicast
Network               Next Hop                 Metric          LocPrf      Weight         Path
*>i2.2.2.2/32         2.2.2.2                  0               100           0            i
*>i4.4.4.4/32         4.4.4.4                  0               100           0            i
*> 6.6.6.6/32         0.0.0.0                  0                           32768          i
    

Task 8: Configure VRF for Customer A & B

Configure Customer A & B with AS 3 as per table below.

Customer NameVRF NameRoute-DistinguisherRoute-TargerInterface
Customer AVPNA3:13:1PE1– Ethernet 0/0
PE2 – GigabitEthernet 0/0/0/0
Customer BVPNB3:23:2PE1– Ethernet 0/1
PE2 – GigabitEthernet 0/0/0/1
PE1#configure terminal
PE1(config)#vrf definition VPNA
PE1(config-vrf)#rd 3:1
PE1(config-vrf)#address-family ipv4 unicast
PE1(config-vrf-af)#route-target both 3:1
PE1(config)#vrf definition VPNB
PE1(config-vrf)#rd 3:2
PE1(config-vrf)#address-family ipv4 unicast
PE1(config-vrf-af)#route-target both 3:2
PE1(config)#interface Ethernet 0/0
PE1(config-if)#vrf forwarding VPNA
% Interface GigabitEthernet1 IPv4 disabled and address(es) removed due to enabling VRF VPNA
PE1(config-if)#ip address 172.16.12.2 255.255.255.0
PE1(config-if)#interface Ethernet 0/1
PE1(config-if)#vrf forwarding VPNB
% Interface GigabitEthernet2 IPv4 disabled and address(es) removed due to enabling VRF VPNB
PE1(config-if)#ip address 172.16.27.2 255.255.255.0
PE1(config-if)#end
PE1#write memory
 
RP/0/0/CPU0:PE2#configure
RP/0/0/CPU0:PE2(config)#vrf VPNA
RP/0/0/CPU0:PE2(config-vrf)#address-family ipv4 unicast
RP/0/0/CPU0:PE2(config-vrf-af)#import route-target 3:1
RP/0/0/CPU0:PE2(config-vrf-af)#export route-target 3:1
RP/0/0/CPU0:PE2(config-vrf-af)#exit
RP/0/0/CPU0:PE2(config-vrf)#exit
RP/0/0/CPU0:PE2(config)#vrf VPNB
RP/0/0/CPU0:PE2(config-vrf)#address-family ipv4 unicast
RP/0/0/CPU0:PE2(config-vrf-af)#import route-target 3:2
RP/0/0/CPU0:PE2(config-vrf-af)#export route-target 3:2
RP/0/0/CPU0:PE2(config-vrf-af)#exit
RP/0/0/CPU0:PE2(config-vrf)#exit
RP/0/0/CPU0:PE2(config)#router bgp 3
RP/0/0/CPU0:PE2(config-bgp)#vrf VPNA
RP/0/0/CPU0:PE2(config-bgp-vrf)#rd 3:1
RP/0/0/CPU0:PE2(config-bgp-vrf)#exit
RP/0/0/CPU0:PE2(config-bgp)#vrf VPNB
RP/0/0/CPU0:PE2(config-bgp-vrf)#rd 3:2
RP/0/0/CPU0:PE2(config)#interface GigabitEthernet 0/0/0/0
RP/0/0/CPU0:PE2(config-if)#no ip address
RP/0/0/CPU0:PE2(config-if)#vrf VPNA
RP/0/0/CPU0:PE2(config-if)#ip address 172.16.69.6 255.255.255.0
RP/0/0/CPU0:PE2(config-if)#exit
RP/0/0/CPU0:PE2(config)#int GigabitEthernet 0/0/0/1
RP/0/0/CPU0:PE2(config-if)#no ip address
RP/0/0/CPU0:PE2(config-if)#vrf VPNB
RP/0/0/CPU0:PE2(config-if)#ip add 172.16.68.6 255.255.255.0
RP/0/0/CPU0:PE2(config-if)#commit
Sat Jun 12 02:03:19.287 UTC
RP/0/0/CPU0:PE2(config-if)#end

Task 9: Verify VRF Configuration & Connectivity

PE1#show vrf
Name                             Default RD                    Protocols   Interfaces
VPNA                             3:1                           ipv4        Gi1
VPNB                             3:2                           ipv4        Gi2
  
RP/0/0/CPU0:PE2#show vrf all
Sat Jun 12 02:06:11.065 UTC
VRF                  RD                     RT                          AFI   SAFI     
VPNA                 3:1                
                                            import  3:1                 IPV4  Unicast  
                                            export  3:1                 IPV4  Unicast  
VPNB                 3:2                
                                            import  3:2                 IPV4  Unicast  
                                            export  3:2                 IPV4  Unicast  
    
RP/0/0/CPU0:PE2#show ipv4 interface brief | inc VPN
GigabitEthernet0/0/0/0         172.16.69.6     Up              Up       VPNA    
GigabitEthernet0/0/0/1         172.16.68.6     Up              Up       VPNB

Let us also verify ping connectivity.

PE1#ping vrf VPNA 172.16.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 7/52/187 ms
PE1#
PE1#ping vrf VPNB 172.16.27.7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.27.7, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 6/72/267 ms

RP/0/0/CPU0:PE2#ping vrf VPNA 172.16.69.9
Sat Jun 12 02:10:26.538 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.69.9, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/47/219 ms

RP/0/0/CPU0:PE2#ping vrf VPNB 172.16.68.8
Sat Jun 12 02:11:04.955 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.68.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/75/359 ms

Task 10: Configure static routing between Customer and Service Provder.

All customer locations must configure default route towards Service Provider.

All PE routers must configure specific routes towards Customer Loopback interfaces.

All PE routers must redistribute static and directly connected routes into BGP vrfs.

RP/0/0/CPU0:A1#configure 
RP/0/0/CPU0:A1(config)#router static
RP/0/0/CPU0:A1(config-static)#address-family ipv4 unicast 
RP/0/0/CPU0:A1(config-static-afi)#0.0.0.0/0 172.16.12.2
RP/0/0/CPU0:A1(config-static-afi)#commit
RP/0/0/CPU0:A1(config-static-afi)#end
    
RP/0/0/CPU0:A2#configure 
RP/0/0/CPU0:A2(config)#router static
RP/0/0/CPU0:A2(config-static)#address-family ipv4 unicast 
RP/0/0/CPU0:A2(config-static-afi)#0.0.0.0/0 172.16.69.6
RP/0/0/CPU0:A2(config-static-afi)#commit
RP/0/0/CPU0:A2(config-static-afi)#end

B1#configure terminal 
B1(config)#ip route 0.0.0.0 0.0.0.0 172.16.27.2
B1(config)#end
B1#write memory 
    
B2#configure terminal 
B2(config)#ip route 0.0.0.0 0.0.0.0 172.16.68.6
B2(config)#end
B2#write memory 
    
PE1#configure terminal 
PE1(config)#ip route vrf VPNA 1.1.1.1 255.255.255.255 172.16.12.1
PE1(config)#ip route vrf VPNB 7.7.7.7 255.255.255.255 172.16.27.7
PE1(config)#router bgp 3
PE1(config-router)#address-family ipv4 vrf VPNA
PE1(config-router-af)#redistribute static 
PE1(config-router-af)#redistribute connected 
PE1(config-router)#address-family ipv4 vrf VPNB
PE1(config-router-af)#redistribute static    
PE1(config-router-af)#redistribute connected
PE1(config-router-af)#end
PE1#write memory
    
RP/0/0/CPU0:PE2#configure 
RP/0/0/CPU0:PE2(config)#router static 
RP/0/0/CPU0:PE2(config-static)#vrf VPNA
RP/0/0/CPU0:PE2(config-static-vrf)#address-family ipv4 unicast 
RP/0/0/CPU0:PE2(config-static-vrf-afi)#9.9.9.9/32 172.16.69.9
RP/0/0/CPU0:PE2(config-static-vrf-afi)#exit
RP/0/0/CPU0:PE2(config-static-vrf)#exit
RP/0/0/CPU0:PE2(config-static)#vrf VPNB
RP/0/0/CPU0:PE2(config-static-vrf)#address-family ipv4 unicast 
RP/0/0/CPU0:PE2(config-static-vrf-afi)#8.8.8.8/32 172.16.68.8      
RP/0/0/CPU0:PE2(config)#router bgp 3
RP/0/0/CPU0:PE2(config-bgp)#address-family vpnv4 unicast
RP/0/0/CPU0:PE2(config-bgp)#vrf VPNA
RP/0/0/CPU0:PE2(config-bgp-vrf)#address-family ipv4 unicast 
RP/0/0/CPU0:PE2(config-bgp-vrf-af)#redistribute static
RP/0/0/CPU0:PE2(config-bgp-vrf-af)#redistribute connected 
RP/0/0/CPU0:PE2(config-bgp-vrf-af)#vrf VPNB
RP/0/0/CPU0:PE2(config-bgp-vrf)#address-family ipv4 unicast 
RP/0/0/CPU0:PE2(config-bgp-vrf-af)#redistribute static         
RP/0/0/CPU0:PE2(config-bgp-vrf-af)#redistribute connected      
RP/0/0/CPU0:PE2(config-bgp-vrf-af)#commit
RP/0/0/CPU0:PE2(config-bgp-vrf-afi)#end
    

Task 11: Verify Static route connectivity between directly connected Service provider and Customer.

PE1#ping vrf VPNA 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/10/29 ms

PE1#ping vrf VPNB 7.7.7.7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/9/26 ms
    
RP/0/0/CPU0:PE2#ping vrf VPNA 9.9.9.9
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 9.9.9.9, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/9/29 ms

RP/0/0/CPU0:PE2#ping vrf VPNB 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/9/19 ms
    

Task 12: Configure Multi-Protoocl BGP.

Configure MP-BGP between PE1 and RR1 with RR1 being Router-reflector.

Configure MP-BGP between PE2 and RR1 with RR1 being Router-reflector.

PE1#configure terminal 
PE1(config)#router bgp 3
PE1(config-router)#address-family vpnv4 unicast 
PE1(config-router-af)#neighbor 4.4.4.4 activate 
PE1(config-router-af)#end
PE1#write memory
    
RP/0/0/CPU0:RR1#configure 
RP/0/0/CPU0:RR1(config)#router bgp 3
RP/0/0/CPU0:RR1(config-bgp)#address-family vpnv4 unicast
RP/0/0/CPU0:RR1(config-bgp)#neighbor 2.2.2.2
RP/0/0/CPU0:RR1(config-bgp-nbr)#address-family vpnv4 unicast 
RP/0/0/CPU0:RR1(config-bgp-nbr-af)#route-reflector-client 
RP/0/0/CPU0:RR1(config-bgp-nbr-af)#neighbor 6.6.6.6             
RP/0/0/CPU0:RR1(config-bgp-nbr)#address-family vpnv4 unicast 
RP/0/0/CPU0:RR1(config-bgp-nbr-af)#route-reflector-client       
RP/0/0/CPU0:RR1(config-bgp-nbr-af)#commit
RP/0/0/CPU0:RR1(config-bgp)#address-family vpnv4 unicast
RP/0/0/CPU0:RR1(config-bgp)#end
    
RP/0/0/CPU0:PE2#configure 
RP/0/0/CPU0:PE2(config)#router bgp 3
RP/0/0/CPU0:PE2(config-bgp)#address-family vpnv4 unicast 
RP/0/0/CPU0:PE2(config-bgp-af)#exit 
RP/0/0/CPU0:PE2(config-bgp)#neighbor 4.4.4.4
RP/0/0/CPU0:PE2(config-bgp-nbr)#address-family vpnv4 unicast 
RP/0/0/CPU0:PE2(config-bgp-nbr-af)#commit
RP/0/0/CPU0:PE2(config-bgp-nbr-af)#end
    

Task 13: Verify Multi-Protoocl BGP.

PE1#show bgp ipv4 unicast neighbors  | inc BGP neighbor|VPNv4
BGP neighbor is 4.4.4.4,  remote AS 3, internal link
    Address family VPNv4 Unicast: advertised and received
    For address family: VPNv4 Unicast
    
RP/0/0/CPU0:RR1#show bgp ipv4 unicast neighbors | inc "BGP neighbor|VPNv4 Uni
Sat Jun 12 02:57:22.841 UTC
BGP neighbor is 2.2.2.2
    Address family VPNv4 Unicast: advertised and received
    BGP neighbor version 15
    For Address Family: VPNv4 Unicast
    BGP neighbor version 9
BGP neighbor is 6.6.6.6
    Address family VPNv4 Unicast: advertised and received
    BGP neighbor version 15
    For Address Family: VPNv4 Unicast
    BGP neighbor version 9
    
RP/0/0/CPU0:PE2#show bgp ipv4 unicast neighbors | inc "BGP neighbor|VPNv4 Uni"
Sat Jun 12 02:57:49.973 UTC
BGP neighbor is 4.4.4.4
    Address family VPNv4 Unicast: advertised and received
    BGP neighbor version 17
    For Address Family: VPNv4 Unicast
    BGP neighbor version 19
    

Task 14: Verify Multi-Protoocl BGP route exchange

PE1#show bgp vpnv4 unicast all
Route Distinguisher: 3:1 (default for vrf VPNA)

Network          	    Next Hop              Metric  LocPrf     Weight 	Path
*>  1.1.1.1/32      	172.16.12.1	          0         	     32768 	    ? 
*>i 9.9.9.9/32      	6.6.6.6               0    	  100          0 		?
*>  172.16.12.0/24   	0.0.0.0               0         		 32768 	    ?
*>i 172.16.69.0/24   	6.6.6.6               0    	  100          0		?

Route Distinguisher: 3:2 (default for vrf VPNB)

Network          	    Next Hop              Metric  LocPrf     Weight 	Path
*>  7.7.7.7/32       	172.16.27.7           0         		 32768 	    ?
*>i 8.8.8.8/32       	6.6.6.6               0    	  100         0 		?
*>  172.16.27.0/24   	0.0.0.0               0         		 32768 	    ?
*>i 172.16.68.0/24   	6.6.6.6               0    	  100         0 		?

Task 14: Verify CE to CE connectivity within VRFs

RP/0/0/CPU0:A1#ping 172.16.69.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.69.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 19/47/119 ms
    
RP/0/0/CPU0:A1#ping 172.16.69.9
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.69.9, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 29/65/189 ms
    
RP/0/0/CPU0:A1#ping 9.9.9.9
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 9.9.9.9, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 29/41/79 ms
    
RP/0/0/CPU0:A2#ping 172.16.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 29/39/69 ms
    
RP/0/0/CPU0:A2#ping 172.16.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 19/51/129 ms
    
RP/0/0/CPU0:A2#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 29/49/99 ms
    
B1#ping 172.16.68.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.68.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 27/39/77 ms
    
B1#ping 172.16.68.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.68.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 31/46/63 ms
    
B1#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/39/64 ms
    
B2#ping 172.16.27.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.27.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 25/45/86 ms
    
B2#ping 172.16.27.7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.27.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 29/37/62 ms
    
B2#ping 7.7.7.7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/43/65 ms