EIGRP Named - Load Balancing and Variance

Load Balancing and Variance

Enhanced Interior Gateway Routing Protocol (EIGRP) Named Mode introduces a more flexible approach to load balancing and variance. In EIGRP Named Mode, load balancing is achieved through the use of named configurations, allowing for more intuitive and context-aware settings. Load balancing in EIGRP Named Mode involves the utilization of multiple equal-cost paths to a destination, distributing traffic across these paths to optimize network utilization. The variance parameter in EIGRP Named Mode remains a critical component, determining the extent to which unequal-cost paths are considered for load balancing. Network administrators can tailor load balancing behaviors by adjusting the variance value, influencing the algorithm's decision-making process. EIGRP Named Mode provides a streamlined and modernized configuration syntax, making it easier for administrators to manage load balancing and variance settings, ultimately enhancing the efficiency and performance of their IPv4 and IPv6 networks.

Lab:

Disclaimer

This Configuration Guide is designed to assist members to enhance their skills in particular technology area. While every effort has been made to ensure that all material is as complete and accurate as possible, the enclosed material is presented on an Dzas isdz basis. Neither the authors nor Forum assume any liability or responsibility to any person or entity with respect to loss or damages incurred from the information contained in this guide. This configuration guide was developed by Forum. Any similarities between material presented in this configuration guide and any other material is completely coincidental.

Cisco IOS Software, Linux Software (I86BI_LINUX-ADVENTERPRISEK9-M), Version 15.2(4)M1, DEVELOPMENT TEST SOFTWARE

Task 1: Configure EIGRP Load balancing and variance using named configuration

Step 1: Configure redundant path between two routers

R1:
interface Serial2/0
ip address 12.0.0.1 255.255.255.0
no shutdown
interface Serial2/3
ip address 21.0.0.1 255.255.255.0
no shutdown
interface loopback 1
ip address 11.0.1.1 255.255.255.0
interface loopback 2
ip address 11.0.2.1 255.255.255.0
interface loopback 3
ip address 11.0.3.1 255.255.255.0
exit
R2:
interface Ethernet0/0
ip address 23.0.0.2 255.255.255.0
no shut
interface Serial2/0
ip address 12.0.0.2 255.255.255.0
no shutdown
interface Serial2/3
ip address 43.0.0.2 255.255.255.0
no shutdown
interface loopback 1
ip address 22.0.0.2 255.255.255.0
interface loopback 2
ip address 22.0.0.2 255.255.255.0
interface loopback 3
ip address 22.0.0.2 255.255.255.0
exit
R3:
interface Ethernet0/0
ip address 23.0.0.3 255.255.255.0
no shutdown
interface Serial2/0
ip address 34.0.0.3 255.255.255.0
no shutdown
interface Serial2/3
ip address 21.0.0.3 255.255.255.0
no shutdown
interface loopback 1
ip address 33.0.1.3 255.255.255.0
interface loopback 2
ip address 33.0.2.3 255.255.255.0
interface loopback 3
ip address 33.0.3.3 255.255.255.0
exit

R4:
interface Serial2/3
ip address 43.0.0.4 255.255.255.0
no shutdown
interface Serial2/0
ip address 34.0.0.4 255.255.255.0
no shutdown
interface loopback 1
ip address 44.0.1.4 255.255.255.0
interface loopback 2
ip address 44.0.2.4 255.255.255.0
interface loopback 3
ip address 44.0.3.4 255.255.255.0
exit

Step 2: Configure EIGRP to learn routes over multiple paths

R1:
router eigrp cisco
address-family ipv4 autonomous-system 100
network 11.0.1.1 0.0.0.0
network 11.0.2.1 0.0.0.0
network 11.0.3.1 0.0.0.0
network 12.0.0.1 0.0.0.0
network 21.0.0.1 0.0.0.0
exit

R2:
router eigrp cisco
address-family ipv4 autonomous-system 100
network 12.0.0.2 0.0.0.0
network 22.0.1.2 0.0.0.0
network 22.0.2.2 0.0.0.0
network 22.0.3.2 0.0.0.0
network 23.0.0.2 0.0.0.0
network 43.0.0.2 0.0.0.0
exit

R3:
router eigrp cisco
address-family ipv4 autonomous-system 100
network 21.0.0.3 0.0.0.0
network 23.0.0.3 0.0.0.0
network 33.0.1.3 0.0.0.0
network 33.0.2.3 0.0.0.0
network 33.0.3.3 0.0.0.0
network 34.0.0.3 0.0.0.0
exit
R4:
router eigrp cisco
address-family ipv4 autonomous-system 100
network 34.0.0.4 0.0.0.0
network 43.0.0.4 0.0.0.0
network 44.0.1.4 0.0.0.0
network 44.0.2.4 0.0.0.0
network 44.0.3.4 0.0.0.0
exit

Step 3: Verify that routes are learnt from multiple path

R2#show ip eigrp topology
EIGRP-IPv4 VR(cisco) Topology Table for AS(100)/ID(22.0.3.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 11.0.1.0/24, 1 successors, FD is 1735257878
        via 12.0.0.1 (1735257878/163840), Serial2/0
P 11.0.2.0/24, 1 successors, FD is 1735257878
        via 12.0.0.1 (1735257878/163840), Serial2/0
P 11.0.3.0/24, 1 successors, FD is 1735257878
        via 12.0.0.1 (1735257878/163840), Serial2/0
P 12.0.0.0/24, 1 successors, FD is 1735175958
        via Connected, Serial2/0
P 21.0.0.0/24, 1 successors, FD is 1800711958
        via 23.0.0.3 (1800711958/1735175958), Ethernet0/0
        via 12.0.0.1 (3045895958/1735175958), Serial2/0
P 22.0.1.0/24, 1 successors, FD is 163840	
        via Connected, Loopback1
P 22.0.2.0/24, 1 successors, FD is 163840
        via Connected, Loopback2
P 22.0.3.0/24, 1 successors, FD is 163840
        via Connected, Loopback3
P 23.0.0.0/24, 1 successors, FD is 131072000
        via Connected, Ethernet0/0
P 33.0.1.0/24, 1 successors, FD is 131153920
        via 23.0.0.3 (131153920/163840), Ethernet0/0
P 33.0.2.0/24, 1 successors, FD is 131153920
        via 23.0.0.3 (131153920/163840), Ethernet0/0
P 33.0.3.0/24, 1 successors, FD is 131153920
        via 23.0.0.3 (131153920/163840), Ethernet0/0
P 34.0.0.0/24, 1 successors, FD is 1800711958
        via 23.0.0.3 (1800711958/1735175958), Ethernet0/0
        via 43.0.0.4 (3045895958/1735175958), Serial2/3
P 43.0.0.0/24, 1 successors, FD is 1735175958
        via Connected, Serial2/3
P 44.0.1.0/24, 1 successors, FD is 1735257878
        via 43.0.0.4 (1735257878/163840), Serial2/3
P 44.0.2.0/24, 1 successors, FD is 1735257878
        via 43.0.0.4 (1735257878/163840), Serial2/3
P 44.0.3.0/24, 1 successors, FD is 1735257878
        via 43.0.0.4 (1735257878/163840), Serial2/3

Step 4: Analyze topology table and verify rules of DUAL

Rules of Diffusion Algorithm (DUAL)

  1. For a path to become Feasible Successor (FS) its Advertise Distance (AD) should be less than current Feasible Distance (FD)

        FS = AD < current FD
    

Example:

P 34.0.0.0/24, 1 successors, FD is 1800711958
        via 23.0.0.3 (1800711958/1735175958), Ethernet0/0
        via 43.0.0.4 (3045895958/1735175958), Serial2/3

FS = 1735175958< 1800711958 In router 1 topology table path to reach 34.0.0.0 there are two path via 23.0.0.3 & 43.0.0.4 both are feasible successor because their AD 1735175958 is less than current FD 1800711958

  1. For a path to be even consider as a valid path its AD should be less than 2 times current FD.

Valid path = AD < 2*current FD

Example:

P 21.0.0.0/24, 1 successors, FD is 1800711958
        via 23.0.0.3 (1800711958/1735175958), Ethernet0/0
        via 12.0.0.1 (3045895958/1735175958), Serial2/0

Valid path = 1735175958 <2*1800711958

A routers topology table shows only valid path. Here both the path to reach 33.0.1.0 are valid path because their AD 1735175958 is less than 2*1800711958 = 3601423916

Step 5: Verify that only best routes are reflecting in routing table

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      11.0.0.0/24 is subnetted, 3 subnets
D        11.0.1.0 [90/13556702] via 12.0.0.1, 00:17:35, Serial2/0
D        11.0.2.0 [90/13556702] via 12.0.0.1, 00:17:35, Serial2/0
D        11.0.3.0 [90/13556702] via 12.0.0.1, 00:17:35, Serial2/0
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.0.0.0/24 is directly connected, Serial2/0
L        12.0.0.2/32 is directly connected, Serial2/0
      21.0.0.0/24 is subnetted, 1 subnets
D        21.0.0.0 [90/14068062] via 23.0.0.3, 00:17:35, Ethernet0/0
      22.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C        22.0.1.0/24 is directly connected, Loopback1
L        22.0.1.2/32 is directly connected, Loopback1
C        22.0.2.0/24 is directly connected, Loopback2
L        22.0.2.2/32 is directly connected, Loopback2
C        22.0.3.0/24 is directly connected, Loopback3
L        22.0.3.2/32 is directly connected, Loopback3
      23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        23.0.0.0/24 is directly connected, Ethernet0/0
L        23.0.0.2/32 is directly connected, Ethernet0/0
      33.0.0.0/24 is subnetted, 3 subnets
D        33.0.1.0 [90/1024640] via 23.0.0.3, 00:17:35, Ethernet0/0
D        33.0.2.0 [90/1024640] via 23.0.0.3, 00:17:35, Ethernet0/0
D        33.0.3.0 [90/1024640] via 23.0.0.3, 00:17:35, Ethernet0/0
      34.0.0.0/24 is subnetted, 1 subnets
D        34.0.0.0 [90/14068062] via 23.0.0.3, 00:17:35, Ethernet0/0
      43.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        43.0.0.0/24 is directly connected, Serial2/3
L        43.0.0.2/32 is directly connected, Serial2/3
      44.0.0.0/24 is subnetted, 3 subnets
D        44.0.1.0 [90/13556702] via 43.0.0.4, 00:17:35, Serial2/3
D        44.0.2.0 [90/13556702] via 43.0.0.4, 00:17:35, Serial2/3
D        44.0.3.0 [90/13556702] via 43.0.0.4, 00:17:35, Serial2/3

Step 6: Enter topology base mode for manipulation set & configure variance command in EIGRP process

R2:
router eigrp cisco
address-family ipv4 autonomous-system 100
topology base
variance 2
exit

Step 7: Verify that multiple path are reflecting in routers routing table

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      11.0.0.0/24 is subnetted, 3 subnets
D        11.0.1.0 [90/14068702] via 23.0.0.3, 00:05:37, Ethernet0/0
                  [90/13556702] via 12.0.0.1, 00:05:37, Serial2/0
D        11.0.2.0 [90/14068702] via 23.0.0.3, 00:05:37, Ethernet0/0
                  [90/13556702] via 12.0.0.1, 00:05:37, Serial2/0
D        11.0.3.0 [90/14068702] via 23.0.0.3, 00:05:37, Ethernet0/0
                  [90/13556702] via 12.0.0.1, 00:05:37, Serial2/0
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.0.0.0/24 is directly connected, Serial2/0
L        12.0.0.2/32 is directly connected, Serial2/0
      21.0.0.0/24 is subnetted, 1 subnets
D        21.0.0.0 [90/14068062] via 23.0.0.3, 00:05:37, Ethernet0/0
                  [90/23796062] via 12.0.0.1, 00:05:37, Serial2/0
      22.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C        22.0.1.0/24 is directly connected, Loopback1
L        22.0.1.2/32 is directly connected, Loopback1
C        22.0.2.0/24 is directly connected, Loopback2
L        22.0.2.2/32 is directly connected, Loopback2
C        22.0.3.0/24 is directly connected, Loopback3
L        22.0.3.2/32 is directly connected, Loopback3
      23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        23.0.0.0/24 is directly connected, Ethernet0/0
L        23.0.0.2/32 is directly connected, Ethernet0/0
      33.0.0.0/24 is subnetted, 3 subnets
D        33.0.1.0 [90/1024640] via 23.0.0.3, 00:05:37, Ethernet0/0
D        33.0.2.0 [90/1024640] via 23.0.0.3, 00:05:37, Ethernet0/0
D        33.0.3.0 [90/1024640] via 23.0.0.3, 00:05:37, Ethernet0/0
      34.0.0.0/24 is subnetted, 1 subnets
D        34.0.0.0 [90/23796062] via 43.0.0.4, 00:05:37, Serial2/3
                            [90/14068062] via 23.0.0.3, 00:05:37, Ethernet0/0
      43.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        43.0.0.0/24 is directly connected, Serial2/3
L        43.0.0.2/32 is directly connected, Serial2/3
      44.0.0.0/24 is subnetted, 3 subnets
D        44.0.1.0 [90/13556702] via 43.0.0.4, 00:05:37, Serial2/3
                           [90/14068702] via 23.0.0.3, 00:05:37, Ethernet0/0
D        44.0.2.0 [90/13556702] via 43.0.0.4, 00:05:37, Serial2/3
                           [90/14068702] via 23.0.0.3, 00:05:37, Ethernet0/0
D        44.0.3.0 [90/13556702] via 43.0.0.4, 00:05:37, Serial2/3
                           [90/14068702] via 23.0.0.3, 00:05:37, Ethernet0/0