BGP IPv6 - Initial Configuration

Initial Configuration

The initial configuration of BGP (Border Gateway Protocol) for IPv6 involves setting up essential parameters to establish BGP routing within a network. Key aspects of the initial configuration include defining the router's Autonomous System (AS) number, configuring BGP neighbors by specifying their IPv6 addresses and AS numbers, and determining which IPv6 networks will be advertised to BGP peers. Administrators may also set attributes such as the BGP router ID, timers, and policies to influence BGP behavior. Proper configuration ensures that BGP routers can form peer relationships, exchange IPv6 routing information, and participate in the BGP routing process. Additionally, careful consideration of route filtering and network advertisements during the initial setup is crucial to ensure optimal routing and network stability. The BGP IPv6 initial configuration serves as the foundation for a well-functioning BGP routing environment, allowing administrators to tailor settings based on the specific requirements and policies of their IPv6 network.

Lab:

Disclaimer This Configuration Guide is designed to assist members to enhance their skills in particular technology area. While every effort has been made to ensure that all material is as complete and accurate as possible, the enclosed material is presented on an “as is” basis. Neither the authors nor Forum assume any liability or responsibility to any person or entity with respect to loss or damages incurred from the information contained in this guide. This configuration guide was developed by Forum. Any similarities between material presented in this configuration guide and any other material is completely coincidental. Cisco IOS Software, Linux Software (I86BI_LINUX-ADVENTERPRISEK9-M), Version 15.2(4)M1, DEVELOPMENT TEST SOFTWARE

Task 1: Configure IPv6 BGP process for Autonomous

Step 1: In the configuration mode of router configure IPv6 BGP Process by following command:

R1:
router bgp 65100				                            //initiate BGP process for AS 65100
neighbor 22:0:1::2 remote-as 65000		                    //creates a IPv6 BGP peer group
neighbor 22:0:1::2 ebgp-multihop 5
neighbor 22:0:1::2 update- loopback 1		                //to form loopback  to loopback indirect peering
address-family ipv6				                            //enable address family IPv6	
neighbor 22:0:1::2 activate			                        //Enables the exchange of information with a IPv6 BGP 
neighbor 22:0:1::2 soft-reconfiguration inbound  neighboring router
exit

R2:
router bgp 65000
neighbor 11:0:1::1 remote-as 65100
neighbor 11:0:1::1 ebgp-multihop 5		                //IPv6 BGP connections to external peers residing
neighbor 11:0:1::1 update-source loopback 1	on networks that are not directly connected
neighbor 33:0:1::3 remote-as 65000
neighbor 33:0:1::3 update-source loopback 1
address-family ipv6
neighbor 11:0:1::1 activate
neighbor 11:0:1::1 soft-reconfiguration inbound	       //to store fresh incoming updated from neighbor
neighbor 33:0:1::3 activate
neighbor 33:0:1::3 soft-reconfiguration inbound
exit
R3:
router bgp 65000
neighbor 44:0:1::4 remote-as 65200
neighbor 44:0:1::4 ebgp-multihop 5
neighbor 44:0:1::4 update-source loopback 1
neighbor 22:0:1::2 remote-as 65000
neighbor 22:0:1::2 update-source loopback 1
address-family ipv6
neighbor 44:0:1::4 activate
neighbor 44:0:1::4 soft-reconfiguration inbound
neighbor 22:0:1::2 activate
neighbor 22:0:1::2 soft-reconfiguration inbound
exit
R4:
router bgp 65200
neighbor 33:0:1::3 remote-as 65000
neighbor 33:0:1::3 ebgp-multihop 5
neighbor 33:0:1::3 update-source loopback 1
address-family ipv6
neighbor 33:0:1::3 activate
neighbor 33:0:1::3 soft-reconfiguration inbound
exit

Step 2: In the configuration mode of router configure IPv4 OSPF Process by following command:

R1:
ipv6 router ospf 1		//initiate IPv6 OSPF process with process id 1
interface serial 2/0
ipv6 ospf 1 area 0		
interface loopback 1
ipv6 ospf 1 area 0
interface loopback 2
ipv6 ospf 1 area 0
interface loopback 3
ipv6 ospf 1 area 0
exit
R2:
ipv6 router ospf 1
interface serial 2/0
ipv6 ospf 1 area 0
interface ethernet 0/0
ipv6 ospf 1 area 0
interface loopback 1
ipv6 ospf 1 area 0
interface loopback 2
ipv6 ospf 1 area 0
interface loopback 3
ipv6 ospf 1 area 0
exit
R3:
ipv6 router ospf 1
interface serial2/0
ipv6 ospf 1 area 0
interface ethernet 0/0
ipv6 ospf 1 area 0
interface loopback 1
ipv6 ospf 1 area 0
interface loopback 2
ipv6 ospf 1 area 0
interface loopback 3
ipv6 ospf 1 area 0
exit
R4:
ipv6 router ospf 1
interface serial 2/0
ipv6 ospf 1 area 0
interface loopback 1
ipv6 ospf 1 area 0
interface loopback 2
ipv6 ospf 1 area 0
interface loopback 3
ipv6 ospf 1 area 0
exit

Step 3: Announce the network in BGP Process

R1:
router bgp 65100
address-family ipv6		     //enable address family for IPv6 BGP
network 11:0:1::0/64		//announce the network in BGP process
network 11:0:2::0/64
network 11:0:3::0/64
exit
R2:
router bgp 65000
address-family ipv6
network 22:0:1::0/64
network 22:0:2::0/64
network 22:0:3::0/64
exit
R3:
router bgp 65000
address-family ipv6
network 33:0:1::0/64
network 33:0:2::0/64
network 33:0:3::0/64
exit
R4:
router bgp 65200
address-family ipv6
network 44:0:1::0/64
network 44:0:2::0/64
network 44:0:3::0/64
exit

Task 2: Verification

Step 1: Verify IPv6 OSPF routes by following command:

R2#show ipv6 route
//shows router’s routing table and IPv6 routes entries
	IPv6 Routing Table - default - 30 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, l - LISP
B   11:0:1::/64 [20/0]
     via 11:0:1::1
O   11:0:1::1/128 [110/64]
     via FE80::A8BB:CCFF:FE00:100, Serial2/0
B   11:0:2::/64 [20/0]
     via 11:0:1::1
O   11:0:2::1/128 [110/64]
     via FE80::A8BB:CCFF:FE00:100, Serial2/0
B   11:0:3::/64 [20/0]
     via 11:0:1::1
O   11:0:3::1/128 [110/64]
     via FE80::A8BB:CCFF:FE00:100, Serial2/0
C   12::/64 [0/0]
     via Serial2/0, directly connected
L   12::A8BB:CCFF:FE00:200/128 [0/0]
     via Serial2/0, receive
C   22:0:1::/64 [0/0]
     via Loopback1, directly connected
L   22:0:1::2/128 [0/0]
     via Loopback1, receive
C   22:0:2::/64 [0/0]
     via Loopback2, directly connected
L   22:0:2::2/128 [0/0]
     via Loopback2, receive
C   22:0:3::/64 [0/0]
     via Loopback3, directly connected
L   22:0:3::2/128 [0/0]
     via Loopback3, receive
C   23::/64 [0/0]
     via Ethernet0/0, directly connected
L   23::A8BB:CCFF:FE00:200/128 [0/0]
     via Ethernet0/0, receive
B   33:0:1::/64 [200/0]
     via 33:0:1::3
O   33:0:1::3/128 [110/10]
     via FE80::A8BB:CCFF:FE00:300, Ethernet0/0
B   33:0:2::/64 [200/0]
     via 33:0:1::3
O   33:0:2::3/128 [110/10]
     via FE80::A8BB:CCFF:FE00:300, Ethernet0/0
B   33:0:3::/64 [200/0]
     via 33:0:1::3
O   33:0:3::3/128 [110/10]
     via FE80::A8BB:CCFF:FE00:300, Ethernet0/0
O   34::/64 [110/74]
     via FE80::A8BB:CCFF:FE00:300, Ethernet0/0
B   44:0:1::/64 [200/0]
     via 44:0:1::4
O   44:0:1::4/128 [110/74]
     via FE80::A8BB:CCFF:FE00:300, Ethernet0/0
B   44:0:2::/64 [200/0]
     via 44:0:1::4
O   44:0:2::4/128 [110/74]
     via FE80::A8BB:CCFF:FE00:300, Ethernet0/0
B   44:0:3::/64 [200/0]
     via 44:0:1::4
O   44:0:3::4/128 [110/74]
     via FE80::A8BB:CCFF:FE00:300, Ethernet0/0
L   FF00::/8 [0/0]
     via Null0, receive

Step 2: Verify IPv6 BGP neighborship and its details by following command:

BGP neighbor states:
1.	Idle – TCP connectivity issue
2.	Active – Command configuration issue
3.	Established – TCP connectivity established

R2#show bgp ipv6 unicast neighbor
//shows details of IPv6bgp neighbor
BGP version 4, remote router ID 11.0.3.1
BGP state = Established, up for 01:41:39
Last read 00:00:45, last write 00:00:17, hold time is 180, keepalive interval is 60 seconds
Neighbor sessions:
1 active, is not multisession capable (disabled)
Neighbor capabilities:
Route refresh: advertised and received(new)
Four-octets ASN Capability: advertised and received
Address family IPv6 Unicast: advertised and received
Enhanced Refresh Capability: advertised and received
----------------Output Omitted------------------


BGP neighbor is 33:0:1::3,  remote AS 65000, internal link
BGP version 4, remote router ID 33.0.3.3
BGP state = Established, up for 01:40:27
Last read 00:00:33, last write 00:00:19, hold time is 180, keepalive interval
is 60 seconds
Neighbor sessions:
1 active, is not multisession capable (disabled)
Neighbor capabilities:
Route refresh: advertised and received(new)
Four-octets ASN Capability: advertised and received
Address family IPv4 Unicast: received
Address family IPv6 Unicast: advertised and received
Enhanced Refresh Capability: advertised and received
----------------Output Omitted------------------

Step 3: Verify IPv6 BGP routes and its details by following command:

R2#show bgp ipv6 unicast
//shows IPv6 BGP table where “>” shows best path.
BGP table version is 13, local router ID is 22.0.3.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop        Metric    LocPrf    Weight   Path
 *>  11:0:1::/64      11:0:1::1         0             	   0       65100 i
 *>  11:0:2::/64      11:0:1::1         0                  0       65100 i
 *>  11:0:3::/64      11:0:1::1         0                  0       65100 i
 *>  22:0:1::/64      ::                0                  32768     i
 *>  22:0:2::/64      ::                0                  32768     i
 *>  22:0:3::/64      ::                0                  32768     i
 *>i 33:0:1::/64      33:0:1::3         0     	  100      0         i
 *>i 33:0:2::/64      33:0:1::3         0         100      0         i
 *>i 33:0:3::/64      33:0:1::3         0         100      0         i
 *>i 44:0:1::/64      44:0:1::4         0         100      0       65200 i
 *>i 44:0:2::/64      44:0:1::4         0         100      0       65200 i
 *>i 44:0:3::/64      44:0:1::4         0         100      0       65200 i