BGP IPv6 - Default Route

Default Route

BGP (Border Gateway Protocol) IPv6 Default Route plays a crucial role in efficiently directing IPv6 traffic within a network. It serves as a strategic routing decision, providing a default path for data packets when no specific route matches their destination. This simplifies routing tables, enhances network scalability, and ensures smoother traffic flow in IPv6-enabled environments. By carefully configuring and managing the BGP IPv6 Default Route, network administrators can optimize routing behaviors and contribute to the overall performance and reliability of their IPv6 networks.

Lab:

BGP Topology

Task 1: Configure IPv6 BGP Process for Autonomous

Step 1: In the configuration mode of router configure IPv6 BGP Process by following command:

R1: 
interface Ethernet0/0
ipv6 address 12::1/64
no shutdown
exit

ipv6 route 33:0:1::3/64 12::2
ipv6 route 33:0:2::3/64 12::2
ipv6 route 33:0:3::3/64 12::2
ipv6 route 44:0:1::4/64 12::2
ipv6 route 44:0:2::4/64 12::2
ipv6 route 44:0:3::4/64 12::2
exit

R2: 
interface Ethernet0/0
ipv6 address 12::2/64
no shutdown
interface Ethernet0/1
ipv6 address 23::2/64
no shutdown 
interface Ethernet0/2
ipv6 address 24::2/64
no shutdown

ipv6 route ::/0 12::1

ipv6 unicast-routing
ipv6 router ospf 1
router-id 2.2.2.2
interface Ethernet0/1
ipv6 ospf 1 area 0
interface Ethernet0/2
ipv6 ospf 1 area 0
exit

router bgp 65000
bgp router-id 2.2.2.2
neighbor 23::3 remote-as 65000
neighbor 24::4 remote-as 65200
address-family ipv6 
neighbor 23::3 activate
neighbor 24::4 activate
exit

R3: 
interface Ethernet0/0
ipv6 address 23::3/64
no shutdown
interface Loopback1
ipv6 address 33:0:1::3/64
interface Loopback2 
ipv6 address 33:0:2::3/64
interface Loopback3
ipv6 address 33:0:3::3/64
exit

ipv6 unicast-routing
ipv6 router ospf 1
router-id 3.3.3.3
interface Ethernet0/0
ipv6 ospf 1 area 0
exit

router bgp 65000
bgp router-id 3.3.3.3
neighbor 23::2 remote-as 65000
address-family ipv6
network 33:0:1::0/64 
network 33:0:2::0/64 
network 33:0:3::0/64 
neighbor 23::2 activate
exit

R4:
interface Ethernet 0/0
ipv6 address 24::4/64
no shutdown
interface Loopback1
ipv6 address 44:0:1::4/64
interface Loopback2
ipv6 address 44:0:2::4/64
interface Loopback3
ipv6 address 44:0:3::4/64
exit

ipv6 unicast-routing
ipv6 router ospf 1
router-id 4.4.4.4
interface Ethernet0/0
ipv6 ospf 1 area 0
exit

router bgp 65200
bgp router-id 4.4.4.4
neighbor 24::2 remote-as 65000
address-family ipv6
network 44:0:1::0/64
network 44:0:2::0/64
network 44:0:3::0/64
neighbor 24::2 activate
exit

Step 2: Verify IPv6 BGP routes by following command

R2 is learning the loopbacks from R3 and R4. 
R2#show bgp ipv6 unicast
BGP table version is 7, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop       Metric 	LocPrf     Weight 	  Path
 *>i 33:0:1::/64      23::3            0    	100      	0 	       i
 *>i 33:0:2::/64      23::3            0    	100      	0 	       i
 *>i 33:0:3::/64      23::3            0    	100      	0 	       i
 *>  44:0:1::/64      24::4            0             	    0 	     65200 i
 *>  44:0:2::/64      24::4            0             	    0 	     65200 i
 *>  44:0:3::/64      24::4            0             	    0 	     65200 i

R2 has a default route towards R1.
The goal is to announce default route in BGP. Redistribute static should be
enough to announce the default route.


R2(config)#router bgp 65000
R2(config-router)address-family ipv6
R2(config-router-af)#redistribute static

R4#show bgp ipv6 unicast
BGP table version is 7, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop      Metric  	LocPrf	    Weight  	Path
 *>  33:0:1::/64      24::2                                   0 	    65000 i
 *>  33:0:2::/64      24::2                                   0 	    65000 i
 *>  33:0:3::/64      24::2                                   0 	    65000 i
 *>  44:0:1::/64      ::              0         		    32768      	i
 *>  44:0:2::/64      ::              0         		    32768      	i
 *>  44:0:3::/64      ::              0         		    32768      	i

 Is it in the BGP RIB of R2?

R2#show bgp ipv6 unicast
BGP table version is 7, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop      Metric      LocPrf   	Weight  	Path
 *>i 33:0:1::/64      23::3           0       	100      	  0 	      i
 *>i 33:0:2::/64      23::3           0       	100      	  0 	      i
 *>i 33:0:3::/64      23::3           0       	100      	  0 	      i
 *>  44:0:1::/64      24::4           0             	      0 	   65200 i
 *>  44:0:2::/64      24::4           0             	      0 	   65200 i
 *>  44:0:3::/64      24::4           0             	      0 	   65200 i

It is not. BGP does not redistribute a static default route unless the
default-information command is used. This protects against someone accidentally
redistributing a default route in BGP which could potentially be disastrous.

R2(config)#router bgp 65000
R2(config-router)#address-family ipv6
R2(config-router)#default-information originate
R2(config-router)#exit

R2#show bgp ipv6 unicast
BGP table version is 8, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop       Metric 	LocPrf  	Weight 	   Path
 *>  ::/0             12::1            0         	        32768   	?
 *>i 33:0:1::/64      23::3            0    	100      	0       	i
 *>i 33:0:2::/64      23::3            0    	100      	0 	        i
 *>i 33:0:3::/64      23::3            0    	100      	0 	        i
 *>  44:0:1::/64      24::4            0             	    0	      65200 i
 *>  44:0:2::/64      24::4            0             	    0	      65200 i
 *>  44:0:3::/64      24::4            0             	    0 	      65200 i
R3#show bgp ipv6 unicast
BGP table version is 7, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop       Metric 	LocPrf 	  Weight 	Path
 *>i ::/0             12::1            0    	100      	0 	     ?
 *>  33:0:1::/64      ::               0         	      32768 	 i
 *>  33:0:2::/64      ::               0         	      32768 	 i
 *>  33:0:3::/64      ::               0         	      32768 	 i
 *>i 44:0:1::/64      24::4            0        100      	0 	   65200 i
 *>i 44:0:2::/64      24::4            0        100      	0 	   65200 i
 *>i 44:0:3::/64      24::4            0        100      	0 	   65200 i


R4#show bgp ipv6 unicast
BGP table version is 8, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop       Metric 	LocPrf  	Weight  	Path
 *>  ::/0             24::2            0                      0 	    65000 ?
 *>  33:0:1::/64      24::2                                   0 	    65000 i
 *>  33:0:2::/64      24::2                                   0 	    65000 i
 *>  33:0:3::/64      24::2                                   0 	    65000 i
 *>  44:0:1::/64      ::               0         	        32768      	i
 *>  44:0:2::/64      ::               0         	        32768      	i
 *>  44:0:3::/64      ::               0         	        32768      	i

Task 2: Configure IPv6 Default Route in BGP using OSPF

Step 1: In the configuration mode of router configure IPv6 default route by following command:

R2:
router bgp 65000
address-family ipv6
no redistribute static
exit
no ipv6 route ::/0 12::1
interface Ethernet0/0
ipv6 ospf 1 area 0
exit

R1:
ipv6 unicast-routing
ipv6 router ospf 1
router-id 1.1.1.1
interface Ethernet0/0
ipv6 ospf 1 area 0
exit

ipv6 router ospf 1
default-information originate always
exit

Step 2: Verify IPv6 OSPF routes by following command:

There is now a default route learned via Ipv6 OSPF

R2#show ipv6 route ospf
IPv6 Routing Table - default - 14 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, l - LISP
OE2 ::/0 [110/1], tag 1
     via FE80::A8BB:CCFF:FE00:100, Ethernet0/0

Step 3: In the configuration mode of router redistribute OSPF into BGP

R2:
router bgp 65000
address-family ipv6
redistribute ospf 1 match external
exit

R2#show bgp ipv6 unicast
BGP table version is 16, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop      Metric  	LocPrf  	Weight  	Path
 *>  ::/0             ::              1         	        32768      	?
 *>i 33:0:1::/64      23::3           0        	100      	0        	i
 *>i 33:0:2::/64      23::3           0        	100      	0        	i
 *>i 33:0:3::/64      23::3           0        	100      	0        	i
 *>  44:0:1::/64      24::4           0             	    0 	        65200 i
 *>  44:0:2::/64      24::4           0             	    0 	        65200 i
 *>  44:0:3::/64      24::4           0             	    0 	        65200 i

R3#show bgp ipv6 unicast
BGP table version is 9, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop      Metric      LocPrf   	Weight   	Path
 *>i ::/0             23::2           1        	 100      	0 	        ?
 *>  33:0:1::/64      ::              0         	        32768      	i
 *>  33:0:2::/64      ::              0         	        32768      	i
 *>  33:0:3::/64      ::              0         	        32768      	i
 *>i 44:0:1::/64      24::4           0    	     100      	0 	        65200 i
 *>i 44:0:2::/64      24::4           0    	     100      	0 	        65200 i
 *>i 44:0:3::/64      24::4           0    	     100      	0 	        65200 i


R4#show bgp ipv6 unicast
BGP table version is 22, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop       Metric 	LocPrf 	    Weight  	Path
 *>  ::/0             24::2            1          0 		            65000 ?
 *>  33:0:1::/64      24::2                       0 		            65000 i
 *>  33:0:2::/64      24::2                       0 		            65000 i
 *>  33:0:3::/64      24::2                       0 		            65000 i
 *>  44:0:1::/64      ::               0         	        32768 	i
 *>  44:0:2::/64      ::               0         	        32768 	i
 *>  44:0:3::/64      ::               0         	        32768 	i

Thus Default Route in BGP can be spread using static as well as IGP protocols