BGP IPv6 - Summarization

Summarization

BGP (Border Gateway Protocol) IPv6 summarization is a technique employed to streamline the representation of routing information within BGP networks. This process involves aggregating multiple IPv6 prefixes into a more condensed summary route. IPv6 summarization in BGP helps address scalability challenges by reducing the size and complexity of routing tables. By presenting a summarized view of the network's topology, routers can optimize memory usage and enhance the efficiency of BGP routing operations. However, careful consideration is needed during summarization to ensure that the aggregated prefixes accurately represent the underlying subnets and avoid unnecessary loss of routing details. Proper implementation of IPv6 summarization in BGP contributes to a more scalable, manageable, and streamlined routing infrastructure, particularly crucial in networks with a large number of IPv6 prefixes.

Lab:

Disclaimer

This Configuration Guide is designed to assist members to enhance their skills in particular technology area. While every effort has been made to ensure that all material is as complete and accurate as possible, the enclosed material is presented on an “as is” basis. Neither the authors nor Forum assume any liability or responsibility to any person or entity with respect to loss or damages incurred from the information contained in this guide. This configuration guide was developed by Forum. Any similarities between material presented in this configuration guide and any other material is completely coincidental.

Cisco IOS Software, Linux Software (I86BI_LINUX-ADVENTERPRISEK9-M), Version 15.2(4)M1, DEVELOPMENT TEST SOFTWARE

Task 1: Configure IPv6 BGP Summarization

Step 1: In the configuration mode of router configure loopbacks with network address in sequence

R1:
interface  loopback 1
ip address 11:0:1::2/64
interface loopback 2
ip address 11:0:2::2/64
interface loopback 3
ip address 11:0:3::2/64
exit

Step 2: Summarize BGP routes in router mode

R1:
router bgp 65100
address-family ipv6
aggregate-address 11::/16
exit

Step 3: Verify receipt of summary route in other router’s BGP table by following command:

R2# clear bgp ipv6 * soft
//it will flush the bgp table and will learn fresh route.
R2#show bgp ipv6 unicast
BGP table version is 14, local router ID is 22.0.3.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete
     Network          Next Hop        Metric      LocPrf     Weight    Path
 *>  11::/16          11:0:1::1         0                       0      65100 i
 *>  11:0:1::/64      11:0:1::1         0                       0      65100 i
 *>  11:0:2::/64      11:0:1::1         0                       0      65100 i
 *>  11:0:3::/64      11:0:1::1         0                       0      65100 i
 *>  22:0:1::/64      ::                0                     32768    i
 *>  22:0:2::/64      ::                0                     32768    i
 *>  22:0:3::/64      ::                0                     32768    i
 *>i 33:0:1::/64      33:0:1::3         0          100         0       i
 *>i 33:0:2::/64      33:0:1::3         0          100         0       i
 *>i 33:0:3::/64      33:0:1::3         0          100         0       i
 *>i 44:0:1::/64      44:0:1::4         0          100         0      65200 i
 *>i 44:0:2::/64      44:0:1::4         0          100         0      65200 i
 *>i 44:0:3::/64      44:0:1::4         0          100         0      65200 i

R4# clear bgp ipv6 * soft


	R4#show bgp ipv6 unicast
BGP table version is 62, local router ID is 44.0.3.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop      Metric    LocPrf    Weight    Path
*> 11::/16          33:0:1::3                           0 	    65000 65100 i
*> 11:0:1::/64      33:0:1::3                           0	    65000 65100 i
*> 11:0:2::/64      33:0:1::3                           0	    65000 65100 i
*> 11:0:3::/64      33:0:1::3                           0	    65000 65100 i
*> 22:0:1::/64      33:0:1::3                           0	    65000 i
*> 22:0:2::/64      33:0:1::3                           0	    65000 i
*> 22:0:3::/64      33:0:1::3                           0	    65000 i
*> 33:0:1::/64      33:0:1::3        0  	            0 	    65000 i
*> 33:0:2::/64      33:0:1::3        0                  0 	    65000 i
*> 33:0:3::/64      33:0:1::3        0            	    0       65000 i
*> 44:0:1::/64       0.0.0.0         0         	      32768    i
*> 44:0:2::/64       0.0.0.0         0    		      32768    i
*> 44:0:3::/64       0.0.0.0         0       	      32768    i

If BGP will send only summary route of an network then the router which is sending summary route will stripped off all previous AS-tag and will send summarized route with fresh originating router, this will lead to Loops in BGP. To avoid loops, BGP send summarized as well as Individual routes to other routers.

Step 4: Configure Summarize only BGP routes in router mode

R3:
router bgp 65000
address-family ipv6
aggregate-address 11::/16 summary-only
exit	

Step 5: Verify receipt of summary route in other router’s BGP table by following command

R4# clear bgp ipv6 * soft

	R4#show bgp ipv6 unicast
BGP table version is 19, local router ID is 44.0.3.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network       Next Hop            Metric    LocPrf    Weight    Path
 *>  11::/16       33:0:1::3            0  		           0	    65000 i
 *>  22:0:1::/64   33:0:1::3                               0	    65000 i
 *>  22:0:2::/64   33:0:1::3                               0	    65000 i
 *>  22:0:3::/64   33:0:1::3                               0	    65000 i
 *>  33:0:1::/64   33:0:1::3            0             	   0	    65000 i
 *>  33:0:2::/64   33:0:1::3            0                  0	    65000 i
 *>  33:0:3::/64   33:0:1::3            0             	   0	    65000 i
 *>  44:0:1::/64      ::                0	             32768      i
 *>  44:0:2::/64      ::                0         	     32768      i
 *>  44:0:3::/64      ::                0	             32768      i

By summary-only command, BGP will send only summary route of network then the router which is sending summary route will stripped off all previous AS-tag and will send summarized route with fresh originating router.

Step 6: Configure Summarize only as-set BGP routes in router mode

R3:
router bgp 65000
address-family ipv6
aggregate-address 11::/16 summary-only as-set
exit

Step 7: Verify receipt of summary route in other router’s BGP table by following command

R4#show bgp ipv6 unicast
BGP table version is 19, local router ID is 44.0.3.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network        Next Hop      Metric    LocPrf    Weight    Path
 *>  11::/16       33:0:1::3        0                   0 	    65000 65100 i
 *>  22:0:1::/64   33:0:1::3                            0 	    65000 i
 *>  22:0:2::/64   33:0:1::3                            0 	    65000 i
 *>  22:0:3::/64   33:0:1::3                            0 	    65000 i
 *>  33:0:1::/64   33:0:1::3        0                   0 	    65000 i
 *>  33:0:2::/64   33:0:1::3        0                   0 	    65000 i
 *>  33:0:3::/64   33:0:1::3        0           	    0 	    65000 i
 *>  44:0:1::/64      ::            0         	      32768     i
 *>  44:0:2::/64      ::            0        	      32768     i
 *>  44:0:3::/64      ::            0         	      32768     i

By as-set command, only summary route as well as retaining all previous AS-tag is achieved.