MPLS - Carrier Supporting Carrier

Carrier Supporting Carrier

Carrier Supporting Carrier (CSC) is a networking concept where one service provider, known as the "supporting carrier," provides connectivity services to another service provider, referred to as the "supported carrier." This framework is often used in the telecommunications industry to enable a smaller or regional service provider to offer global connectivity services without establishing a worldwide network infrastructure. The supporting carrier extends its network reach and resources to the supported carrier, allowing the latter to provide connectivity services to its customers on a broader scale. MPLS (Multiprotocol Label Switching) technology is commonly employed in Carrier Supporting Carrier implementations, facilitating efficient and secure transport of data across the interconnected networks. CSC is a strategic approach that promotes collaboration and resource sharing among service providers, enabling them to deliver comprehensive and extended services to their customers without the need for significant infrastructure investments.

Lab:

Disclaimer

This Configuration Guide is designed to assist members to enhance their skills in particular technology area. While every effort has been made to ensure that all material is as complete and accurate as possible, the enclosed material is presented on an “as is” basis. Neither the authors nor Forum assume any liability or responsibility to any person or entity with respect to loss or damages incurred from the information contained in this guide. This configuration guide was developed by Forum. Any similarities between material presented in this configuration guide and any other material is completely coincidental.

CE1 Router:

ip cef! 
interface Loopback1 
ip address 203.1.0.1 255.255.255.255 
! 
interface Loopback2
ip address 203.1.1.1 255.255.255.0 
! 
interface FastEthernet0/0 
ip address 150.1.1.2 255.255.255.252 
! 
ip route 0.0.0.0 0.0.0.0 150.1.1.1 
! 
end

CE2 Router:

ip cef 
! 
interface Loopback1 
ip address 203.1.0.4 255.255.255.255 
!
interface Loopback2 
ip address 203.1.4.1 255.255.255.0 
! 
interface FastEthernet0/0 
ip address 150.1.1.6 255.255.255.252 
! 
ip route 0.0.0.0 0.0.0.0 150.1.1.5 
! 
end

PE1 Router:

ip cef! 
ip vrf vpna 
rd 3:1 
route-target export 3:1 
route-target import 3:1 
! 
mpls label protocol ldp 
! 
interface Loopback1 
ip address 1.1.1.1 255.255.255.255 
! 
interface FastEthernet0/0 
ip vrf forwarding vpna 
ip address 150.1.1.1 255.255.255.252 
! 
interface Serial2/0 
ip address 10.0.0.1 255.255.255.0 
mpls ip 
! 
router ospf 1 
network 1.1.1.1 0.0.0.0 area 0 
network 10.0.0.0 0.0.0.255 area 0 
! 
router bgp 65100 
no synchronization 
neighbor 6.6.6.6 remote-as 65100 
neighbor 6.6.6.6 update-source Loopback1 
no auto-summary 
! 
address-family vpnv4 
neighbor 6.6.6.6 activate 
neighbor 6.6.6.6 send-community extended 
exit-address-family 
! 
address-family ipv4 vrf vpna 
redistribute connected 
redistribute static 
no synchronization 
exit-address-family 
! 
ip route vrf vpna 203.1.0.1 255.255.255.255 
150.1.1.2 
ip route vrf vpna 203.1.1.0 255.255.255.0 150.1.1.2 
! 
mpls ldp router-id Loopback1 
! 
end

PE6 Router:

ip cef!ip vrf vpna 
rd 3:1 
route-target export 3:1 
route-target import 3:1 
! 
mpls label protocol ldp 
! 
interface Loopback1 
ip address 6.6.6.6 255.255.255.255 
! 
interface FastEthernet0/0 
ip vrf forwarding vpna 
ip address 150.1.1.5 255.255.255.252 
! 
interface Serial2/0 
ip address 30.0.0.6 255.255.255.0 
mpls ip 
! 
router ospf 1 
network 6.6.6.6 0.0.0.0 area 0 
network 30.0.0.6 0.0.0.0 area 0 
! 
router bgp 65100 
no synchronization 
neighbor 1.1.1.1 remote-as 65100 
neighbor 1.1.1.1 update-source Loopback1 
no auto-summary 
!
address-family vpnv4 
neighbor 1.1.1.1 activate 
neighbor 1.1.1.1 send-community extended 
exit-address-family 
! 
address-family ipv4 vrf vpna 
redistribute connected 
redistribute static 
no synchronization 
exit-address-family 
! 
ip route vrf vpna 203.1.0.4 255.255.255.255 
150.1.1.6 
ip route vrf vpna 203.1.4.0 255.255.255.0 150.1.1.6 
! 
mpls ldp router-id Loopback1 
! 
end

PE2 Router:

ip cef!mpls label protocol ldp 
! 
interface Loopback1 
ip address 2.2.2.2 255.255.255.255 
! 
interface Serial2/0 
ip address 10.0.0.2 255.255.255.0 
mpls ip 
! 
interface Serial2/1 
ip address 23.0.0.2 255.255.255.0 
! 
router ospf 1 
redistribute bgp 65100 metric 10 subnets 
network 2.2.2.2 0.0.0.0 area 0 
network 10.0.0.0 0.255.255.255 area 0 
network 23.0.0.0 0.255.255.255 area 0 
! 
router bgp 65100 
no synchronization 
redistribute ospf 1 metric 10 match internal external 1 
external 2 
neighbor 23.0.0.3 remote-as 65000 
neighbor 23.0.0.3 send-label 
no auto-summary 
! 
mpls ldp router-id Loopback1 
! 
end

PE5 Router:

ip cef!mpls label protocol ldp 
! 
interface Loopback1 
ip address 5.5.5.5 255.255.255.255 
! 
interface Serial2/0 
ip address 30.0.0.5 255.255.255.0 
mpls ip 
! 
interface Serial2/1 
ip address 45.0.0.5 255.255.255.0 
! 
router ospf 1 
redistribute bgp 65100 metric 10 subnets 
network 5.5.5.5 0.0.0.0 area 0 
network 30.0.0.0 0.255.255.255 area 0 
network 45.0.0.0 0.255.255.255 area 0 
! 
router bgp 65100 
no synchronization 
redistribute ospf 1 metric 10 match internal external 1 
external 2 
neighbor 45.0.0.4 remote-as 65000 
neighbor 45.0.0.4 send-label 
no auto-summary 
! 
mpls ldp router-id Loopback1 
! 
end

PE3 Router:

ip cef!ip vrf SP1-vpna 
rd 3:11 
route-target export 3:11 
route-target import 3:11 
! 
mpls label protocol ldp 
! 
interface Loopback1 
ip address 3.3.3.3 255.255.255.255 
! 
interface Serial2/0 
ip address 20.0.0.3 255.255.255.0 
mpls ip 
! 
interface Serial2/1 
ip vrf forwarding SP1-vpna 
ip address 23.0.0.3 255.255.255.0 
! 
router ospf 64 
network 3.3.3.3 0.0.0.0 area 0 
network 20.0.0.0 0.255.255.255 area 0 
! 
router bgp 65000 
no synchronization 
neighbor 4.4.4.4 remote-as 65000 
neighbor 4.4.4.4 update-source Loopback1
no auto-summary 
! 
address-family vpnv4 
neighbor 4.4.4.4 activate 
neighbor 4.4.4.4 send-community extended 
exit-address-family
! 
address-family ipv4 vrf SP1-vpna 
redistribute connected 
neighbor 23.0.0.2 remote-as 65100 
neighbor 23.0.0.2 activate 
neighbor 23.0.0.2 as-override 
neighbor 23.0.0.2 send-label 
no synchronization 
exit-address-family 
! 
mpls ldp router-id Loopback1 force 
! 
end

PE4 Router:

ip cef!ip vrf SP1-vpna 
rd 3:11 
route-target export 3:11 
route-target import 3:11 
! 
mpls label protocol ldp 
! 
interface Loopback1 
ip address 4.4.4.4 255.255.255.255 
! 
interface Serial2/0 
ip address 20.0.0.4 255.255.255.0 
mpls ip 
! 
interface Serial2/1 
ip vrf forwarding SP1-vpna 
ip address 45.0.0.4 255.255.255.0 
! 
router ospf 64 
network 4.4.4.4 0.0.0.0 area 0 
network 20.0.0.0 0.255.255.255 area 0 
! 
router bgp 65000 
no synchronization 
neighbor 3.3.3.3 remote-as 65000 
neighbor 3.3.3.3 update-source Loopback1 
no auto-summary 
! 
address-family vpnv4 
neighbor 3.3.3.3 activate 
neighbor 3.3.3.3 send-community extended 
exit-address-family 
! 
address-family ipv4 vrf SP1-vpna 
redistribute connected 
neighbor 45.0.0.5 remote-as 65100 
neighbor 45.0.0.5 activate 
neighbor 45.0.0.5 as-override 
neighbor 45.0.0.5 send-label 
no synchronization 
exit-address-family 
! 
mpls ldp router-id Loopback1 force 
! 
end

PE4 Router:

ip cef 
! 
ip vrf vpnc 
rd 3:30 
route-target export 3:30 
route-target import 3:30 
! 
mpls label protocol ldp 
! 
interface Loopback0 
ip address 192.168.3.4 255.255.255.255 
! 
interface Loopback30 
ip vrf forwarding vpnc 
ip address 60.60.60.60 255.255.255.255 
! 
interface FastEthernet0/0 
description *** Link to A4 *** 
ip vrf forwarding vpnc 
ip address 150.1.31.17 255.255.255.252 
! 
interface Serial2/1 
description *** Link to PE3 *** 
ip address 192.168.3.9 255.255.255.252 
no ip directed-broadcast 
tag-switching ip 
! 
router ospf 30 vrf vpnc 
router-id 60.60.60.60 
area 0 sham-link 60.60.60.60 30.30.30.30 
cost 10 
redistribute bgp 3 subnets 
network 150.1.0.0 0.0.255.255 area 0 
! 
router ospf 1 
network 192.168.3.0 0.0.0.255 area 0 
! 
router bgp 3 
no synchronization 
bgp log-neighbor-changes 
network 192.168.3.4 mask 255.255.255.255 
neighbor 192.168.3.3 remote-as 3
neighbor 192.168.3.3 update-source 
Loopback0 
no auto-summary 
! 
address-family vpnv4 
neighbor 192.168.3.3 activate 
neighbor 192.168.3.3 send-community 
extended 
exit-address-family 
! 
address-family ipv4 vrf vpnc 
redistribute ospf 30 vrf vpnc 
no synchronization 
network 60.60.60.60 mask 255.255.255.255 
exit-address-family 
! 
tag-switching tdp router-id Loopback0 
! 
end