Switching - DHCP Lab 1

DHCP Lab 1

In a Switching DHCP Lab 1 scenario, the focus is likely on configuring and testing DHCP (Dynamic Host Configuration Protocol) services within a switching environment. This lab may involve setting up a network with multiple switches and routers, where the switches play a role in connecting end-user devices and the routers are responsible for inter-VLAN routing. The DHCP server, which could be implemented on a router or a dedicated server, assigns IP addresses dynamically to devices in the network. The lab participants might configure DHCP relay agents on the switches to facilitate the communication between DHCP clients and the DHCP server. Additionally, VLAN configurations on the switches may be involved to segment the network. The lab aims to provide hands-on experience in configuring DHCP services in a switching environment, ensuring that devices connected to different VLANs receive appropriate IP addresses dynamically, thereby optimizing network management and simplifying IP address assignments.

Lab 1: Configure DHCP

DHCP Topology

Disclaimer This Configuration Guide is designed to assist members to enhance their skills in particular technology area. While every effort has been made to ensure that all material is as complete and accurate as possible, the eŶĐlosed ŵaterial is preseŶted oŶ aŶ ͞as is͟ ďasis. Neither the authors Ŷor Foruŵ assuŵe aŶy liaďility or responsibility to any person or entity with respect to loss or damages incurred from the information contained in this guide. This configuration guide was developed by Forum. Any similarities between material presented in this configuration guide and any other material is completely coincidental.

Cisco IOS Software, Linux Software (I86BI_LINUX-ADVENTERPRISEK9-M), Version 15.2(4)M1, DEVELOPMENT TEST SOFTWARE

Task 1: Configure IPv4 DHCP

Step 1: In the configuration mode of router configure IPv4 DHCP by following command:

Multilayer Switch 1 
interface fastethernet 0/1 
switchport trunk encapsulation dot1q 
switchport mode trunk 
exit 
vlan 100, 200 
exit 
interface vlan 100 
ip address 100.0.0.1 255.255.255.0
interface vlan 200 
ip address 200.0.0.1 255.255.255.0
ip dhcp pool VLAN0100 
network 100.0.0.0 255.255.255.0 
default-router 100.0.0.1 
exit
ip dhcp pool VLAN0200 
network 200.0.0.0 255.255.255.0 
default-router 200.0.0.1 
exit 
Switch 1 
interface fastethernet 0/1 
switchport trunk encapsulation dot1q 
switchport mode trunk 
exit 
interface fastethernet 0/2 
switchport access vlan 100 
switchport mode access 
interface fastethernet 0/3 
switchport access vlan 200 
switchport mode access

Configure the HOST to obtain IP from DHCP.