Switching - DHCP Lab 3

DHCP Lab 3

In a Switching DHCP Lab 3, participants are likely engaged in advanced configurations and troubleshooting scenarios related to DHCP (Dynamic Host Configuration Protocol) services within a switched environment. This lab may involve complex network topologies, spanning multiple switches and routers, where participants are challenged to implement and optimize DHCP services across diverse VLANs. The focus could extend to exploring features like DHCP failover mechanisms, exploring redundancy options, and implementing security measures such as DHCP snooping and IP source guard. Participants might be tasked with addressing scenarios involving DHCP lease management, understanding and mitigating IP address conflicts, and ensuring seamless communication between DHCP clients and servers. Switching DHCP Lab 3 aims to provide a comprehensive hands-on experience, equipping participants with the skills to design, implement, and troubleshoot sophisticated DHCP configurations in complex switched network environments.

Lab 3: Configure DHCP Relay Agent

DHCP Topology

Disclaimer This Configuration Guide is designed to assist members to enhance their skills in particular technology area. While every effort has been made to ensure that all material is as complete and accurate as possible, the eŶĐlosed ŵaterial is preseŶted oŶ aŶ ͞as is͟ ďasis. Neither the authors Ŷor Foruŵ assuŵe aŶy liaďility or responsibility to any person or entity with respect to loss or damages incurred from the information contained in this guide. This configuration guide was developed by Forum. Any similarities between material presented in this configuration guide and any other material is completely coincidental.

Cisco IOS Software, Linux Software (I86BI_LINUX-ADVENTERPRISEK9-M), Version 15.2(4)M1, DEVELOPMENT TEST SOFTWARE

Task 3: Configure IPv4 DHCP Relay Agent

Step 1: In the configuration mode of router configure IPv4 DHCP by following command:

Router1:
interface fastethernet 0/0 
no shutdown 
interface fastethernet 0/0.1 
encapsulation dotlq 100 
ip address 100.0.0.1 255.255.255.0
interface fastethernet 0/0.2 
encapsulation dot1q 200 
ip address 200.0.0.1 255.255.255.0 
exit
ip dhcp pool VLAN100 
network 100.0.0.0 255.255.255.0 
default-router 100.0.0.1 
exit 
ip dhcp excluded-address 100.0.0.1 
ip dhcp pool VLAN200 
network 200.0.0.0 255.255.255.0 
default-router 200.0.0.1 
exit 
ip dhcp excluded-address 200.0.0.1
Switch1:
interface fastethernet 0/1 
switchport mode trunk 
exit 
interface fastethernet 0/2 
switchport access vlan 100 
switchport mode access 
interface fastethernet 0/3 
switchport access vlan 200 
switchport mode access 
exit

Configure the HOST to obtain IP from DHCP.