IPv6 - EIGRP
Cisco's Enhanced Interior Gateway Routing Protocol (EIGRP)
As of my last knowledge update in January 2022, Cisco's Enhanced Interior Gateway Routing Protocol (EIGRP) has traditionally been associated with IPv4 routing. However, Cisco introduced EIGRP for IPv6 to support the routing needs of IPv6 networks. IPv6 EIGRP retains the core features of its IPv4 counterpart, providing a scalable and efficient routing protocol for IPv6 environments. It incorporates support for IPv6 addresses and utilizes the same core concepts, including the Diffusing Update Algorithm (DUAL) for loop prevention and the Reliable Transport Protocol (RTP) for reliable delivery of routing information. IPv6 EIGRP allows network administrators to leverage the benefits of EIGRP in dual-stack or IPv6-only networks, simplifying the transition to IPv6 by maintaining a familiar routing protocol. It is worth checking the Cisco documentation for the latest updates and features related to IPv6 EIGRP, as advancements and changes may have occurred since my last knowledge update in January 2022.
Lab:
Disclaimer
This Configuration Guide is designed to assist members to enhance their skills in particular technology area. While every effort has been made to ensure that all material is as complete and accurate as possible, the enclosed material is presented on an “as is” basis. Neither the authors nor Forum assume any liability or responsibility to any person or entity with respect to loss or damages incurred from the information contained in this guide. This configuration guide was developed by Forum. Any similarities between material presented in this configuration guide and any other material is completely coincidental.
R1 Router Config:
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
no ip address
ipv6 address 2002:0:1:1::1/128
ipv6 eigrp 100
!
interface Loopback1
no ip address
ipv6 address 2002:0:1:2::1/128
ipv6 eigrp 100
!
interface Loopback2
no ip address
ipv6 address 2002:0:1:3::1/128
ipv6 eigrp 100
!
interface Serial1/0
no ip address
ipv6 address 2001:0:0:12::1/128
ipv6 eigrp 100
no fair-queue
serial restart-delay 0
!
ipv6 router eigrp 100
eigrp router-id 1.1.1.1
!
R4 Router Config:
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
no ip address
ipv6 address 2002:0:4:1::4/128
ipv6 eigrp 100
!
interface Loopback1
no ip address
ipv6 address 2002:0:4:2::4/128
ipv6 eigrp 100
!
interface Loopback2
no ip address
ipv6 address 2002:0:4:3::4/128
ipv6 eigrp 100
!
interface Serial1/0
no ip address
ipv6 address 2001:0:0:34::4/128
ipv6 eigrp 100
serial restart-delay 0
clock rate 64000
!
ipv6 router eigrp 100
eigrp router-id 4.4.4.4
!
R2 Router Config:
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
no ip address
ipv6 address 2002:0:2:1::2/128
ipv6 eigrp 100
!
interface Loopback1
no ip address
ipv6 address 2002:0:2:2::2/128
ipv6 eigrp 100
!
interface Loopback2
no ip address
ipv6 address 2002:0:2:3::2/128
ipv6 eigrp 100
!
interface Serial1/0
no ip address
ipv6 address 2001:0:0:12::/64 eui-64
ipv6 eigrp 100
no fair-queue
serial restart-delay 0
clock rate 64000
!
interface FastEthernet2/0
no ip address
duplex full
speed 100
ipv6 address 2001:0:0:23::/64 eui-64
ipv6 eigrp 100
!
ipv6 router eigrp 100
eigrp router-id 2.2.2.2
!
R3 Router Config:
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
no ip address
ipv6 address 2002:0:3:1::3/128
ipv6 eigrp 100
!
interface Loopback1
no ip address
ipv6 address 2002:0:3:2::3/128
ipv6 eigrp 100
!
interface Loopback2
no ip address
ipv6 address 2002:0:3:3::3/128
ipv6 eigrp 100
!
interface Serial1/0
no ip address
ipv6 address 2001:0:0:34::3/128
ipv6 eigrp 100
no fair-queue
serial restart-delay 0
clock rate 64000
!
interface FastEthernet2/0
no ip address
duplex full
speed 100
ipv6 address 2001:0:0:23::/64 eui-64
ipv6 eigrp 100
!
ipv6 router eigrp 100
eigrp router-id 3.3.3.3
!
Note: When EIGRP used in IPv6 Toplology in which routers do not have any IPv4 address, router-id need to be provided for EIGRP process.
R1#sh ipv6 eigrp 100 neighbors
EIGRP-IPv6 Neighbors for AS(100)
H Address Interface Hold Uptime SRTT RTO Q
Seq
(sec) (ms) Cnt
Num
0 Link-local address: Se1/0 11 00:16:14 21 200 0 9
FE80::C802:8FF:FE5F:0
(H shows the nuber of attempt in which neighbor has been made) (Address is the address of interface on which neighborship has been formed) (Interface shows the physical interface on which address is confiured) (Link Local address has not been configured manually. It is assinged to interface automatically where FE80::/64 mask with EUI-64 has been used. Since this is a serial interface it does not have any Layer 2 address (MAC address) hence MAC of Interface FastEthernet 0/0 has been used.)Note: EIGRP uses Link Local address for neighborship formation but do not advertise it anywhere.
R2#sh ipv6 eigrp 100 neighbors
EIGRP-IPv6 Neighbors for AS(100)
H Address Interface Hold Uptime SRTT RTO Q
Seq
(sec) (ms) Cnt
Num
1 Link-local address: Fa2/0 12 00:16:11 15 200 0 7
FE80::C803:8FF:FE5F:38
0 Link-local address: Se1/0 12 00:16:51 25 200 0 5
FE80::C801:8FF:FE5F:0
R3#sh ipv6 eigrp 100 neighbors
EIGRP-IPv6 Neighbors for AS(100)
H Address Interface Hold Uptime SRTT RTO Q
Seq
(sec) (ms) Cnt
Num
1 Link-local address: Se1/0 10 00:16:20 24 200 0 3
FE80::C800:8FF:FE5F:0
0 Link-local address: Fa2/0 14 00:16:59 50 300 0 8
FE80::C802:8FF:FE5F:38
R4#sh ipv6 eigrp 100 neighbors
EIGRP-IPv6 Neighbors for AS(100)
H Address Interface Hold Uptime SRTT RTO Q
Seq
(sec) (ms) Cnt
Num
0 Link-local address: Se1/0 13 00:16:44 22 200 0 6
FE80::C803:8FF:FE5F:0
R1#sh ipv6 eigrp 100 int
EIGRP-IPv6 Interfaces for AS(100)
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Lo0 0 0/0 0 0/1 0 0
Lo1 0 0/0 0 0/1 0 0
Lo2 0 0/0 0 0/1 0 0
Se1/0 1 0/0 29 0/15 143 0
(Interfaces on which EIGRP IPv6 for AS 100 has been enabled) (Peers is the number of neighbors for EIGRP AS 100 for IPv6)
R2#sh ipv6 eigrp int
EIGRP-IPv6 Interfaces for AS(100)
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se1/0 1 0/0 21 0/15 107 0
Fa2/0 1 0/0 51 0/1 224 0
Lo0 0 0/0 0 0/1 0 0
Lo1 0 0/0 0 0/1 0 0
Lo2 0 0/0 0 0/1 0 0
R3#sh ipv6 eigrp int
EIGRP-IPv6 Interfaces for AS(100)
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se1/0 1 0/0 32 0/15 159 0
Fa2/0 1 0/0 1584 0/1 7904 0
Lo0 0 0/0 0 0/1 0 0
Lo1 0 0/0 0 0/1 0 0
Lo2 0 0/0 0 0/1 0 0
R4#sh ipv6 eigrp 100 int
EIGRP-IPv6 Interfaces for AS(100)
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se1/0 1 0/0 24 0/15 123 0
Lo0 0 0/0 0 0/1 0 0
Lo1 0 0/0 0 0/1 0 0
Lo2 0 0/0 0 0/1 0 0
R1#sh ipv6 route
IPv6 Routing Table – default – 18 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D 2001:0:0:12::/64 [90/2681856]
via FE80::C802:8FF:FE5F:0, Serial1/0
LC 2001:0:0:12::1/128 [0/0]
via Serial1/0, receive (A different mask has been used on the connected
interfaces so for the same network entry is made twice by EIGRP)
D 2001:0:0:23::/64 [90/2172416]
via FE80::C802:8FF:FE5F:0, Serial1/0 (Same mask has been used on connected
interfaces, so only a single entry for the network made by EIGRP)
D 2001:0:0:34::3/128 [90/2684416]
via FE80::C802:8FF:FE5F:0, Serial1/0
D 2001:0:0:34::4/128 [90/3196416]
via FE80::C802:8FF:FE5F:0, Serial1/0 (Same mask but /128 i.e. host specific
is used so different entries for same network is made by EIGRP)
LC 2002:0:1:1::1/128 [0/0]
via Loopback0, receive
LC 2002:0:1:2::1/128 [0/0]
via Loopback1, receive (L-represents local to router. Entries are made for
/128 connected addresses)
LC 2002:0:1:3::1/128 [0/0]
via Loopback2, receive (C-means the connected network to the interface network)
D 2002:0:2:1::2/128 [90/2297856]
via FE80::C802:8FF:FE5F:0, Serial1/0 (D-the routes are learnt by EIGRP process)
D 2002:0:2:2::2/128 [90/2297856]
via FE80::C802:8FF:FE5F:0, Serial1/0
D 2002:0:2:3::2/128 [90/2297856]
via FE80::C802:8FF:FE5F:0, Serial1/0
D 2002:0:3:1::3/128 [90/2300416]
via FE80::C802:8FF:FE5F:0, Serial1/0
D 2002:0:3:2::3/128 [90/2300416]
via FE80::C802:8FF:FE5F:0, Serial1/0
D 2002:0:3:3::3/128 [90/2300416]
via FE80::C802:8FF:FE5F:0, Serial1/0
D 2002:0:4:1::4/128 [90/2812416]
via FE80::C802:8FF:FE5F:0, Serial1/0
D 2002:0:4:2::4/128 [90/2812416]
via FE80::C802:8FF:FE5F:0, Serial1/0
D 2002:0:4:3::4/128 [90/2812416]
via FE80::C802:8FF:FE5F:0, Serial1/0
L FF00::/8 [0/0]
via Null0, receive
R2#sh ipv6 route
IPv6 Routing Table – default – 20 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C 2001:0:0:12::/64 [0/0]
via Serial1/0, directly connected
D 2001:0:0:12::1/128 [90/2681856]
via FE80::C801:8FF:FE5F:0, Serial1/0
L 2001::12:C802:8FF:FE5F:0/128 [0/0]
via Serial1/0, receive
C 2001:0:0:23::/64 [0/0]
via FastEthernet2/0, directly connected
L 2001::23:C802:8FF:FE5F:38/128 [0/0]
via FastEthernet2/0, receive
D 2001:0:0:34::3/128 [90/2172416]
via FE80::C803:8FF:FE5F:38, FastEthernet2/0
D 2001:0:0:34::4/128 [90/2684416]
via FE80::C803:8FF:FE5F:38, FastEthernet2/0
D 2002:0:1:1::1/128 [90/2297856]
via FE80::C801:8FF:FE5F:0, Serial1/0
D 2002:0:1:2::1/128 [90/2297856]
via FE80::C801:8FF:FE5F:0, Serial1/0
D 2002:0:1:3::1/128 [90/2297856]
via FE80::C801:8FF:FE5F:0, Serial1/0
LC 2002:0:2:1::2/128 [0/0]
via Loopback0, receive
LC 2002:0:2:2::2/128 [0/0]
via Loopback1, receive
LC 2002:0:2:3::2/128 [0/0]
via Loopback2, receive
D 2002:0:3:1::3/128 [90/156160]
via FE80::C803:8FF:FE5F:38, FastEthernet2/0
D 2002:0:3:2::3/128 [90/156160]
via FE80::C803:8FF:FE5F:38, FastEthernet2/0
D 2002:0:3:3::3/128 [90/156160]
via FE80::C803:8FF:FE5F:38, FastEthernet2/0
D 2002:0:4:1::4/128 [90/2300416]
via FE80::C803:8FF:FE5F:38, FastEthernet2/0
D 2002:0:4:2::4/128 [90/2300416]
via FE80::C803:8FF:FE5F:38, FastEthernet2/0
D 2002:0:4:3::4/128 [90/2300416]
via FE80::C803:8FF:FE5F:38, FastEthernet2/0
L FF00::/8 [0/0]
via Null0, receive
R3#sh ipv6 route
IPv6 Routing Table – default – 19 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D 2001:0:0:12::/64 [90/2172416]
via FE80::C802:8FF:FE5F:38, FastEthernet2/0
D 2001:0:0:12::1/128 [90/2684416]
via FE80::C802:8FF:FE5F:38, FastEthernet2/0
C 2001:0:0:23::/64 [0/0]
via FastEthernet2/0, directly connected
L 2001::23:C803:8FF:FE5F:38/128 [0/0]
via FastEthernet2/0, receive
LC 2001:0:0:34::3/128 [0/0]
via Serial1/0, receive
D 2001:0:0:34::4/128 [90/2681856]
via FE80::C800:8FF:FE5F:0, Serial1/0
D 2002:0:1:1::1/128 [90/2300416]
via FE80::C802:8FF:FE5F:38, FastEthernet2/0
D 2002:0:1:2::1/128 [90/2300416]
via FE80::C802:8FF:FE5F:38, FastEthernet2/0
D 2002:0:1:3::1/128 [90/2300416]
via FE80::C802:8FF:FE5F:38, FastEthernet2/0
D 2002:0:2:1::2/128 [90/156160]
via FE80::C802:8FF:FE5F:38, FastEthernet2/0
D 2002:0:2:2::2/128 [90/156160]
via FE80::C802:8FF:FE5F:38, FastEthernet2/0
D 2002:0:2:3::2/128 [90/156160]
via FE80::C802:8FF:FE5F:38, FastEthernet2/0
LC 2002:0:3:1::3/128 [0/0]
via Loopback0, receive
LC 2002:0:3:2::3/128 [0/0]
via Loopback1, receive
LC 2002:0:3:3::3/128 [0/0]
via Loopback2, receive
D 2002:0:4:1::4/128 [90/2297856]
via FE80::C800:8FF:FE5F:0, Serial1/0
D 2002:0:4:2::4/128 [90/2297856]
via FE80::C800:8FF:FE5F:0, Serial1/0
D 2002:0:4:3::4/128 [90/2297856]
via FE80::C800:8FF:FE5F:0, Serial1/0
L FF00::/8 [0/0]
via Null0, receive
R4#sh ipv6 route
IPv6 Routing Table – default – 18 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D 2001:0:0:12::/64 [90/2684416]
via FE80::C803:8FF:FE5F:0, Serial1/0
D 2001:0:0:12::1/128 [90/3196416]
via FE80::C803:8FF:FE5F:0, Serial1/0
D 2001:0:0:23::/64 [90/2172416]
via FE80::C803:8FF:FE5F:0, Serial1/0
D 2001:0:0:34::3/128 [90/2681856]
via FE80::C803:8FF:FE5F:0, Serial1/0
LC 2001:0:0:34::4/128 [0/0]
via Serial1/0, receive
D 2002:0:1:1::1/128 [90/2812416]
via FE80::C803:8FF:FE5F:0, Serial1/0
D 2002:0:1:2::1/128 [90/2812416]
via FE80::C803:8FF:FE5F:0, Serial1/0
D 2002:0:1:3::1/128 [90/2812416]
via FE80::C803:8FF:FE5F:0, Serial1/0
D 2002:0:2:1::2/128 [90/2300416]
via FE80::C803:8FF:FE5F:0, Serial1/0
D 2002:0:2:2::2/128 [90/2300416]
via FE80::C803:8FF:FE5F:0, Serial1/0
D 2002:0:2:3::2/128 [90/2300416]
via FE80::C803:8FF:FE5F:0, Serial1/0
D 2002:0:3:1::3/128 [90/2297856]
via FE80::C803:8FF:FE5F:0, Serial1/0
D 2002:0:3:2::3/128 [90/2297856]
via FE80::C803:8FF:FE5F:0, Serial1/0
D 2002:0:3:3::3/128 [90/2297856]
via FE80::C803:8FF:FE5F:0, Serial1/0
LC 2002:0:4:1::4/128 [0/0]
via Loopback0, receive
LC 2002:0:4:2::4/128 [0/0]
via Loopback1, receive
LC 2002:0:4:3::4/128 [0/0]
via Loopback2, receive
L FF00::/8 [0/0]
via Null0, receive