MPLS - EoMPLS Carrying One VLAN

EoMPLS Carrying One VLAN

Ethernet over MPLS (EoMPLS) carrying a single VLAN involves the transport of Ethernet frames associated with a specific VLAN across an MPLS network. In this setup, MPLS labels are used to encapsulate and forward VLAN-tagged traffic between two endpoints, enabling the extension of Layer 2 connectivity over a service provider's MPLS infrastructure. EoMPLS carrying one VLAN is particularly valuable in scenarios where organizations seek to interconnect geographically dispersed sites while maintaining VLAN segmentation. This approach allows for the secure and efficient transfer of VLAN-tagged frames across the MPLS network, providing a seamless and scalable solution for maintaining VLAN-specific communication between remote locations. The careful configuration and coordination of VLAN settings between the connected devices and the MPLS infrastructure are essential to ensure the proper handling and integrity of the VLAN-tagged Ethernet frames during transit.

Lab:

Disclaimer

This Configuration Guide is designed to assist members to enhance their skills in particular technology area. While every effort has been made to ensure that all material is as complete and accurate as possible, the enclosed material is presented on an “as is” basis. Neither the authors nor Forum assume any liability or responsibility to any person or entity with respect to loss or damages incurred from the information contained in this guide. This configuration guide was developed by Forum. Any similarities between material presented in this configuration guide and any other material is completely coincidental.

Basic information: Here, an 802.1Q trunk is established between CE and PE. Each VLAN is mapped to one Pseudowire.

CE1 Router:

int f0/0 
no ip address 
! 
int f 0/0.100 
encapsulation dot1q 100 
ip address 10.100.1.1 255.255.255.252 
! 
int f 0/0.200 
encapsulation dot1q 200 
ip address 10.200.1.1 255.255.255.252 
! 

CE2 Router:

int f0/0 
no ip address 
! 
int f 0/0.100 
encapsulation dot1q 100
ip address 10.100.1.2 255.255.255.252 
! 
int f 0/0.200 
encapsulation dot1q 200 
ip address 10.200.1.2 255.255.255.252 
! 

PE1 Router:

ip cef 
mpls label protocol ldp 
! 
int loop 0 
ip add 192.168.3.1 255.255.255.255 
ip ospf 1 area 0 
! 
int f0/0 
no ip address 
! 
int f 0/0.100 
encapsulation dot1q 100 
no ip address 
xconnect 192.168.3.2 1000 encapsulation mpls 
! 
int f 0/0.200 
encapsulation dot1q 200 
no ip address 
xconnect 192.168.3.2 2000 encapsulation mpls 
! 
interface Serial2/0 
ip address 192.168.3.22 255.255.255.252 
ip ospf 1 area 0 
tag-switching ip 
! 
router ospf 1 
! 
tag-switching tdp router-id Loopback0 force 
! 
end

PE2 Router:

ip cef 
mpls label protocol ldp 
! 
int loop 0 
ip add 192.168.3.2 255.255.255.255 
ip ospf 1 area 0 
! 
int f0/0 
no ip address
! 
int f 0/0.100 
encapsulation dot1q 100 
no ip address 
xconnect 192.168.3.1 1000 encapsulation mpls 
! 
int f 0/0.200 
encapsulation dot1q 200 
no ip address 
xconnect 192.168.3.1 2000 encapsulation mpls 
! 
interface Serial2/0 
ip address 192.168.3.21 255.255.255.252 
ip ospf 1 area 0 
tag-switching ip 
! 
router ospf 1 
! 
tag-switching tdp router-id Loopback0 force 
! 
end 

Verification:

The following output shows successful Pseudowire setup.

Local intf      Local circuit      Dest address     VC ID     Status 

-------------   -------------      -------------   -------   -------- 

Fa0/0.100       Eth VLAN 100       192.168.3.2      1000      UP 

Fa0/0.200       Eth VLAN 200       192.168.3.2      2000      UP
PE1#sh mpls l2transport vc detail

Codes: C – connected, S – stat 
Local interface: Fa0/0.100 up, line protocol up, Eth VLAN 100 up 
D – EIG 
Destination address: 192.168.3.2, VC ID: 1000, VC status: up 
Preferred path: not configured 1, N2 – OSPF NSSA external type 2 
Default path: active 
Next hop: point2point E1 – OSPF external type 
Output interface: Se2/0, imposed label stack {17} 
Create time: 00:19:57, last status change time: 00:15:412 – IS-IS level-2 
Signaling protocol: LDP, peer 192.168.3.2:0 upS-IS inter area, * – candidate default, U – per-MPLS VC labels: local 17, remote 17 
Remote interface description: 
C 150.1 
Sequencing: receive disabled, send disabled 
packet drops: receive 0, seq error 0, send 0 
Local interface: Fa0/0.200 up, line protocol up, Eth VLAN 200 up 
Destination address: 192.168.3.2, VC ID: 2000, VC status: up 
Preferred path: not configured 
Default path: active 
Next hop: point2point 
Output interface: Se2/0, imposed label stack {18} 
Create time: 00:18:17, last status change time: 00:13:55 
Signaling protocol: LDP, peer 192.168.3.2:0 up 
MPLS VC labels: local 18, remote 18 
Group ID: local 0, remote 0 
MTU: local 1500, remote 1500 
Remote interface description: 
Sequencing: receive disabled, send disabled 
VC statistics: 
packet totals: receive 626, send 627 
byte totals: receive 96474, send 97028 
packet drops: receive 0, seq error 0, send 0 

The following output shows the MPLS LFIB table on PE1 router. It indicates two point-to-point L2 circuits i.e. Pseudowires.

PE1#sh mpls forwarding-table

Local     Outgoing      Prefix            Bytes tag     Outgoing     Next Hop 
tag       tag or VC     or Tunnel Id      switched      interface 

16        Pop tag       192.168.3.2/32    0             Se2/0        point2point 
17        Untagged      l2ckt(1000)       8020          none         point2point 
18        Untagged      l2ckt(2000)       7218          none         point2point