MPLS - EoMPLS Carrying One VLAN (VLAN-ID Rewrite)

EoMPLS Carrying One VLAN (VLAN-ID Rewrite)

Ethernet over MPLS (EoMPLS) carrying one VLAN with VLAN-ID rewrite involves the transport of Ethernet frames associated with a specific VLAN across an MPLS network, with the capability to modify or rewrite the VLAN ID during transit. In this configuration, MPLS labels are used to encapsulate and forward VLAN-tagged traffic between two endpoints, allowing for the extension of Layer 2 connectivity over a service provider's MPLS infrastructure. The VLAN-ID rewrite feature provides flexibility by enabling the adjustment of VLAN identifiers as the traffic traverses the MPLS network. This functionality is useful in scenarios where VLAN translation or mapping is required to ensure compatibility between the VLAN configurations of the interconnected sites. Careful configuration of VLAN-ID rewrite parameters is crucial to maintaining proper VLAN segmentation and ensuring the accurate handling of VLAN-tagged Ethernet frames throughout their journey across the MPLS network.

Lab:

Disclaimer

This Configuration Guide is designed to assist members to enhance their skills in particular technology area. While every effort has been made to ensure that all material is as complete and accurate as possible, the enclosed material is presented on an “as is” basis. Neither the authors nor Forum assume any liability or responsibility to any person or entity with respect to loss or damages incurred from the information contained in this guide. This configuration guide was developed by Forum. Any similarities between material presented in this configuration guide and any other material is completely coincidental.

Basic information: VLAN ID Rewrite is a feature (enabled by default, and cannot be disabled) where if the Ethernet 802.1Q VLAN ID is different at both sides of the AToM network, then the 802.1Q tag might be rewritten. Here, one 802.1Q trunk between PE2 and CE2 routers is changed to VLAN 1000.

CE1 Router:

int f0/0 
no ip address 
! 
int f 0/0.100 
incapsulation dot1q 100 
ip address 10.100.1.1 255.255.255.252 
! 
int f 0/0.200 
encapsulation dot1q 200 
ip address 10.200.1.1 255.255.255.252 
!

CE2 Router:

int f0/0 
no ip address 
! 
int f 0/0.100 
encapsulation dot1q 1000 
ip address 10.100.1.2 255.255.255.252 
! 
int f 0/0.200 
encapsulation dot1q 200 
ip address 10.200.1.2 255.255.255.252 
! 

PE1 Router:

ip cef 
mpls label protocol ldp 
! 
int loop 0 
ip add 192.168.3.1 255.255.255.255 
ip ospf 1 area 0 
! 
int f0/0 
no ip address 
! 
int f 0/0.100 
encapsulation dot1q 100 
no ip address 
xconnect 192.168.3.2 1000 encapsulation 
mpls 
! 
int f 0/0.200 
encapsulation dot1q 200 
no ip address 
xconnect 192.168.3.2 2000 encapsulation 
mpls 
! 
interface Serial2/0 
ip address 192.168.3.22 255.255.255.252 
ip ospf 1 area 0 
tag-switching ip 
! 
router ospf 1 
! 
tag-switching tdp router-id Loopback0 force

PE2 Router:

ip cef 
mpls label protocol ldp 
! 
int loop 0 
ip add 192.168.3.2 255.255.255.255 
ip ospf 1 area 0 
! 
int f0/0 
no ip address 
! 
int f 0/0.100 
encapsulation dot1q 1000 
no ip address 
xconnect 192.168.3.1 1000 encapsulation 
mpls 
! 
int f 0/0.200 
encapsulation dot1q 200 
no ip address 
xconnect 192.168.3.1 2000 encapsulation 
mpls 
! 
interface Serial2/0 
ip address 192.168.3.21 255.255.255.252 
ip ospf 1 area 0 
tag-switching ip 
! 
router ospf 1 
! 
tag-switching tdp router-id Loopback0 force

Verification:

Although the VLAN IDs do not match, the VC is still UP.

Local intf      Local circuit      Dest address     VC ID     Status 

-------------   -------------      -------------   -------   -------- 

Fa0/0.100       Eth VLAN 100       192.168.3.2      1000      UP 

Fa0/0.200       Eth VLAN 200       192.168.3.2      2000      UP
PE2(config)#do sh mpls l2transport vc

Local intf      Local circuit      Dest address     VC ID     Status 

-------------   -------------      -------------   -------   -------- 

Fa0/0.100       Eth VLAN 100       192.168.3.2      1000      UP 

Fa0/0.200       Eth VLAN 200       192.168.3.2      2000      UP