MPLS - EoMPLS Carrying Simple Ethernet

EoMPLS Carrying Simple Ethernet

Ethernet over MPLS (EoMPLS) is a technology that facilitates the transparent transport of Ethernet frames over an MPLS network. When used to carry simple Ethernet, EoMPLS provides a point-to-point Ethernet connection between two sites over an MPLS infrastructure. In this scenario, Ethernet frames are encapsulated within MPLS labels, allowing them to traverse the MPLS network while maintaining the characteristics of the original Ethernet traffic. This method is commonly employed in service provider networks to extend Ethernet connectivity between customer sites. EoMPLS with simple Ethernet is particularly useful for interconnecting geographically dispersed locations in a way that appears to the connected devices as a direct Ethernet link, enabling seamless communication over the MPLS network. The simplicity and efficiency of EoMPLS make it a preferred choice for extending Ethernet connectivity in various network scenarios.

Lab:

Disclaimer

This Configuration Guide is designed to assist members to enhance their skills in particular technology area. While every effort has been made to ensure that all material is as complete and accurate as possible, the enclosed material is presented on an “as is” basis. Neither the authors nor Forum assume any liability or responsibility to any person or entity with respect to loss or damages incurred from the information contained in this guide. This configuration guide was developed by Forum. Any similarities between material presented in this configuration guide and any other material is completely coincidental.

Summary: The Attachment Circuit (AC) can be Ethernet port or 802.1Q sub-interface (VLAN). For each AC, LDP signals different VC type via the targeted LDP session. VC Type 5 for Ethernet Port mode and VC Type 4 for Ethernet VLAN mode. Here, Ethernet Port mode is described. In Ethernet Port mode, a VLAN header might or might not be present on the frame. In any case, the PE router carries the frame transparently. This allows an Ethernet Trunk to be carried over a single Pseudowire.

CE1 Router:

ip cef 
! 
interface FastEthernet0/0 
description Connected to PE1 
ip address 150.1.31.2 255.255.255.252 
! 
end 

CE2 Router:

ip cef 
! 
interface FastEthernet0/0 
description Connected to PE1 
ip address 150.1.31.6 255.255.255.252 
! 
end

PE1 Router:

ip cef 
mpls label protocol ldp 
! 
pseudowire-class MPLS_Encapsulation 
encapsulation mpls 
! 
interface Loopback0 
ip address 192.168.3.1 255.255.255.255 
ip ospf 1 area 0 
! 
interface FastEthernet0/0 
description Connected to CE1 
xconnect 192.168.3.2 1000 pw-class 
MPLS_Encapsulation 
! 
interface Serial2/0 
ip address 192.168.3.22 255.255.255.252 
ip ospf 1 area 0 
tag-switching ip 
! 
router ospf 1 
! 
tag-switching tdp router-id Loopback0 force 
! 
end 

PE2 Router:

ip cef 
! 
mpls label protocol ldp 
! 
interface Loopback0 
ip address 192.168.3.2 
255.255.255.255 
ip ospf 1 area 0 
! 
interface FastEthernet0/0 
description Connected to CE2 
xconnect 192.168.3.1 1000 
encapsulation mpls 
! 
interface Serial2/0 
ip address 192.168.3.21 
255.255.255.252 
ip ospf 1 area 0 
tag-switching ip 
! 
router ospf 1 
! 
tag-switching tdp router-id Loopback0 
force 
! 
end

Verification:

PE#show mpls 12transport vc

Local intf      Local circuit       Dest address       VC ID         Status

------------- ----------------     ---------------   --------      ----------

Fa0/0           Ethernet            192.168.3.2        2000           UP 

PE2#show mpls l2transport vc

Local intf      Local circuit       Dest address       VC ID         Status

------------- -------------------------- --------------- ---------- ----------

Fa0/0 Ethernet  Ethernet            192.168.3.1        2000           UP 
PE1#sh mpls l2transport vc detail
Local interface: Fa0/0 up, line protocol up, Ethernet up 
 Destination address: 192.168.3.2, VC ID: 2000, VC status: up 
     Preferred path: not configured 
     Default path: active 
     Next hop: point2point 
     Output interface: Se2/0, imposed label stack {17} 
 Create time: 00:22:38, last status change time: 00:21:57 
 Signaling protocol: LDP, peer 192.168.3.2:0 up 
     MPLS VC labels: local 17, remote 17 
     Group ID: local 0, remote 0 
     MTU: local 1500, remote 1500 
     Remote interface description: Connected to CE2 
 Sequencing: receive disabled, send disabled 
 VC statistics: 
     packet totals: receive 157, send 154 
     byte totals: receive 17709, send 17380 
     packet drops: receive 0, seq error 0, send 0 
PE2#sh mpls l2transport vc detail

Local interface: Fa0/0 up, line protocol up, Ethernet up 
 Destination address: 192.168.3.1, VC ID: 2000, VC status: up 
     Preferred path: not configured 
     Default path: active 
     Next hop: point2point 
     Output interface: Se2/0, imposed label stack {17}
     Create time: 00:23:19, last status change time: 00:23:14 
 Signaling protocol: LDP, peer 192.168.3.1:0 up 
     MPLS VC labels: local 17, remote 17 
     Group ID: local 0, remote 0 
     MTU: local 1500, remote 1500 
     Remote interface description: Connected to CE1 
 Sequencing: receive disabled, send disabled 
 VC statistics: 
     packet totals: receive 162, send 165 
     byte totals: receive 18238, send 18572 
     packet drops: receive 0, seq error 0, send 0