Switching - Gateway Load Balancing Protocol

Gateway Load Balancing Protocol

The Gateway Load Balancing Protocol (GLBP) is another Cisco proprietary protocol that enhances network reliability and optimizes load distribution in switching environments. Specifically designed for providing redundancy and load balancing for default gateways, GLBP enables multiple routers or layer 3 switches to work collaboratively, presenting a virtual IP address and a set of virtual MAC addresses to the connected devices. GLBP employs a round-robin algorithm to distribute traffic among the available routers, enhancing network utilization and preventing a single point of failure. In the event of a router failure, GLBP dynamically reassigns the load to the remaining routers, ensuring continuous network availability. This protocol is particularly beneficial in environments where maximizing network resources and minimizing downtime are critical considerations. The integration of GLBP with switching technologies contributes to the creation of highly available and efficient network infrastructures.

Lab:

GLBP Topology

Task 1: Configure GLBP

Step 1: Configure GLBP Basic Configuration

PC1: 
interface f0/0 
ip address 10.0.0.10 255.255.255.0 
no shutdown 
exit

ip route 100.0.0.0 255.0.0.0 10.0.0.5 

PC2: 
interface f0/0 
ip address 10.0.0.20 255.255.255.0 
no shutdown 
exit

ip route 100.0.0.0 255.0.0.0 10.0.0.5 

R2: 
interface f0/0 
ip address 10.0.0.2 255.255.255.0 
no shutdown 
exit

interface serial 1/0 
ip address 20.0.0.2 255.255.255.0 
no shutdown 
exit 

ip route 100.0.0.0 255.0.0.0 20.0.0.4

int f0/0 
glbp 1 ip 10.0.0.5 
glbp 1 priority 100 
glbp 1 preempt 
glbp 1 load-balancing round-robin 
glbp 1 timers msec 200 msec 700 
exit

R3: 
interface f0/0 
ip address 10.0.0.3 255.255.255.0 
no shutdown 
exit 

interface serial 1/0 
ip address 30.0.0.3 255.255.255.0 
no shutdown 
exit

ip route 100.0.0.0 255.0.0.0 30.0.0.4 

int f0/0 
glbp 1 ip 10.0.0.5 
glbp 1 priority 150 
glbp 1 preempt 
glbp 1 load-balancing round-robin 
glbp 1 timers msec 200 msec 700 
exit

R1: interface serial 1/0 
ip address 20.0.0.1 255.255.255.0 
no shutdown 
exit

interface serial 1/2 
ip address 30.0.0.1 255.255.255.0 
no shutdown 
exit

interface loopback 1 
ip address 100.100.100.100 255.255.255.0 
exit

ip route 0.0.0.0 0.0.0.0 20.0.0.2 
ip route 0.0.0.0 0.0.0.0 30.0.0.3 

Task 2: Verification

Step 1: Verify Gateway State and GLBP Round Robin Load Balancing

R2: 
R2#show glbp 
FastEthernet0/0 - Group 1 
State is Standby 
7 state changes, last state change 00:00:51 
Virtual IP address is 10.0.0.5 
Hello time 200 msec, hold time 700 msec 
Next hello sent in 0.092 secs 
Redirect time 600 sec, forwarder timeout 14400 sec 
Preemption enabled, min delay 0 sec 
Active is 10.0.0.3, priority 150 (expires in 0.520 sec) 
Standby is local 
Priority 100 (default) 
Weighting 100 (default 100), thresholds: lower 1, upper 100 
Load balancing: round-robin 
Group members: 
c202.11ec.0000 (10.0.0.2) local 
c203.11ec.0000 (10.0.0.3) 
There are 2 forwarders (1 active) 
Forwarder 1 
State is Active 
1 state change, last state change 00:10:27 
MAC address is 0007.b400.0101 (default) 
Owner ID is c202.11ec.0000 
Preemption enabled, min delay 30 sec 
Active is local, weighting 100 
Forwarder 2 
State is Listen 
2 state changes, last state change 00:01:26 
MAC address is 0007.b400.0102 (learnt) 
Owner ID is c203.11ec.0000 
Time to live: 14399.936 sec (maximum 14400 sec) 
Preemption enabled, min delay 30 sec 
Active is 10.0.0.3 (primary), weighting 100 (expires in 0.656 sec)
R3: 
R3#show glbp 
FastEthernet0/0 - Group 1 
State is Active 
1 state change, last state change 00:06:18 
Virtual IP address is 10.0.0.5 
Hello time 200 msec, hold time 700 msec 
Next hello sent in 0.024 secs 
Redirect time 600 sec, forwarder timeout 14400 sec 
Preemption enabled, min delay 0 sec 
Active is local 
Standby is 10.0.0.2, priority 100 (expires in 0.588 sec) 
Priority 150 (configured) 
Weighting 100 (default 100), thresholds: lower 1, upper 100 
Load balancing: round-robin 
Group members: 
c202.11ec.0000 (10.0.0.2) 
c203.11ec.0000 (10.0.0.3) local 
There are 2 forwarders (1 active) 
Forwarder 1 
State is Listen 
4 state changes, last state change 00:04:43 
MAC address is 0007.b400.0101 (learnt) 
Owner ID is c202.11ec.0000 
Redirection enabled, 599.868 sec remaining (maximum 600 sec) 
Time to live: 14399.848 sec (maximum 14400 sec) 
Preemption enabled, min delay 30 sec 
Active is 10.0.0.2 (primary), weighting 100 (expires in 0.536 sec) 
Forwarder 2 
State is Active 
1 state change, last state change 00:06:24 
MAC address is 0007.b400.0102 (default) 
Owner ID is c203.11ec.0000 
Redirection enabled 
Preemption enabled, min delay 30 sec 
Active is local, weighting 100
R2: 
R2#show glbp brief 
Interface Grp Fwd Pri State Address Active router Standby router 
Fa0/0 1 - 100 Standby 10.0.0.5 10.0.0.3 local 
Fa0/0 1 1 - Active 0007.b400.0101 local - 
Fa0/0 1 2 - Listen 0007.b400.0102 10.0.0.3 - 
R3#show glbp brief 
Interface Grp Fwd Pri State Address Active router Standby router 
Fa0/0 1 - 150 Active 10.0.0.5 local 10.0.0.2 
Fa0/0 1 1 - Listen 0007.b400.0101 10.0.0.2 - 
Fa0/0 1 2 - Active 0007.b400.0102 local -
PC1#show arp 
Protocol Address Age (min) Hardware Addr Type Interface 
Internet 10.0.0.10 - c206.11ec.0000 ARPA FastEthernet0/0 
PC2#show arp 
Protocol Address Age (min) Hardware Addr Type Interface 
Internet 10.0.0.20 - c207.0c70.0000 ARPA FastEthernet0/0 
PC2: 
PC2#debug arp 
ARP packet debugging is on 
PC2#ping 100.100.100.100 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 100.100.100.100, timeout is 2 seconds: 

*Mar 1 00:50:16.067: IP ARP: creating incomplete entry for IP address: 10.0.0.5 
interface FastEthernet0/0 
*Mar 1 00:50:16.071: IP ARP: sent req src 10.0.0.20 c207.0c70.0000, 
 dst 10.0.0.5 0000.0000.0000 FastEthernet0/0 
*Mar 1 00:50:16.199: IP ARP: rcvd rep src 10.0.0.5 0007.b400.0101, dst 10.0.0.20 
FastEthernet0/0.!!!! 
Success rate is 80 percent (4/5), round-trip min/avg/max = 128/184/220 ms 
PC1: 
PC1#debug arp 
ARP packet debugging is on 
PC1# 
PC1#ping 100.100.100.100 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 100.100.100.100, timeout is 2 seconds: 

*Mar 1 00:52:04.131: IP ARP: creating incomplete entry for IP address: 10.0.0.5 
interface FastEthernet0/0 
*Mar 1 00:52:04.131: IP ARP: sent req src 10.0.0.10 c206.11ec.0000, 
 dst 10.0.0.5 0000.0000.0000 FastEthernet0/0 
*Mar 1 00:52:04.307: IP ARP: rcvd rep src 10.0.0.5 0007.b400.0102, dst 10.0.0.10 
FastEthernet0/0. 
*Mar 1 00:52:06.271: IP ARP: rcvd req src 10.0.0.2 c202.11ec.0000, dst 10.0.0.10 
FastEthernet0/0 
*Mar 1 00:52:06.275: IP ARP: creating entry for IP address: 10.0.0.2, hw: 
c202.11ec.0000 
*Mar 1 00:52:06.275: IP ARP: sent rep src 10.0.0.10 c206.11ec.0000, 
 dst 10.0.0.2 c202.11ec.0000 FastEthernet0/0.!!! 
Success rate is 60 percent (3/5), round-trip min/avg/max = 156/194/220 ms

GLBP Load balancing is done by using Round Robin

Task 3: GLBP Weighted Load balancing

Step 1: Configure GLBP Load balancing based on Weight

R2: 
int f0/0 
glbp 1 weighting 120 
glbp 1 load-balancing weighted 
exit 

R3: 
int f0/0 
glbp 1 weighting 110 
glbp 1 load-balancing weighted 
exit

Step 2: Verify GLBP Weighted Load balancing

R2: 
R2#show glbp 
FastEthernet0/0 - Group 1 
State is Standby 
16 state changes, last state change 00:14:24 
Virtual IP address is 10.0.0.5 
Hello time 200 msec, hold time 700 msec 
Next hello sent in 0.088 secs 
Redirect time 600 sec, forwarder timeout 14400 sec 
Preemption enabled, min delay 0 sec 
Active is 10.0.0.3, priority 150 (expires in 0.508 sec) 
Standby is local 
Priority 100 (default) 
Weighting 120 (configured 120), thresholds: lower 1, upper 120 
Load balancing: weighted 
Group members: 
c202.11ec.0000 (10.0.0.2) local 
c203.11ec.0000 (10.0.0.3) 
There are 2 forwarders (1 active) 
Forwarder 1 
State is Active 
1 state change, last state change 00:59:08 
MAC address is 0007.b400.0101 (default) 
Owner ID is c202.11ec.0000 
Preemption enabled, min delay 30 sec 
Active is local, weighting 120 
Forwarder 2 
State is Listen 
8 state changes, last state change 00:14:27 
MAC address is 0007.b400.0102 (learnt) 
Owner ID is c203.11ec.0000 
Time to live: 14399.776 sec (maximum 14400 sec) 
Preemption enabled, min delay 30 sec 
Active is 10.0.0.3 (primary), weighting 110 (expires in 0.664 sec)
R3: 
R3#show glbp 
FastEthernet0/0 - Group 1 
State is Active 
1 state change, last state change 00:48:28 
Virtual IP address is 10.0.0.5 
Hello time 200 msec, hold time 700 msec 
Next hello sent in 0.100 secs 
Redirect time 600 sec, forwarder timeout 14400 sec 
Preemption enabled, min delay 0 sec 
Active is local 
Standby is 10.0.0.2, priority 100 (expires in 0.480 sec) 
Priority 150 (configured) 
Weighting 110 (configured 110), thresholds: lower 1, upper 110 
Load balancing: weighted 
Group members: 
c202.11ec.0000 (10.0.0.2) 
c203.11ec.0000 (10.0.0.3) local 
There are 2 forwarders (1 active) 
Forwarder 1 
State is Listen 
6 state changes, last state change 00:12:19 
MAC address is 0007.b400.0101 (learnt) 
Owner ID is c202.11ec.0000 
Redirection enabled, 599.776 sec remaining (maximum 600 sec) 
Time to live: 14399.848 sec (maximum 14400 sec) 
Preemption enabled, min delay 30 sec 
Active is 10.0.0.2 (primary), weighting 120 (expires in 0.604 sec) 
Client selection count: 1 
Forwarder 2 
State is Active 
1 state change, last state change 00:48:43 
MAC address is 0007.b400.0102 (default) 
Owner ID is c203.11ec.0000 
Redirection enabled 
Preemption enabled, min delay 30 sec 
Active is local, weighting 110 
Client selection count: 1
R2#debug glbp 
GLBP debugging is on 
R2# 
*Mar 1 00:04:49.323: GLBP: Fa0/0 Grp 1 Hello in VG Active pri 150 vIP 10.0.0.5 hello 
3000, hold 10000 VF 2 Active pri 167 vMAC 0007.b400.0102 
*Mar 1 00:04:49.559: GLBP: Fa0/0 Grp 1 Hello out VG Standby pri 100 vIP 10.0.0.5 
hello 3000, hold 10000 VF 1 Active pri 167 vMAC 0007.b400.0101 
R2# 
*Mar 1 00:04:52.335: GLBP: Fa0/0 Grp 1 Hello in VG Active pri 150 vIP 10.0.0.5 hello 
3000, hold 10000 VF 2 Active pri 167 vMAC 0007.b400.0102 
*Mar 1 00:04:52.563: GLBP: Fa0/0 Grp 1 Hello out VG Standby pri 100 vIP 10.0.0.5 
hello 3000, hold 10000 VF 1 Active pri 167 vMAC 0007.b400.0101 

R3#debug glbp 
GLBP debugging is on 
*Mar 1 01:36:46.471: GLBP: Fa0/0 Grp 1 Hello out VG Active pri 150 vIP 10.0.0.5 hello 
3000, hold 10000 VF 2 Active pri 167 vMAC 0007.b400.0102 
*Mar 1 01:36:46.979: GLBP: Fa0/0 Grp 1 Hello in VG Standby pri 100 vIP 10.0.0.5 hello 
3000, hold 10000 VF 1 Active pri 167 vMAC 0007.b400.0101 
R3# 
*Mar 1 01:36:49.475: GLBP: Fa0/0 Grp 1 Hello out VG Active pri 150 vIP 10.0.0.5 hello 
3000, hold 10000 VF 2 Active pri 167 vMAC 0007.b400.0102 
*Mar 1 01:36:49.971: GLBP: Fa0/0 Grp 1 Hello in VG Standby pri 100 vIP 10.0.0.5 hello 
3000, hold 10000 VF 1 Active pri 167 vMAC 0007.b400.0101 
PC1: 
PC1#debug arp 
ARP packet debugging is on 
PC1#ping 100.100.100.100 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 100.100.100.100, timeout is 2 seconds: 

*Mar 1 00:23:43.279: IP ARP: creating incomplete entry for IP address: 10.0.0.5 
interface FastEthernet0/0 
*Mar 1 00:23:43.283: IP ARP: sent req src 10.0.0.10 c203.0c90.0000, 
 dst 10.0.0.5 0000.0000.0000 FastEthernet0/0 
*Mar 1 00:23:43.483: IP ARP: rcvd rep src 10.0.0.5 0007.b400.0101, dst 10.0.0.10 
FastEthernet0/0.. 
*Mar 1 00:23:45.627: IP ARP: rcvd req src 10.0.0.2 c201.0c90.0000, dst 10.0.0.10 
FastEthernet0/0 
*Mar 1 00:23:45.635: IP ARP: creating entry for IP address: 10.0.0.2, hw: 
c201.0c90.0000 
*Mar 1 00:23:45.635: IP ARP: sent rep src 10.0.0.10 c203.0c90.0000, 
 dst 10.0.0.2 c201.0c90.0000 FastEthernet0/0!!! 
Success rate is 60 percent (3/5), round-trip min/avg/max = 136/144/156 ms
PC2: 
PC2#debug arp 
ARP packet debugging is on 
PC2#ping 100.100.100.100 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 100.100.100.100, timeout is 2 seconds: 

*Mar 1 00:24:54.939: IP ARP: creating incomplete entry for IP address: 10.0.0.5 
interface FastEthernet0/0 
*Mar 1 00:24:54.943: IP ARP: sent req src 10.0.0.20 c204.11cc.0000, 
 dst 10.0.0.5 0000.0000.0000 FastEthernet0/0 
*Mar 1 00:24:55.255: IP ARP: rcvd rep src 10.0.0.5 0007.b400.0102, dst 10.0.0.20
FastEthernet0/0.!!!! 
Success rate is 80 percent (4/5), round-trip min/avg/max = 120/280/472 ms 
PC1#traceroute 100.100.100.100 
Type escape sequence to abort. 
Tracing the route to 100.100.100.100 

1 10.0.0.2 120 msec 136 msec 184 msec 
2 20.0.0.1 272 msec 172 msec * 

PC2#traceroute 100.100.100.100 
Type escape sequence to abort. 
Tracing the route to 100.100.100.100 

1 10.0.0.3 516 msec 300 msec 68 msec 
2 30.0.0.1 460 msec * 156 msec

GLBP Load balancing is done based on Weightage of Forwarder

Task 4: Verify GLBP Automatic Gateway Selection

Step 1: Shutdown one of the forwarder

R2 
interface f0/0
shutdown

Step 2: Verify GLBP Automatic Gateway selection to Router 3

R3: 
R3#debug glbp 
GLBP debugging is on 
*Mar 1 00:55:21.803: GLBP: Fa0/0 Grp 1 Hello in VG Standby pri 100 vIP 10.0.0.5 hello 
3000, hold 10000 VF 1 Active pri 167 vMAC 0007.b400.0101 
*Mar 1 00:55:22.167: GLBP: Fa0/0 Grp 1 Hello out VG Active pri 150 vIP 10.0.0.5 hello 
3000, hold 10000 VF 2 Active pri 167 vMAC 0007.b400.0102 
R3# 
*Mar 1 00:55:34.759: GLBP: Fa0/0 1 Standby router is unknown, was 10.0.0.2 
*Mar 1 00:55:34.763: GLBP: Fa0/0 1.1 Listen: g/Active timer expired 
*Mar 1 00:55:34.763: GLBP: Fa0/0 1.1 Listen -> Active 
*Mar 1 00:55:34.763: %GLBP-6-FWDSTATECHANGE: FastEthernet0/0 Grp 1 Fwd 1 state 
Listen -> Active 
R3# 
*Mar 1 00:55:34.771: GLBP: Fa0/0 Grp 1 Hello out VF 1 Active pri 135 vMAC 0007.b400.0101 
R3# 
*Mar 1 00:55:37.187: GLBP: Fa0/0 Grp 1 Hello out VG Active pri 150 vIP 10.0.0.5 hello 
3000, hold 10000 VF 1 Active pri 135 vMAC 0007.b400.0101 VF 2 Active pri 167 vMAC 
0007.b400.0102 
R3# 
*Mar 1 00:55:40.195: GLBP: Fa0/0 Grp 1 Hello out VG Active pri 150 vIP 10.0.0.5 hello 
3000, hold 10000 VF 1 Active pri 135 vMAC 0007.b400.0101 VF 2 Active pri 167 vMAC 
0007.b400.0102

When forwarder 1 fails or link goes down, then forwarder 2 will support both its own Virtual MAC address as well as Virtual MAC address of the failed Forwarder 1 i.e. Forwarder 2 will Active for both PCs Now traffic will only forwarded by Forwarder 2 for both PCs

R3#show glbp 
FastEthernet0/0 - Group 1 
State is Active 
1 state change, last state change 01:15:21 
Virtual IP address is 10.0.0.5 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 0.812 secs 
Redirect time 600 sec, forwarder timeout 14400 sec 
Preemption enabled, min delay 0 sec 
Active is local 
Standby is unknown 
Priority 150 (configured) 
Weighting 110 (configured 110), thresholds: lower 1, upper 110 
Load balancing: weighted 
Group members: 
c202.0c90.0000 (10.0.0.3) local 
There are 2 forwarders (2 active) 
Forwarder 1 
State is Active 
5 state changes, last state change 00:32:14 
MAC address is 0007.b400.0101 (learnt) 
Owner ID is c201.0c90.0000 
Redirection disabled 
Time to live: 12455.732 sec (maximum 14400 sec) 
Preemption enabled, min delay 30 sec 
Active is local, weighting 110 
Client selection count: 1 
Forwarder 2 
State is Active 
1 state change, last state change 01:16:13 
MAC address is 0007.b400.0102 (default) 
Owner ID is c202.0c90.0000 
Redirection enabled 
Preemption enabled, min delay 30 sec 
Active is local, weighting 110 
Client selection count: 1
R3#show glbp brief 
Interface   Grp   Fwd   Pri   State    Address          Active router    Standby router 
Fa0/0       1     -     150   Active   10.0.0.5         local            unknown 
Fa0/0       1     1      -    Active   0007.b400.0101   local             - 
Fa0/0       1     2      -    Active   0007.b400.0102   local             - 

Forwarder 2 will Active for both PCs Now traffic will only forwarded by Forwarder 2 for both PCs

PC1#ping 100.100.100.100 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 100.100.100.100, timeout is 2 seconds: 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 128/179/252 ms

PC1#traceroute 100.100.100.100 
Type escape sequence to abort. 
Tracing the route to 100.100.100.100 
 1 10.0.0.3 76 msec 60 msec 92 msec 
 2 30.0.0.1 80 msec * 184 msec 
PC2#ping 100.100.100.100 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 100.100.100.100, timeout is 2 seconds: 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 128/179/252 ms
PC2#traceroute 100.100.100.100 
Type escape sequence to abort. 
Tracing the route to 100.100.100.100 

1 10.0.0.3 76 msec 60 msec 92 msec 
 2 30.0.0.1 80 msec * 184 msec 

Task 5: Verify GLBP Automatic Gateway Selection when Serial link is down

Step 1: Shutdown the serial interface

R2: 
interface serial 1/0 
shutdown 
R2#show glbp 
FastEthernet0/0 - Group 1 
State is Standby 
1 state change, last state change 00:05:58 
Virtual IP address is 10.0.0.5 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 1.132 secs 
Redirect time 600 sec, forwarder timeout 14400 sec 
Preemption enabled, min delay 0 sec 
Active is 10.0.0.3, priority 150 (expires in 7.872 sec) 
Standby is local 
Priority 100 (default) 
Weighting 120 (configured 120), thresholds: lower 1, upper 120 
Load balancing: weighted 
Group members: 
c201.0360.0000 (10.0.0.2) local 
c202.0360.0000 (10.0.0.3) 
There are 2 forwarders (1 active) 
Forwarder 1 
State is Listen 
MAC address is 0007.b400.0101 (learnt) 
Owner ID is c202.0360.0000 
Time to live: 14397.872 sec (maximum 14400 sec) 
Preemption enabled, min delay 30 sec 
Active is 10.0.0.3 (primary), weighting 110 (expires in 8.236 sec) 
Forwarder 2 
State is Active 
1 state change, last state change 00:06:08 
MAC address is 0007.b400.0102 (default) 
Owner ID is c201.0360.0000 
Preemption enabled, min delay 30 sec 
Active is local, weighting 120 
R3: 
R3#debug glbp 
GLBP debugging is on 
R3# 
*Mar 1 00:14:20.255: GLBP: Fa0/0 Grp 1 Hello out VG Active pri 150 vIP 10.0.0.5 hello 
3000, hold 10000 VF 1 Active pri 167 vMAC 0007.b400.0101 
*Mar 1 00:14:20.627: GLBP: Fa0/0 Grp 1 Hello in VG Standby pri 100 vIP 10.0.0.5 hello 
3000, hold 10000 VF 2 Active pri 167 vMAC 0007.b400.0102 
R3# 
*Mar 1 00:14:23.263: GLBP: Fa0/0 Grp 1 Hello out VG Active pri 150 vIP 10.0.0.5 hello 
3000, hold 10000 VF 1 Active pri 167 vMAC 0007.b400.0101 
*Mar 1 00:14:23.687: GLBP: Fa0/0 Grp 1 Hello in VG Standby pri 100 vIP 10.0.0.5 hello 
3000, hold 10000 VF 2 Active pri 167 vMAC 0007.b400.0102

Step 2: Configure GLBP Track to track serial interface

R2: 
track 1 interface serial 1/0 line-protocol 
exit 
interface FastEthernet 0/0 
glbp 1 weighting 120 lower 1 
glbp 1 weighting track 1 decrement 50 
exit

Serial interface 1/0 is being tracked 

interface serial 1/0 
shutdown 

*Mar 1 01:02:03.619: %TRACKING-5-STATE: 1 interface Se1/0 line-protocol Up->Down 
R2(config-if)#exit 
*Mar 1 01:02:05.579: %LINK-5-CHANGED: Interface Serial1/0, changed state to 
administratively down 
*Mar 1 01:02:06.579: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, 
changed state to down

Step 3: Verify GLBP Automatic Gateway selection to Router 3 form Standby state to Active state

R2: 
R2#show glbp 
FastEthernet0/0 - Group 1 
State is Standby 
1 state change, last state change 02:35:43 
Virtual IP address is 10.0.0.5 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 2.004 secs 
Redirect time 600 sec, forwarder timeout 14400 sec 
Preemption enabled, min delay 0 sec 
Active is 10.0.0.3, priority 150 (expires in 8.472 sec) 
Standby is local 
Priority 100 (default) 
Weighting 70 (configured 120), thresholds: lower 1, upper 120 
Track object 1 state Down decrement 50 
Load balancing: weighted 
Group members: 
c201.0360.0000 (10.0.0.2) local 
c202.0360.0000 (10.0.0.3) 
There are 2 forwarders (1 active) 
Forwarder 1 
State is Listen 
MAC address is 0007.b400.0101 (learnt) 
Owner ID is c202.0360.0000 
Time to live: 14398.476 sec (maximum 14400 sec) 
Preemption enabled, min delay 30 sec 
Active is 10.0.0.3 (primary), weighting 110 (expires in 7.864 sec) 
Forwarder 2 
State is Active 
1 state change, last state change 02:36:05 
MAC address is 0007.b400.0102 (default) 
Owner ID is c201.0360.0000 
Preemption enabled, min delay 30 sec 
Active is local, weighting 70