In advanced switching configurations, the integration of the Gateway Load Balancing Protocol (GLBP) represents a sophisticated approach to optimizing network efficiency and availability. Primarily designed for default gateway redundancy, GLBP enables collaboration among multiple layer 3 switches, collectively presenting a virtual IP address and a set of virtual MAC addresses as a shared gateway to connected devices. In advanced switching environments, GLBP introduces sophisticated load-balancing mechanisms, distributing traffic intelligently across available routers to prevent congestion and maximize resource utilization. This protocol's redundancy features designate one router as the active virtual gateway, with others serving as backups, ensuring seamless failover in the event of hardware failures. The advanced capabilities of GLBP make it a valuable asset in complex network architectures where efficient traffic distribution, fault tolerance, and high availability are critical considerations for maintaining optimal network performance.
GLBP Topology
Task 1: Configure GLBP
Step 1: Configure Initial Configuration
R1:
hostname EDGE_1
ip route 0.0.0.0 0.0.0.0 101.0.0.2
interface ethernet 0/0
ip address 10.0.0.251 255.255.255.0
no shutdown
ip nat inside
interface ethernet 0/1
ip address 101.0.0.1 255.255.255.0
no shutdown
ip nat outside
ip nat inside source list 1 interface ethernet 0/1 overload
access-list 1 permit any
exit
R2:
hostname EDGE_2
ip route 0.0.0.0 0.0.0.0 102.0.0.2
interface ethernet 0/0
ip address 10.0.0.252 255.255.255.0
ip nat inside
no shutdown
interface ethernet 0/1
ip address 102.0.0.1 255.255.255.0
ip nat outside
no shutdown
ip nat inside source list 1 interface ethernet 0/1 overload
access-list 1 permit any
R3:
hostname EDGE_3
ip route 0.0.0.0 0.0.0.0 103.0.0.2
interface ethernet 0/0
ip address 10.0.0.253 255.255.255.0
ip nat inside
no shutdown
interface ethernet 0/1
ip address 103.0.0.1 255.255.255.0
ip nat outside
no shutdown
ip nat inside source list 1 interface ethernet 0/1 overload
access-list 1 permit any
exit
R4:
hostname INTERNET
interface ethernet 0/1
ip address 101.0.0.2 255.255.255.0
no shutdown
interface ethernet 0/2
ip address 102.0.0.2 255.255.255.0
no shutdown
interface ethernet 0/3
ip address 103.0.0.2 255.255.255.0
no shutdown
interface loopback 0
ip address 200.0.0.1 255.255.255.255
exit
R5:
hostname HOST1
interface ethernet 0/0
ip address 10.0.0.1 255.255.255.0
no shutdown
ip route 0.0.0.0 0.0.0.0 10.0.0.254
exit
R6:
hostname HOST2
interface ethernet 0/0
ip address 10.0.0.2 255.255.255.0
no shutdown
ip route 0.0.0.0 0.0.0.0 10.0.0.254
exit
R7:
hostname HOST3
interface ethernet 0/0
ip address 10.0.0.3 255.255.255.0
no shutdown
ip route 0.0.0.0 0.0.0.0 10.0.0.254
exit
R8:
hostname HOST4
interface ethernet 0/0
ip address 10.0.0.4 255.255.255.0
no shutdown
ip route 0.0.0.0 0.0.0.0 10.0.0.254
exit
SW9:
hostname ACCESS_SWITCH
interface range ethernet0/0-3,ethernet1/0-3
switchport mode access
switchport access vlan 10
exit
Step 2: Configure Basic GLBP Configuration
Configure R1, R2, and R3 to perform forwarding via GLBP. R1 should become AVG and R2 should be second preference.
R1:
interface Ethernet0/0
glbp 10 ip 10.0.0.254
glbp 10 priority 200
glbp 10 preempt
exit
R2:
interface Ethernet0/0
glbp 10 ip 10.0.0.254
glbp 10 priority 150
glbp 10 preempt
exit
R3:
interface Ethernet0/0
glbp 10 ip 10.0.0.254
exit
Task 2: Verification
Step 1: Verify Gateway State and GLBP Round Robin Load Balancing
EDGE_1#show glbp
Ethernet0/0 - Group 10
State is Active
1 state change, last state change 00:50:26
Virtual IP address is 10.0.0.254
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.216 secs
Redirect time 600 sec, forwarder timeout 14400 sec
Preemption enabled, min delay 0 sec
Active is local
Standby is 10.0.0.252, priority 150 (expires in 7.232 sec)
Priority 200 (configured)
Weighting 100 (default 100), thresholds: lower 1, upper 100
Load balancing: round-robin
Group members:
aabb.cc00.0100 (10.0.0.251) local
aabb.cc00.0200 (10.0.0.252)
aabb.cc00.0300 (10.0.0.253)
There are 3 forwarders (1 active)
Forwarder 1
State is Active
1 state change, last state change 00:50:15
MAC address is 0007.b400.0a01 (default)
Owner ID is aabb.cc00.0100
Redirection enabled
Preemption enabled, min delay 30 sec
Active is local, weighting 100
Client selection count: 2
Forwarder 2
State is Listen
MAC address is 0007.b400.0a02 (learnt)
Owner ID is aabb.cc00.0200
Redirection enabled, 597.248 sec remaining (maximum 600 sec)
Time to live: 14397.248 sec (maximum 14400 sec)
Preemption enabled, min delay 30 sec
Active is 10.0.0.252 (primary), weighting 100 (expires in 8.288 sec)
Client selection count: 2
Forwarder 3
State is Listen
MAC address is 0007.b400.0a03 (learnt)
Owner ID is aabb.cc00.0300
Redirection enabled, 597.376 sec remaining (maximum 600 sec)
Time to live: 14397.376 sec (maximum 14400 sec)
Preemption enabled, min delay 30 sec
Active is 10.0.0.253 (primary), weighting 100 (expires in 9.088 sec)
Client selection count: 1
EDGE_2#show glbp
Ethernet0/0 - Group 10
State is Standby
1 state change, last state change 01:12:02
Virtual IP address is 10.0.0.254
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.496 secs
Redirect time 600 sec, forwarder timeout 14400 sec
Preemption enabled, min delay 0 sec
Active is 10.0.0.251, priority 200 (expires in 10.368 sec)
Standby is local
Priority 150 (configured)
Weighting 100 (default 100), thresholds: lower 1, upper 100
Load balancing: round-robin
Group members:
aabb.cc00.0100 (10.0.0.251)
aabb.cc00.0200 (10.0.0.252) local
aabb.cc00.0300 (10.0.0.253)
There are 3 forwarders (1 active)
Forwarder 1
State is Listen
MAC address is 0007.b400.0a01 (learnt)
Owner ID is aabb.cc00.0100
Time to live: 14399.808 sec (maximum 14400 sec)
Preemption enabled, min delay 30 sec
Active is 10.0.0.251 (primary), weighting 100 (expires in 10.176 sec)
Forwarder 2
State is Active
1 state change, last state change 01:12:06
MAC address is 0007.b400.0a02 (default)
Owner ID is aabb.cc00.0200
Preemption enabled, min delay 30 sec
Active is local, weighting 100
Forwarder 3
State is Listen
MAC address is 0007.b400.0a03 (learnt)
Owner ID is aabb.cc00.0300
Time to live: 14398.400 sec (maximum 14400 sec)
Preemption enabled, min delay 30 sec
Active is 10.0.0.253 (primary), weighting 100 (expires in 8.608 sec)
EDGE_3#show glbp
Ethernet0/0 - Group 10
State is Listen
Virtual IP address is 10.0.0.254
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.576 secs
Redirect time 600 sec, forwarder timeout 14400 sec
Preemption disabled
Active is 10.0.0.251, priority 200 (expires in 9.440 sec)
Standby is 10.0.0.252, priority 150 (expires in 9.792 sec)
Priority 100 (default)
Weighting 100 (default 100), thresholds: lower 1, upper 100
Load balancing: round-robin
Group members:
aabb.cc00.0100 (10.0.0.251)
aabb.cc00.0200 (10.0.0.252)
aabb.cc00.0300 (10.0.0.253) local
There are 3 forwarders (1 active)
Forwarder 1
State is Listen
MAC address is 0007.b400.0a01 (learnt)
Owner ID is aabb.cc00.0100
Time to live: 14397.632 sec (maximum 14400 sec)
Preemption enabled, min delay 30 sec
Active is 10.0.0.251 (primary), weighting 100 (expires in 9.568 sec)
Forwarder 2
State is Listen
MAC address is 0007.b400.0a02 (learnt)
Owner ID is aabb.cc00.0200
Time to live: 14399.808 sec (maximum 14400 sec)
Preemption enabled, min delay 30 sec
Active is 10.0.0.252 (primary), weighting 100 (expires in 11.520 sec)
Forwarder 3
State is Active
1 state change, last state change 00:03:30
MAC address is 0007.b400.0a03 (default)
Owner ID is aabb.cc00.0300
Preemption enabled, min delay 30 sec
Active is local, weighting 100
EDGE_1#show glbp brief
Interface Grp Fwd Pri State Address Active router Standby router
Et0/0 10 - 200 Active 10.0.0.254 local 10.0.0.252
Et0/0 10 1 - Active 0007.b400.0a01 local -
Et0/0 10 2 - Listen 0007.b400.0a02 10.0.0.252 -
Et0/0 10 3 - Listen 0007.b400.0a03 10.0.0.253 -
EDGE_2#show glbp brief
Interface Grp Fwd Pri State Address Active router Standby router
Et0/0 10 - 150 Standby 10.0.0.254 10.0.0.251 local
Et0/0 10 1 - Listen 0007.b400.0a01 10.0.0.251 -
Et0/0 10 2 - Active 0007.b400.0a02 local -
Et0/0 10 3 - Listen 0007.b400.0a03 10.0.0.253 -
EDGE_3#show glbp brief
Interface Grp Fwd Pri State Address Active router Standby router
Et0/0 10 - 100 Listen 10.0.0.254 10.0.0.251 10.0.0.252
Et0/0 10 1 - Listen 0007.b400.0a01 10.0.0.251 -
Et0/0 10 2 - Listen 0007.b400.0a02 10.0.0.252 -
Et0/0 10 3 - Active 0007.b400.0a03 local -
HOST1#show ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.0.1 - aabb.cc00.0500 ARPA Ethernet0/0
HOST1#debug arp
ARP packet debugging is on
HOST1#ping 10.0.0.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.254, timeout is 2 seconds:
*Jun 16 06:54:34.374: IP ARP: creating incomplete entry for IP address: 10.0.0.254
interface Ethernet0/0
*Jun 16 06:54:34.382: IP ARP: sent req src 10.0.0.1 aabb.cc00.0500,
dst 10.0.0.254 0000.0000.0000 Ethernet0/0
*Jun 16 06:54:34.397: IP ARP: rcvd rep src 10.0.0.254 0007.b400.0a01, dst 10.0.0
.1 Ethernet0/0.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms
HOST1#show ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.0.1 - aabb.cc00.0500 ARPA Ethernet0/0
Internet 10.0.0.254 0 0007.b400.0a01 ARPA Ethernet0/0
In the first ARP Broadcast by HOST1, the Mac address of EDGE_1 was provided.
HOST2#ping 10.0.0.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.254, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/2 ms
HOST2#show ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.0.1 - aabb.cc00.0500 ARPA Ethernet0/0
Internet 10.0.0.254 0 0007.b400.0a02 ARPA Ethernet0/0
The second time around ARP Broadcast by HOST2, the Mac address of EDGE_2 was
provided.
HOST3#ping 10.0.0.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.254, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/2 ms
HOST3#show ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.0.1 - aabb.cc00.0500 ARPA Ethernet0/0
Internet 10.0.0.254 0 0007.b400.0a03 ARPA Ethernet0/0
The third time around ARP Broadcast by HOST3, EDGE_3 Mac address was provided.
HOST1#ping 10.0.0.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.254, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/2 ms
HOST1#show ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.0.1 - aabb.cc00.0500 ARPA Ethernet0/0
Internet 10.0.0.254 0 0007.b400.0a01 ARPA Ethernet0/0
So due to the round robin effect, EDGE_1 is again first in queue. Hence again ARP Broadcast send by HOST1, EDGE_1 Mac address was provided GLBP Load balancing is done by using Round Robin
Task 3: GLBP Weighted Load balancing
Step 1: Configure GLBP Load balancing based on Weight
EDGE_1:
interface ethernet 0/0
glbp 10 weight 50
glbp 10 load-balancing weighted
exit
EDGE_2:
interface ethernet 0/0
glbp 10 weight 30
glbp 10 load-balancing weighted
exit
EDGE_3:
interface ethernet 0/0
glbp 10 weight 20
glbp 10 load-balancing weighted
exit
Step 2: Verify GLBP Weighted Load balancing
EDGE_1#show glbp | inc Weight
Load balancing: weighted
Active is local, weighting 50
Active is 10.0.0.252 (primary), weighting 30 (expires in 9.696 sec)
Active is 10.0.0.253 (primary), weighting 20 (expires in 9.184 sec)
EDGE_2#show glbp | inc Weight
Load balancing: weighted
Active is 10.0.0.251 (primary), weighting 50 (expires in 9.632 sec)
Active is local, weighting 30
Active is 10.0.0.253 (primary), weighting 20 (expires in 9.792 sec)
EDGE_3#show glbp | inc Weight
Load balancing: weighted
Active is 10.0.0.251 (primary), weighting 50 (expires in 8.832 sec)
Active is 10.0.0.252 (primary), weighting 30 (expires in 7.872 sec)
Active is local, weighting 20
HOST1#show ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.0.1 - aabb.cc00.0500 ARPA Ethernet0/0
HOST1#ping 10.0.0.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.254, timeout is 2 seconds:
.!!!!
Success rate is 60 percent (3/5), round-trip min/avg/max = 1/1/1 ms
HOST1#show ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.0.1 - aabb.cc00.0500 ARPA Ethernet0/0
Internet 10.0.0.254 49 0007.b400.0a01 ARPA Ethernet0/0
HOST1 Arp Reveals Gateway as Edge_1
HOST2#show ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.0.2 - aabb.cc00.0500 ARPA Ethernet0/0
HOST2#ping 10.0.0.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.254, timeout is 2 seconds:
.!!!!
Success rate is 60 percent (3/5), round-trip min/avg/max = 1/1/1 ms
HOST2#show ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.0.2 - aabb.cc00.0500 ARPA Ethernet0/0
Internet 10.0.0.254 0 0007.b400.0a02 ARPA Ethernet0/0
HOST2 Arp Reveals Gateway as Edge_2
HOST3#show ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.0.3 - aabb.cc00.0500 ARPA Ethernet0/0
HOST3#ping 10.0.0.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.254, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms
HOST3#show ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.0.3 - aabb.cc00.0500 ARPA Ethernet0/0
Internet 10.0.0.254 0 0007.b400.0a03 ARPA Ethernet0/0
HOST3 Arp Reveals Gateway as Edge_3
HOST1#show ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.0.1 - aabb.cc00.0500 ARPA Ethernet0/0
HOST1#ping 10.0.0.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.254, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms
HOST1#show ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.0.1 - aabb.cc00.0500 ARPA Ethernet0/0
Internet 10.0.0.254 0 0007.b400.0a01 ARPA Ethernet0/0
HOST1 Arp Reveals Gateway as Edge_1
Load Balancing is done based on weight of gateway
Task 3: GLBP Tracking
Configure R1, R2 & R3 such that they would move to listen state if their WAN interfaces were to go down.
Step 1: Configure GLBP Track to track WAN interface
EDGE_1:
track 1 interface Ethernet0/1 line-protocol
interface Ethernet0/0
glbp 10 weighting 50 lower 1
glbp 10 weighting track 1 decrement 50
exit
EDGE_2:
track 1 interface Ethernet0/1 line-protocol
interface Ethernet0/0
glbp 10 weighting 30 lower 1
glbp 10 weighting track 1 decrement 30
exit
EDGE_3:
track 1 interface Ethernet0/1 line-protocol
interface Ethernet0/0
glbp 10 weighting 30 lower 1
glbp 10 weighting track 1 decrement 30
exit
Step 2: Verify GLBP Tracking
EDGE_1#show glbp
Ethernet0/0 - Group 10
State is Active
1 state change, last state change 01:58:31
Virtual IP address is 10.0.0.254
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.152 secs
Redirect time 600 sec, forwarder timeout 14400 sec
Preemption enabled, min delay 0 sec
Active is local
Standby is 10.0.0.252, priority 150 (expires in 8.608 sec)
Priority 200 (configured)
Weighting 50 (configured 50), thresholds: lower 1, upper 50
Track object 1 state Up decrement 50
EDGE_1#show track 1
Track 1
Interface Ethernet0/1 line-protocol
Line protocol is Up
1 change, last change 00:05:33
Tracked by:
GLBP Ethernet0/0 10
EDGE_2#show glbp
Ethernet0/0 - Group 10
State is Standby
1 state change, last state change 01:59:28
Virtual IP address is 10.0.0.254
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.304 secs
Redirect time 600 sec, forwarder timeout 14400 sec
Preemption enabled, min delay 0 sec
Active is 10.0.0.251, priority 200 (expires in 10.176 sec)
Standby is local
Priority 150 (configured)
Weighting 30 (configured 30), thresholds: lower 1, upper 30
Track object 1 state Up decrement 30
EDGE_2#show track 1
Track 1
Interface Ethernet0/1 line-protocol
Line protocol is Up
1 change, last change 00:02:38
Tracked by:
GLBP Ethernet0/0 10
EDGE_3#show glbp
Ethernet0/0 - Group 10
State is Listen
Virtual IP address is 10.0.0.254
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.800 secs
Redirect time 600 sec, forwarder timeout 14400 sec
Preemption disabled
Active is 10.0.0.251, priority 200 (expires in 10.176 sec)
Standby is 10.0.0.252, priority 150 (expires in 7.040 sec)
Priority 100 (default)
Weighting 30 (configured 30), thresholds: lower 1, upper 30
Track object 1 state Up decrement 30
EDGE_3#show track 1
Track 1
Interface Ethernet0/1 line-protocol
Line protocol is Up
1 change, last change 00:03:29
Tracked by:
GLBP Ethernet0/0 10
Step 3: Shutdown WAN interface of EDGE_1 for verification for Track Decrement
R1:
EDGE_1#debug glbp events
interface ethernet 0/1
shutdown
*Oct 2 11:18:34.533: %TRACKING-5-STATE: 1 interface Et0/1 line-protocol Up->Down
*Oct 2 11:18:34.533: GLBP: Et0/0 10 Track 1 object changed, state Up -> Down
*Oct 2 11:18:34.533: GLBP: Et0/0 10 Weighting 50 -> 0
*Oct 2 11:18:37.540: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1,
changed state to down
*Oct 2 11:19:05.475: GLBP: Et0/0 10.1 Active: i/Hello rcvd from higher pri Active router
(135/10.0.0.252)
*Oct 2 11:19:05.475: GLBP: Et0/0 10.1 Active -> Listen
EDGE_1(config)#int ethernet 0/1
*Oct 2 11:19:05.475: %GLBP-6-FWDSTATECHANGE: Ethernet0/0 Grp 10 Fwd 1 state
Active -> Listen
EDGE_1#show glbp | inc Forwarder|State|MAC
State is Active
Forwarder 1
State is Listen
MAC address is 0007.b400.0a01 (default)
Forwarder 2
State is Listen
MAC address is 0007.b400.0a02 (learnt)
Forwarder 3
State is Listen
MAC address is 0007.b400.0a03 (learnt)
EDGE_2#show glbp | inc Forwarder|State|MAC
State is Standby
Forwarder 1
State is Listen
MAC address is 0007.b400.0a01 (learnt)
Forwarder 2
State is Active
MAC address is 0007.b400.0a02 (default)
Forwarder 3
State is Listen
MAC address is 0007.b400.0a03 (learnt)
EDGE_3#show glbp | inc Forwarder|State|MAC
State is Listen
Forwarder 1
State is Active
MAC address is 0007.b400.0a01 (learnt)
Forwarder 2
State is Listen
MAC address is 0007.b400.0a02 (learnt)
Forwarder 3
State is Active
MAC address is 0007.b400.0a03 (default)
Now EDGE_3 is active forwarder for both 0007.b400.0a01 (EDGE_1 mac) as well as
0007.b400.0a03 (its own mac)
Step 4: Shutdown WAN interface of EDGE_3 for verification for Track Decrement
R3:
interface ethernet 0/1
shutdown
*Oct 7 14:52:55.096: %TRACKING-5-STATE: 1 interface Et0/1 line-protocol Up->Down
EDGE_2#
*Oct 7 15:50:01.554: %GLBP-6-FWDSTATECHANGE: Ethernet0/0 Grp 10 Fwd 1 state
Listen -> Active
*Oct 7 15:50:01.555: %GLBP-6-FWDSTATECHANGE: Ethernet0/0 Grp 10 Fwd 3 state
Listen -> Active
EDGE_2#show glbp | inc Forward|State|MAC
State is Standby
Forwarder 1
State is Active
MAC address is 0007.b400.0a01 (learnt)
Forwarder 2
State is Active
MAC address is 0007.b400.0a02 (default)
Forwarder 3
State is Active
MAC address is 0007.b400.0a03 (learnt)
Now EDGE_2 is active forwarder for EDGE_1 0007.b400.0a01 and EDGE_3
0007.b400.0a03 as well as 0007.b400.0a02 (its own mac)
Task 3: GLBP MD5 Authentication
Step 1: Configure GLBP MD5 Authentication
R1:
interface ethernet 0/0
glbp 10 authentication md5 key-string cisco
exit
R2:
interface ethernet 0/0
glbp 10 authentication md5 key-string cisco
exit
R3:
interface ethernet 0/0
glbp 10 authentication md5 key-string cisco
exit
Step 2: GLBP MD5 Authentication Verification
EDGE_1#show glbp
Ethernet0/0 - Group 10
State is Active
1 state change, last state change 01:55:51
Virtual IP address is 10.0.0.254
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.824 secs
Redirect time 600 sec, forwarder timeout 14400 sec
Authentication MD5, key-string
Preemption enabled, min delay 0 sec
Active is local
Standby is 10.0.0.252, priority 150 (expires in 9.152 sec)
Priority 200 (configured)
Weighting 50 (configured 50), thresholds: lower 1, upper 50
Track object 1 state Up decrement 50
Load balancing: weighted
Group members:
aabb.cc00.0100 (10.0.0.251) local
aabb.cc00.0200 (10.0.0.252) authenticated
aabb.cc00.0300 (10.0.0.253) authenticated
There are 3 forwarders (1 active)
Forwarder 1
State is Active
5 state changes, last state change 00:10:12
MAC address is 0007.b400.0a01 (default)
Owner ID is aabb.cc00.0100
Redirection enabled
Preemption enabled, min delay 30 sec
Active is local, weighting 50
Client selection count: 1
Forwarder 2
State is Listen
2 state changes, last state change 00:01:00
MAC address is 0007.b400.0a02 (learnt)
Owner ID is aabb.cc00.0200
Redirection enabled, 599.168 sec remaining (maximum 600 sec)
Time to live: 14399.168 sec (maximum 14400 sec)
Preemption enabled, min delay 30 sec
Active is 10.0.0.252 (primary), weighting 30 (expires in 9.984 sec)
Forwarder 3
State is Listen
2 state changes, last state change 00:00:54
MAC address is 0007.b400.0a03 (learnt)
Owner ID is aabb.cc00.0300
Redirection enabled, 598.592 sec remaining (maximum 600 sec)
Time to live: 14398.592 sec (maximum 14400 sec)
Preemption enabled, min delay 30 sec
Active is 10.0.0.253 (primary), weighting 30 (expires in 9.184 sec)
R2:
EDGE_2#show glbp
Ethernet0/0 - Group 10
State is Standby
4 state changes, last state change 00:06:59
Virtual IP address is 10.0.0.254
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.760 secs
Redirect time 600 sec, forwarder timeout 14400 sec
Authentication MD5, key-string
Preemption enabled, min delay 0 sec
Active is 10.0.0.251, priority 200 (expires in 9.216 sec)
Standby is local
Priority 150 (configured)
Weighting 30 (configured 30), thresholds: lower 1, upper 30
Track object 1 state Up decrement 30
Load balancing: weighted
Group members:
aabb.cc00.0100 (10.0.0.251) authenticated
aabb.cc00.0200 (10.0.0.252) local
aabb.cc00.0300 (10.0.0.253) authenticated
There are 3 forwarders (1 active)
Forwarder 1
State is Listen
6 state changes, last state change 00:08:15
MAC address is 0007.b400.0a01 (learnt)
Owner ID is aabb.cc00.0100
Time to live: 14397.408 sec (maximum 14400 sec)
Preemption enabled, min delay 30 sec
Active is 10.0.0.251 (primary), weighting 50 (expires in 8.256 sec)
Forwarder 2
State is Active
1 state change, last state change 02:01:40
MAC address is 0007.b400.0a02 (default)
Owner ID is aabb.cc00.0200
Preemption enabled, min delay 30 sec
Active is local, weighting 30
Forwarder 3
State is Listen
2 state changes, last state change 00:15:48
MAC address is 0007.b400.0a03 (learnt)
Owner ID is aabb.cc00.0300
Time to live: 14397.984 sec (maximum 14400 sec)
Preemption enabled, min delay 30 sec
Active is 10.0.0.253 (primary), weighting 30 (expires in 8.544 sec)
R3:
EDGE_3#show glbp
Ethernet0/0 - Group 10
State is Listen
2 state changes, last state change 00:09:37
Virtual IP address is 10.0.0.254
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.032 secs
Redirect time 600 sec, forwarder timeout 14400 sec
Authentication MD5, key-string
Preemption disabled
Active is 10.0.0.251, priority 200 (expires in 9.216 sec)
Standby is 10.0.0.252, priority 150 (expires in 9.664 sec)
Priority 100 (default)
Weighting 30 (configured 30), thresholds: lower 1, upper 30
Track object 1 state Up decrement 30
Load balancing: weighted
Group members:
aabb.cc00.0100 (10.0.0.251) authenticated
aabb.cc00.0200 (10.0.0.252) authenticated
aabb.cc00.0300 (10.0.0.253) local
There are 3 forwarders (1 active)
Forwarder 1
State is Listen
4 state changes, last state change 00:09:35
MAC address is 0007.b400.0a01 (learnt)
Owner ID is aabb.cc00.0100
Time to live: 14399.104 sec (maximum 14400 sec)
Preemption enabled, min delay 30 sec
Active is 10.0.0.251 (primary), weighting 50 (expires in 9.376 sec)
Forwarder 2
State is Listen
MAC address is 0007.b400.0a02 (learnt)
Owner ID is aabb.cc00.0200
Time to live: 14399.680 sec (maximum 14400 sec)
Preemption enabled, min delay 30 sec
Active is 10.0.0.252 (primary), weighting 30 (expires in 11.456 sec)
Forwarder 3
State is Active
3 state changes, last state change 00:18:25
MAC address is 0007.b400.0a03 (default)
Owner ID is aabb.cc00.0300
Preemption enabled, min delay 30 sec
Active is local, weighting 30