Hot Standby Router Protocol - Switching Advance

HSRP CCIE

In advanced switching configurations, the integration of Hot Standby Router Protocol (HSRP) contributes to enhanced network resilience and high availability. Traditionally associated with routers, HSRP extends its capabilities to optimize switching environments, providing redundancy for default gateways. In advanced scenarios, multiple layer 3 switches collaborate to form an HSRP group, designating one as the active router and others as standby. This collective intelligence enables dynamic load balancing, fault tolerance, and seamless failover capabilities. The HSRP group presents a single virtual IP address to connected devices, ensuring continuous network availability even if the active switch encounters issues. The integration of HSRP in advanced switching environments underscores its adaptability, offering a robust solution for maintaining uninterrupted communication and access to network resources in complex network architectures.

Lab:

HSRP Topology

Task 1: Configure HSRP

Step 1: Configure Initial Configuration

R1: 
hostname EDGE_1 
ip route 0.0.0.0 0.0.0.0 101.0.0.2 
interface ethernet 0/0 
ip address 10.0.0.251 255.255.255.0 
no shutdown 
ip nat inside 
interface ethernet 0/1 
ip address 101.0.0.1 255.255.255.0 
no shutdown 
ip nat outside 
ip nat inside source list 1 interface ethernet 0/1 overload 
access-list 1 permit any 
exit 

R2: 
hostname EDGE_2 
ip route 0.0.0.0 0.0.0.0 102.0.0.2 
interface ethernet 0/0 
ip address 10.0.0.252 255.255.255.0 
ip nat inside 
no shutdown 
interface ethernet 0/1 
ip address 102.0.0.1 255.255.255.0 
ip nat outside 
no shutdown 
ip nat inside source list 1 interface ethernet 0/1 overload 
access-list 1 permit any 
exit 

R4: 
hostname INTERNET 
interface ethernet 0/1 
ip address 101.0.0.2 255.255.255.0 
no shutdown 
interface e0/2 
ip address 102.0.0.2 255.255.255.0 
no shutdown 
interface loopback 0 
ip add 200.0.0.1 255.255.255.255 
exit

R5: 
hostname HOST1 
interface ethernet 0/0 
ip add 10.0.0.1 255.255.255.0 
no shutdown 
ip route 0.0.0.0 0.0.0.0 10.0.0.254 
exit 

SW9: 
hostname ACCESS_SWITCH 
no ip domain-lookup 
interface range ethernet0/0-3,ethernet1/0-3 
switchport mode access 
switchport access vlan 10 
exit 

Step 2: Configure Basic HSRP Configuration

Configure HSRP on R1 & R2. Use Virtual address of 10.0.0.254. R1 should be the Active 
router
R1: 
interface ethernet 0/0 
standby 10 ip 10.0.0.254 
standby 10 priority 200 
exit 

R2: 
interface ethernet 0/0 
standby 10 ip 10.0.0.254 
exit 

Task 2: Verification

Step 1: Verify Active and Standby State in HSRP

R2: 
EDGE_1#sh standby 
Ethernet0/0 - Group 10 
State is Active 
2 state changes, last state change 01:43:29 
Virtual IP address is 10.0.0.254 
Active virtual MAC address is 0000.0c07.ac0a 
Local virtual MAC address is 0000.0c07.ac0a (v1 default) 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 0.176 secs 
Preemption disabled 
Active router is local 
Standby router is 10.0.0.252, priority 100 (expires in 8.768 sec) 
Priority 200 (configured 200) 
Group name is "hsrp-Et0/0-10" (default) 

EDGE_2#show standby 
Ethernet0/0 - Group 10 
State is Standby 
1 state change, last state change 01:45:52 
Virtual IP address is 10.0.0.254 
Active virtual MAC address is 0000.0c07.ac0a 
Local virtual MAC address is 0000.0c07.ac0a (v1 default) 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 0.528 secs 
Preemption disabled 
Active router is 10.0.0.251, priority 200 (expires in 10.256 sec) 
Standby router is local 
Priority 100 (default 100) 
Group name is "hsrp-Et0/0-10" (default)

EDGE_1#debug standby 
HSRP debugging is on 
*Jun 16 09:58:47.604: HSRP: Et0/0 Grp 10 Hello in 10.0.0.252 Standby pri 100 vIP 
10.0.0.254 
*Jun 16 09:58:48.341: HSRP: Et0/0 Grp 10 Hello out 10.0.0.251 Active pri 200 vIP 
10.0.0.254 
EDGE_1# 
*Jun 16 09:58:50.341: HSRP: Et0/0 Grp 10 Hello in 10.0.0.252 Standby pri 100 vIP 
10.0.0.254 
*Jun 16 09:58:50.879: HSRP: Et0/0 Grp 10 Hello out 10.0.0.251 Active pri 200 vIP 
10.0.0.254 

It is possible to have more than 2 routers in a HSRP group. If a 3rd router were to be 
introduced, then it would assume LISTEN STATE. 

Even though preemption is disabled for active routers by default, it is enabled for a 
standby router. If a higher ip address or priority router will come up than EDGE_2 which 
is in standby state, it will transition to standby and EDGE_2 will transition to LISTEN state.

Configure EDGE_3 with an IP Address of 10.0.0.253/24 and introduce it to the group. 

R3: 
hostname EDGE_3 
interface e0/0 
ip add 10.0.0.253 255.255.255.0 
no shutdown 
standby 10 ip 10.0.0.254 
exit 

EDGE_2# 
*Jun 16 06:26:18.517: %HSRP-5-STATECHANGE: Ethernet0/0 Grp 10 state Standby -> 
Listen 

EDGE_3# 
*Jun 16 06:26:29.729: %HSRP-5-STATECHANGE: Ethernet0/0 Grp 10 state Speak -> 
Standby 

Even though Preemption is not configured, standby router can change on basis of 
priority. In this case, EDGE_3 moved to STANDBY and EDGE_2 moved from STANDBY to 
LISTEN because Ip address of EDGE_3 was higher 

EDGE_1#show standby 
Ethernet0/0 - Group 10 
State is Active 
2 state changes, last state change 02:40:51 
Virtual IP address is 10.0.0.254 
Active virtual MAC address is 0000.0c07.ac0a 
Local virtual MAC address is 0000.0c07.ac0a (v1 default) 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 2.160 secs 
Preemption disabled 
Active router is local 
Standby router is 10.0.0.253, priority 100 (expires in 10.736 sec) 
Priority 200 (configured 200) 
Group name is "hsrp-Et0/0-10" (default)

EDGE_2#show standby 
Ethernet0/0 - Group 10 
State is Listen 
4 state changes, last state change 00:03:50 
Virtual IP address is 10.0.0.254 
Active virtual MAC address is 0000.0c07.ac0a 
Local virtual MAC address is 0000.0c07.ac0a (v1 default) 
Hello time 3 sec, hold time 10 sec 
Preemption disabled 
Active router is 10.0.0.251, priority 200 (expires in 9.280 sec) 
Standby router is 10.0.0.253, priority 100 (expires in 10.320 sec) 
Priority 100 (default 100) 
Group name is "hsrp-Et0/0-10" (default) 

EDGE_3#show standby 
Ethernet0/0 - Group 10 
State is Standby 
1 state change, last state change 00:04:17 
Virtual IP address is 10.0.0.254 
Active virtual MAC address is 0000.0c07.ac0a 
Local virtual MAC address is 0000.0c07.ac0a (v1 default) 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 0.176 secs 
Preemption disabled 
Active router is 10.0.0.251, priority 200 (expires in 9.904 sec) 
Standby router is local 
Priority 100 (default 100) 
Group name is "hsrp-Et0/0-10" (default)

Task 3: Understanding HSRP Failover for Active Routers

By Default, Preemption is not enabled. Which means that an active router will remain in active 
state even if a higher priority router is introduced into the network 

EDGE_1#show standby 
Ethernet0/0 - Group 10 
State is Active 
Preemption disabled 
Active router is local 
Standby router is 10.0.0.252, priority 100 (expires in 9.216 sec) 
Priority 200 (configured 200)

EDGE_2#show standby 
Ethernet0/0 - Group 10 
State is Standby 
Preemption disabled 
Active router is 10.0.0.251, priority 200 (expires in 8.608 sec) 
Standby router is local 
Priority 100 (default 100) 

**Step 1:** Shutdown the Active router to initiate failover 

R1: 
interface e0/0 
shutdown 

*Jun 16 09:06:02.861: %HSRP-5-STATECHANGE: Ethernet0/0 Grp 10 state Active -> Init 
*Jun 16 09:06:04.855: %LINK-5-CHANGED: Interface Ethernet0/0, changed state to 
administratively down

EDGE_2# 
*Jun 16 09:06:02.855: %HSRP-5-STATECHANGE: Ethernet0/0 Grp 10 state Standby -> 
Active 

R1: 
interface e0/0 
no shutdown 

*Jun 16 09:08:35.785: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up 
*Jun 16 09:08:57.484: %HSRP-5-STATECHANGE: Ethernet0/0 Grp 10 state Speak -> 
Standby 

The standby preempt command enables the Hot Standby Router Protocol (HSRP) router with the 
highest priority to immediately become the active router. When a higher priority router preempts 
a lower priority router, the router sends a Coup message. When a lower priority active router 
receives a Coup message or a Hello message from an active, higher priority router, the router 
changes to the Speak state and sends a resign message. 

Enable Preemption on EDGE_1 such that it becomes ACTIVE once it will initialize. 

Step 2: Preempt to claim status

R1: 
interface e0/0 
standby 10 preempt 
exit 

Step 3: Verify HSRP Failover for Active Router form Standby state to Active state

router (100/10.0.0.252) 
*Sep 10 11:33:46.590: HSRP: Et0/0 Grp 10 Active router is local, was 10.0.0.252 
*Jun 16 11:33:46.590: HSRP: Et0/0 Nbr 10.0.0.252 no longer active for group 10 
(Standby) 
*Jun 16 11:33:46.590: HSRP: Et0/0 Nbr 10.0.0.252 Was active or standby - start passive 
holddown 
*Jun 16 11:33:46.590: HSRP: Et0/0 Grp 10 Standby router is unknown, was local 
*Jun 16 11:33:46.590: HSRP: Et0/0 Grp 10 Standby -> Active 
*Jun 16 11:33:46.590: %HSRP-5-STATECHANGE: Ethernet0/0 Grp 10 state Standby -> 
Active 

EDGE_1#sh standby 
Ethernet0/0 - Group 10 
State is Active 
2 state changes, last state change 00:01:56 
Virtual IP address is 10.0.0.254 
Active virtual MAC address is 0000.0c07.ac0a 
Local virtual MAC address is 0000.0c07.ac0a (v1 default) 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 2.256 secs 
Preemption enabled 
Active router is local 
Standby router is 10.0.0.252, priority 100 (expires in 10.016 sec) 
Priority 200 (configured 200) 
Group name is "hsrp-Et0/0-10" (default)

Task 4: Verify HSRP Failover using HSRP Tracking

If Eth0/1 on EDGE_1 would go down, failover would not take place and all packets would be dropped on EDGE_1. Solution to this problem would be to track the interface pointing towards Service Provider. If the link would fail, then priority could be decreased on EDGE_1 to an extend that EDGE_2 would move to ACTIVE state.

Step 1: Configure HSRP Track

R1: 
int e0/0 
standby 10 track ethernet 0/1 101 
exit 

EDGE_1#show standby 
Ethernet0/0 - Group 10 
State is Active 
2 state changes, last state change 04:02:54 
Virtual IP address is 10.0.0.254 
Active virtual MAC address is 0000.0c07.ac0a 
Local virtual MAC address is 0000.0c07.ac0a (v1 default) 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 0.048 secs 
Preemption enabled 
Active router is local 
Standby router is 10.0.0.252, priority 100 (expires in 9.024 sec) 
Priority 200 (configured 200) 
Track interface Ethernet0/1 state Up decrement 101 
Group name is "hsrp-Et0/0-10" (default)

R1: 
int e0/1 
shutdown 
exit 

*Jun 1615:50:34.286: %TRACKING-5-STATE: 1 interface Et0/1 line-protocol Up->Down 
*Jun 1615:50:34.286: HSRP: Et0/0 Grp 10 Track 1 object changed, state Up -> Down 
*Jun 1615:50:34.286: HSRP: Et0/0 Grp 10 Priority 200 -> 99 
*Jun 16 15:50:37.288: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1, 
changed state to down

EDGE_1#show standby 
Ethernet0/0 - Group 10 
State is Active 
4 state changes, last state change 00:12:14 
Virtual IP address is 10.0.0.254 
Active virtual MAC address is 0000.0c07.ac0a 
Local virtual MAC address is 0000.0c07.ac0a (v1 default) 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 2.544 secs 
Preemption enabled 
Active router is local 
Standby router is 10.0.0.252, priority 100 (expires in 9.920 sec) 
Priority 99 (configured 200) 
Track interface Ethernet0/1 state Down decrement 101 
Group name is "hsrp-Et0/0-10" (default) 

Failover did not take place as Preemption is not enabled on 

EDGE_2 
R2: 
interface ethernet 0/0 
standby 10 preempt 
exit 

*Jun 16 16:06:14.552: HSRP: Et0/0 Grp 10 Standby: h/Hello rcvd from lower pri Active 
router (99/10.0.0.251) 
*Jun 16 16:06:14.552: HSRP: Et0/0 Grp 10 Active router is local, was 10.0.0.251
*Jun 16 16:06:14.552: HSRP: Et0/0 Nbr 10.0.0.251 no longer active for group 10 
(Standby) 
*Jun 16 16:06:14.552: HSRP: Et0/0 Nbr 10.0.0.251 Was active or standby - start passive 
holddown 
*Jun 16 16:06:14.552: HSRP: Et0/0 Grp 10 Standby router is unknown, was local 
*Jun 16 16:06:14.552: HSRP: Et0/0 Grp 10 Standby -> Active 
*Jun 16 16:06:14.552: %HSRP-5-STATECHANGE: Ethernet0/0 Grp 10 state Standby -> 
Active 
*Jun 16 10:06:42.738: HSRP: Et0/0 Grp 10 Hello in 10.0.0.251 Standby pri 99 vIP 
10.0.0.254 
*Jun 16 10:06:43.616: HSRP: Et0/0 Grp 10 Hello out 10.0.0.252 Active pri 100 vIP 
10.0.0.254 
EDGE_2# 
*Jun 16 10:06:45.337: HSRP: Et0/0 Grp 10 Hello in 10.0.0.251 Standby pri 99 vIP 
10.0.0.254 
*Jun 16 10:06:46.299: HSRP: Et0/0 Grp 10 Hello out 10.0.0.252 Active pri 100 vIP 
10.0.0.254

R1: 
int e0/1 
no shutdown 
exit 

*Jun 16 16:11:03.261: %TRACKING-5-STATE: 1 interface Et0/1 line-protocol Down->Up 
*Jun 16 16:11:03.261: HSRP: Et0/0 Grp 10 Track 1 object changed, state Down -> Up 
*Jun 16 16:11:03.261: HSRP: Et0/0 Grp 10 Priority 99 -> 200 
*Jun 16 16:11:04.612: HSRP: Et0/0 Grp 10 Standby: h/Hello rcvd from lower pri Active 
router (100/10.0.0.252) 
*Jun 16 16:11:04.612: HSRP: Et0/0 Grp 10 Active router is local, was 10.0.0.252
*Jun 16 16:11:04.612: HSRP: Et0/0 Nbr 10.0.0.252 no longer active for group 10 
(Standby) 
*Jun 16 16:11:04.612: HSRP: Et0/0 Nbr 10.0.0.252 Was active or standby - start passive 
holddown 
*Jun 16 16:11:04.612: HSRP: Et0/0 Grp 10 Standby router is unknown, was local 
*Jun 16 16:11:04.612: HSRP: Et0/0 Grp 10 Standby -> Active 
*Jun 16 16:11:04.612: %HSRP-5-STATECHANGE: Ethernet0/0 Grp 10 state Standby -> 
Active 
*Jun 16 16:11:04.612: HSRP: Et0/0 Grp 10 Redundancy "hsrp-Et0/0-10" state Standby -> 
Active

R2: 
*Jun 16 16:11:04.620: HSRP: Et0/0 Grp 10 Active: j/Coup rcvd from higher pri router 
(200/10.0.0.251) 
*Jun 16 16:11:04.620: HSRP: Et0/0 Grp 10 Active router is 10.0.0.251, was local 
*Jun 16 16:11:04.620: HSRP: Et0/0 Nbr 10.0.0.251 active for group 10 
*Jun 16 16:11:04.620: HSRP: Et0/0 Grp 10 Standby router is unknown, was 10.0.0.251 
*Jun 16 16:11:04.620: HSRP: Et0/0 Nbr 10.0.0.251 no longer standby for group 10 
(Active) 
*Jun 16 16:11:04.620: HSRP: Et0/0 Grp 10 Active -> Speak 
*Jun 16 16:11:04.620: %HSRP-5-STATECHANGE: Ethernet0/0 Grp 10 state Active -> 
Speak 
*Jun 16 16:11:14.812: HSRP: Et0/0 Grp 10 Standby router is local 
*Jun 16 16:11:14.812: HSRP: Et0/0 Grp 10 Speak -> Standby 
*Jun 16 16:11:14.813: %HSRP-5-STATECHANGE: Ethernet0/0 Grp 10 state Speak -> 
Standby 

Task 5: Verify HSRP Authentication

Step 1: Configure HSRP Authentication

R1: 
interface ethernet 0/0 
standby 10 authentication cisco 
exit 

EDGE_1#sh standby 
Ethernet0/0 - Group 10 
State is Active 
2 state changes, last state change 02:48:26 
Virtual IP address is 10.0.0.254 
Active virtual MAC address is 0000.0c07.ac0a 
Local virtual MAC address is 0000.0c07.ac0a (v1 default) 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 2.368 secs 
Preemption disabled 
Active router is local 
Standby router is 10.0.0.252, priority 100 (expires in 9.952 sec) 
Priority 200 (configured 200) 
Group name is "hsrp-Et0/0-10" (default) 

This proves that the peer is still authenticated if the password is cisco sent in clear text. 
If the key were to be sent via md5, authentication would fail. 

R1: 
interface ethernet 0/0 
standby 10 authentication md5 key-string cisco 
exit 

%HSRP-4-BADAUTH: Bad authentication from 10.0.0.252, group 10, remote state Active 
*Sep 11 12:18:31.096: HSRP: Et0/0 Grp 10 Auth failed for Hello pkt from 10.0.0.252, MD5 
confgd but no tlv 

Configure EDGE_2 to match authentication configured previously on EDGE_1 

R2: 
interface ethernet 0/0 
standby 10 authentication md5 key-string cisco 
exit

Step 2: Verify HSRP Authentication

EDGE_1#show standby 
Ethernet0/0 - Group 10 
State is Active 
2 state changes, last state change 02:57:10 
Virtual IP address is 10.0.0.254 
Active virtual MAC address is 0000.0c07.ac0a 
Local virtual MAC address is 0000.0c07.ac0a (v1 default) 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 1.808 secs 
Authentication MD5, key-string 
Preemption disabled 
Active router is local 
Standby router is 10.0.0.252, priority 100 (expires in 8.704 sec) 
Priority 200 (configured 200) 
Group name is "hsrp-Et0/0-10" (default) 

EDGE_2#show standby 
Ethernet0/0 - Group 10 
State is Standby 
7 state changes, last state change 00:00:49 
Virtual IP address is 10.0.0.254 
Active virtual MAC address is 0000.0c07.ac0a 
Local virtual MAC address is 0000.0c07.ac0a (v1 default) 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 1.472 secs 
Authentication MD5, key-string 
Preemption disabled 
Active router is 10.0.0.251, priority 200 (expires in 10.320 sec) 
Standby router is local 
Priority 100 (default 100) 
Group name is "hsrp-Et0/0-10" (default)

Task 5: Configure MHSRP (Multigroup Hot Standby Router Protocol)

Configure EDGE_1 and EDGE_2 such that 

EDGE_1 --> ACTIVE FOR VLAN 10 / STANDBY FOR VLAN 20 
EDGE_2 --> ACTIVE FOR VLAN 20 / STANDBY FOR VLAN 10 

HOST 1 ---> VLAN 10 ---> 10.0.0.1/24 ---> DFG:10.0.0.254 
HOST 2 ---> VLAN 10 ---> 10.0.0.2/24 ---> DFG:10.0.0.254 
HOST 3 ---> VLAN 20 ---> 20.0.0.1/24 ---> DFG:20.0.0.254 
HOST 4 ---> VLAN 20 ---> 20.0.0.2/24 ---> DFG:20.0.0.254 

EDGE_1 --> E0/0.10 --> VLAN 10 --> IP 10.0.0.251/24 --> STNDBY IP 10.0.0.254 -->PRI=200 
EDGE_1 --> E0/0.20 --> VLAN 20 --> IP 20.0.0.251/24 --> STNDBY IP 20.0.0.254 -->PRI=100 
EDGE_2 --> E0/0.10 --> VLAN 10 --> IP 10.0.0.252/24 --> STNDBY IP 10.0.0.254 -->PRI=200 
EDGE_2 --> E0/0.20 --> VLAN 20 --> IP 20.0.0.252/24 --> STNDBY IP 10.0.0.254 -->PRI=100 

EDGE_1 ---> TRACK E0/1 
EDGE_2 ---> TRACK E0/1 

Step 1: Configure Initial Configuration

R1: 
hostname EDGE_1 
ip route 0.0.0.0 0.0.0.0 101.0.0.2 
interface ethernet 0/0 
no shutdown 
interface ethernet 0/0.10 
encapsulation dot1q 10 
ip address 10.0.0.251 255.255.255.0 
interface ethernet 0/0.20 
encapsulation dot1q 20 
ip address 20.0.0.251 255.255.255.0 
interface ethernet 0/1 
ip address 101.0.0.1 255.255.255.0 
no shutdown 
exit

R2: 
hostname EDGE_2 
ip route 0.0.0.0 0.0.0.0 102.0.0.2 
interface ethernet 0/0 
no shutdown 
interface ethernet 0/0.10 
encapsulation dot1q 10 
ip address 10.0.0.252 255.255.255.0 
interface ethernet 0/0.20 
encapsulation dot1q 20 
ip address 20.0.0.252 255.255.255.0 
interface ethernet 0/1 
ip address 102.0.0.1 255.255.255.0 
no shutdown 
exit 

R4: 
hostname OUTSIDE 
interface ethernet 0/1 
ip address 101.0.0.2 255.255.255.0 
no shutdown 
interface ethernet 0/2 
ip address 102.0.0.2 255.255.255.0 
no shutdown 
interface ethernet 0/3 
ip address 103.0.0.2 255.255.255.0 
no shutdown 
interface loopback 0 
ip address 200.0.0.1 255.255.255.255 
exit 

R5: 
hostname HOST1 
no ip domain-lookup 
interface ethernet 0/0 
ip address 10.0.0.1 255.255.255.0 
no shutdown 
ip route 0.0.0.0 0.0.0.0 10.0.0.254 
exit

R6: 
hostname HOST2 
no ip domain-lookup 
interface ethernet 0/0 
ip address 10.0.0.2 255.255.255.0 
no shutdown 
ip route 0.0.0.0 0.0.0.0 10.0.0.254 
exit 

R7: 
hostname HOST3 
no ip domain-lookup 
interface ethernet 0/0 
ip address 20.0.0.1 255.255.255.0 
no shutdown 
ip route 0.0.0.0 0.0.0.0 20.0.0.254 
exit 

R8: 
hostname HOST4 
no ip domain-lookup 
interface ethernet 0/0 
ip address 20.0.0.2 255.255.255.0 
no shutdown 
ip route 0.0.0.0 0.0.0.0 20.0.0.254 
exit 

SW9: 
hostname ACCESS_SWITCH 
no ip domain-lookup 
interface range ethernet1/0-1 
switchport mode access 
switchport access vlan 10 
interface range ethernet1/2-3 
switchport mode access 
switchport access vlan 20 
interface range e0/0-3 
switchport trunk encap dot1q 
switchport mode trunk 
exit

Step 2: Configure Basic MHSRP

R1: 
interface ethernet 0/0 
no shutdown 
exit 
interface ethernet 0/0.10 
encapsulation dot1q 10 
ip address 10.0.0.251 255.255.255.0 
standby 10 ip 10.0.0.254 
standby 10 priority 200 
standby 10 preempt 
standby 10 track ethernet 0/1 101 
interface ethernet 0/0.20 
encapsulation dot1q 20 
ip address 20.0.0.251 255.255.255.0 
standby 20 ip 20.0.0.254 
standby 20 preempt 
exit 

R2: 
interface ethernet 0/0 
no shutdown 
exit 
interface ethernet 0/0.10 
encapsulation dot1q 10 
ip address 10.0.0.252 255.255.255.0 
standby 10 ip 10.0.0.254 
standby 10 preempt 
interface ethernet 0/0.20 
encapsulation dot1q 20 
ip address 20.0.0.252 255.255.255.0 
standby 20 ip 20.0.0.254 
standby 20 priority 200 
standby 20 preempt 
standby 20 track ethernet 0/1

Task 2: Verification

Step 1: Verify MHSRP

EDGE_1#show standby 
Ethernet0/0.10 - Group 10 
State is Active 
2 state changes, last state change 00:01:03 
Virtual IP address is 10.0.0.254 
Active virtual MAC address is 0000.0c07.ac0a 
Local virtual MAC address is 0000.0c07.ac0a (v1 default) 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 0.672 secs 
Preemption enabled 
Active router is local 
Standby router is 10.0.0.252, priority 100 (expires in 8.736 sec) 
Priority 200 (configured 200) 
Track interface Ethernet0/1 state Up decrement 101 
Group name is "hsrp-Et0/0.10-10" (default) 
Ethernet0/0.20 - Group 20 
State is Standby 
4 state changes, last state change 00:00:49 
Virtual IP address is 20.0.0.254 
Active virtual MAC address is 0000.0c07.ac14 
Local virtual MAC address is 0000.0c07.ac14 (v1 default) 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 2.304 secs 
Preemption enabled 
Active router is 20.0.0.252, priority 200 (expires in 7.680 sec) 
Standby router is local 
Priority 100 (default 100) 
Group name is "hsrp-Et0/0.20-20" (default) 

EDGE_2#show standby 
Ethernet0/0.10 - Group 10 
State is Standby 
1 state change, last state change 00:29:13 
Virtual IP address is 10.0.0.254 
Active virtual MAC address is 0000.0c07.ac0a 
Local virtual MAC address is 0000.0c07.ac0a (v1 default) 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 0.656 secs 
Preemption enabled 
Active router is 10.0.0.251, priority 200 (expires in 8.880 sec) 
Standby router is local 
Priority 100 (default 100) 
Group name is "hsrp-Et0/0.10-10" (default) 
Ethernet0/0.20 - Group 20

State is Active 
1 state change, last state change 00:29:32 
Virtual IP address is 20.0.0.254 
Active virtual MAC address is 0000.0c07.ac14 
Local virtual MAC address is 0000.0c07.ac14 (v1 default) 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 0.992 secs 
Preemption enabled 
Active router is local 
 Standby router is 20.0.0.251, priority 100 (expires in 11.184 sec) 
Priority 200 (configured 200) 
Track interface Ethernet0/1 state Up decrement 10 
Group name is "hsrp-Et0/0.20-20" (default) 

All traffic for VLAN 10 will exit via EDGE_1 as it is the active router for that VLAN. 
All traffic for VLAN 20 will exit via EDGE_2 as it is the active router for that VLAN.