Lab 2: Configuring Single Area OSPF Within Service Provider

Lab 2: Configuring Single Area OSPF Within Service Provider

Task 1: Configuration of IP Addresses with Service Provider

The following configuration needs to be configured

IP addressing for all nodes including Physical and Software Interfaces.

DeviceHostnameOperating systemInterfaceIP Address & Mask
Provider Edge 1PE1IOS10.0.23.2/24
Loopback 110.0.23.2/24
Provider 1P1IOS-XRGigabitEthernet 0/0/0/210.0.23.3/24
GigabitEthernet 0/0/0/310.0.34.3/24
Loopback 13.3.3.3/32
Route Reflector 1RR1IOS-XRGigabitEthernet 0/0/0/310.0.34.4/24
GigabitEthernet 0/0/0/210.0.45.4/24
Loopback 14.4.4.4/32
Provider 2P2IOSEthernet 0/210.0.45.5/24
Ethernet 0/310.0.56.5/24
Loopback 15.5.5.5/32
Provider Edge 2PE2IOS-XRGigabitEthernet 0/0/0/4
Loopback 1Area 0

Task 2: Verify IP Addresses Configured within the Service Provider.

PE1#show ip interface brief
Interface                  	IP-Address	        OK? Method 	Status               	    Protocol
Ethernet0/0                	unassigned      	YES unset  	administratively down 	    down    
Ethernet0/1                	unassigned      	YES unset  	administratively down 	    down    
Ethernet0/2                	10.0.23.2       	YES manual 	up                          up      
Ethernet0/3                	unassigned      	YES unset  	administratively down 	    down    
Loopback1                  	2.2.2.2         	YES manual 	up                          up      
    
RP/0/0/CPU0:P1#show  ipv4 interface brief
Interface                      	IP-Address	        Status		        Protocol 	Vrf-Name
Loopback1                      	3.3.3.3         	Up              	Up       	default 
MgmtEth0/0/CPU0/0              	unassigned      	Shutdown        	Down     	default 
GigabitEthernet0/0/0/0         	unassigned      	Shutdown        	Down     	default 
GigabitEthernet0/0/0/1         	unassigned      	Shutdown        	Down     	default 
GigabitEthernet0/0/0/2         	10.0.23.3       	Up              	Up       	default 
GigabitEthernet0/0/0/3         	10.0.34.3       	Up              	Up       	default 
GigabitEthernet0/0/0/4         	unassigned      	Shutdown        	Down     	default

RP/0/0/CPU0:RR1#show ipv4 interface brief
Interface                      	IP-Address      	Status          	Protocol 	Vrf-Name
Loopback1                      	4.4.4.4         	Up              	Up       	default 
MgmtEth0/0/CPU0/0              	unassigned      	Shutdown        	Down     	default 
GigabitEthernet0/0/0/0         	unassigned      	Shutdown        	Down     	default 
GigabitEthernet0/0/0/1         	unassigned      	Shutdown        	Down     	default 
GigabitEthernet0/0/0/2         	10.0.45.4       	Up              	Up       	default 
GigabitEthernet0/0/0/3         	10.0.34.4       	Up              	Up       	default 
GigabitEthernet0/0/0/4         	unassigned      	Shutdown        	Down     	default
    
P2#show ip interface brief
Interface                  	IP-Address	        OK? Method 	Status                		Protocol
Ethernet0/0                	unassigned      	YES NVRAM  	administratively down           down    
Ethernet0/1                	unassigned      	YES NVRAM  	administratively down           down    
Ethernet0/2                	10.0.45.5       	YES NVRAM  	up                    		up      
Ethernet0/3                	10.0.56.5       	YES NVRAM  	up                    		up      
Loopback1                  	5.5.5.5         	YES NVRAM  	up                    		up
    
RP/0/0/CPU0:PE2#show ipv4 interface brief
Interface                      	IP-Address	        Status		        Protocol	Vrf-Name
Loopback1                      	6.6.6.6         	Up              	Up       	default 
MgmtEth0/0/CPU0/0              	unassigned      	Shutdown        	Down     	default 
GigabitEthernet0/0/0/0         	unassigned      	Shutdown        	Down     	default 
GigabitEthernet0/0/0/1         	unassigned      	Shutdown        	Down     	default 
GigabitEthernet0/0/0/2         	unassigned      	Shutdown        	Down     	default 
GigabitEthernet0/0/0/3         	10.0.56.6       	Up              	Up       	default 
GigabitEthernet0/0/0/4         	unassigned      	Shutdown        	Down     	default
    

Task 3: Configure OSPF within AS 3

Use the following parameters to configure OSPF within the Service Provider

DeviceOSPF ProcessInterfaceArea
Provider Edge 11Ethernet 0/2Area 0
1Loopback 1Area 0
Provider 11GigabitEthernet 0/0/0/2Area 0
1GigabitEthernet 0/0/0/3Area 0
1Loopback 1Area 0
Route Reflector 11GigabitEthernet 0/0/0/3Area 0
1GigabitEthernet 0/0/0/2Area 0
1Loopback 1Area 0
Provider 21Ethernet 0/2Area 0
1Ethernet 0/3Area 0
1Loopback 1Area 0
Provider Edge 21GigabitEthernet 0/0/0/4Area 0
1Ethernet 0/3Area 0

PE1:

PE1#configure terminal 
PE1(config)#router ospf 1
PE1(config-router)#interface loopback 1
PE1(config-if)#ip ospf 1 area 0
PE1(config)#interface Ethernet 0/2
PE1(config-if)#ip ospf 1 area 0           
PE1(config-if)#end
PE1#write memory 
    

P1::

RP/0/0/CPU0:P1#configure 
RP/0/0/CPU0:P1(config)#router ospf 1
RP/0/0/CPU0:P1(config-ospf)#area 0
RP/0/0/CPU0:P1(config-ospf-ar)#interface g0/0/0/2
RP/0/0/CPU0:P1(config-ospf-ar-if)#interface g0/0/0/3
RP/0/0/CPU0:P1(config-ospf-ar-if)#interface loopback 1
RP/0/0/CPU0:P1(config-ospf-ar-if)#commit
RP/0/0/CPU0:P1(config-ospf-ar-if)#end  
    

RR1:

RP/0/0/CPU0:RR1#configure
RP/0/0/CPU0:RR1(config)#router ospf 1
RP/0/0/CPU0:RR1(config-ospf)#area 0
RP/0/0/CPU0:RR1(config-ospf-ar)#interface loopback1
RP/0/0/CPU0:RR1(config-ospf-ar-if)#interface g0/0/0/2
RP/0/0/CPU0:RR1(config-ospf-ar-if)#interface g0/0/0/3
RP/0/0/CPU0:RR1(config-ospf-ar-if)#commit
RP/0/0/CPU0:RR1(config-ospf-ar-if)#end
    

P2:

P2#configure terminal 
P2(config)#router ospf 1
P2(config)#interface loopback 1
P2(config-if)#ip ospf 1 area 0  
P2(config)#interface Ethernet 0/2
P2(config-if)#ip ospf 1 area 0           
P2(config-if)#interface Ethernet 0/3
P2(config-if)#ip ospf 1 area 0           
P2(config-if)#end
P2#write memory 
    

PE2:

RP/0/0/CPU0:PE2#configure 
RP/0/0/CPU0:PE2(config)#router ospf 1
RP/0/0/CPU0:PE2(config-ospf)#area 0
RP/0/0/CPU0:PE2(config-ospf-ar)#interface loopback 1
RP/0/0/CPU0:PE2(config-ospf-ar)#interface gigabitEthernet 0/0/0/3
RP/0/0/CPU0:PE2(config-ospf-ar-if)#commit
RP/0/0/CPU0:PE2(config-ospf-ar-if)#end
    

Task 4: Verify OSPF Routes.

Verify all routes within the routing table of all Provider devices.

PE1#show ip route ospf 

O        3.3.3.3 [110/2] via 10.0.23.3, 00:33:15, Ethernet 0/3
O        4.4.4.4 [110/3] via 10.0.23.3, 00:32:07, Ethernet 0/3
O        5.5.5.5 [110/4] via 10.0.23.3, 00:29:17, Ethernet 0/3
O        10.0.34.0/24 [110/2] via 10.0.23.3, 00:31:09, Ethernet 0/3
O        10.0.45.0/24 [110/3] via 10.0.23.3, 00:32:07, Ethernet 0/3
O        10.0.56.0/24 [110/4] via 10.0.23.3, 00:29:17, Ethernet 0/3
    

RP/0/0/CPU0:RR1#show route ipv4 unicast ospf O 2.2.2.2/32 [110/3] via 10.0.34.3, 00:35:35, GigabitEthernet0/0/0/3 O 3.3.3.3/32 [110/2] via 10.0.34.3, 00:35:35, GigabitEthernet0/0/0/3 O 5.5.5.5/32 [110/2] via 10.0.45.5, 00:32:41, GigabitEthernet0/0/0/2 O 6.6.6.6/32 [110/3] via 10.0.45.5, 00:30:03, GigabitEthernet0/0/0/2 O 10.0.23.0/24 [110/2] via 10.0.34.3, 00:35:35, GigabitEthernet0/0/0/3 O 10.0.56.0/24 [110/2] via 10.0.45.5, 00:32:41, GigabitEthernet0/0/0/2

RP/0/0/CPU0:P1#show route ipv4 unicast ospf

O    2.2.2.2/32 [110/2] via 10.0.23.2, 00:35:52, GigabitEthernet0/0/0/2
O    4.4.4.4/32 [110/2] via 10.0.34.4, 00:34:45, GigabitEthernet0/0/0/3
O    5.5.5.5/32 [110/3] via 10.0.34.4, 00:31:50, GigabitEthernet0/0/0/3
O    6.6.6.6/32 [110/4] via 10.0.34.4, 00:29:12, GigabitEthernet0/0/0/3
O    10.0.45.0/24 [110/2] via 10.0.34.4, 00:34:45, GigabitEthernet0/0/0/3
O    10.0.56.0/24 [110/3] via 10.0.34.4, 00:31:50, GigabitEthernet0/0/0/3
    
P2#show ip route ospf 

O   2.2.2.2 [110/4] via 10.0.45.4, 00:34:24, Ethernet 0/2
O   3.3.3.3 [110/3] via 10.0.45.4, 00:34:24, Ethernet 0/2
O   4.4.4.4 [110/2] via 10.0.45.4, 00:34:24, Ethernet 0/2
O   6.6.6.6 [110/2] via 10.0.56.6, 00:31:51, Ethernet 0/3
O   10.0.23.0/24 [110/3] via 10.0.45.4, 00:34:24, Ethernet 0/2
O   10.0.34.0/24 [110/2] via 10.0.45.4, 00:34:24, Ethernet 0/2
    
RP/0/0/CPU0:PE2#show route ipv4 unicast ospf 

O    2.2.2.2/32 [110/5] via 10.0.56.5, 00:34:50, GigabitEthernet0/0/0/3
O    3.3.3.3/32 [110/4] via 10.0.56.5, 00:34:50, GigabitEthernet0/0/0/3
O    4.4.4.4/32 [110/3] via 10.0.56.5, 00:34:50, GigabitEthernet0/0/0/3
O    5.5.5.5/32 [110/2] via 10.0.56.5, 00:34:50, GigabitEthernet0/0/0/3
O    10.0.23.0/24 [110/4] via 10.0.56.5, 00:34:50, GigabitEthernet0/0/0/3
O    10.0.34.0/24 [110/3] via 10.0.56.5, 00:34:50, GigabitEthernet0/0/0/3
O    10.0.45.0/24 [110/2] via 10.0.56.5, 00:34:50, GigabitEthernet0/0/0/3

Task 5: Verify OSPF Neighborship.

PE1#show ip ospf neighbor 

Neighbor ID     	Pri   	State           Dead Time	Address         Interface
3.3.3.3           	1   	FULL/BDR       00:00:33    	10.0.23.3       Ethernet0/2
    
RP/0/0/CPU0:P1#show ospf neighbor 

Neighbor ID     	Pri   	State           Dead Time   	Address         Interface
2.2.2.2         	1     	FULL/DR         00:00:36    	10.0.23.2       GigabitEthernet0/0/0/2
4.4.4.4         	1     	FULL/DR         00:00:36    	10.0.34.4       GigabitEthernet0/0/0/3
RP/0/0/CPU0:RR1#show ospf neighbor 

Neighbor ID     	Pri   	State           Dead Time   	Address         Interface
5.5.5.5         	1     	FULL/DR         00:00:34    	10.0.45.5       GigabitEthernet0/0/0/2
3.3.3.3         	1     	FULL/DR         00:00:38    	10.0.34.3       GigabitEthernet0/0/0/3
    
PE1#show ip ospf neighbor 
Neighbor ID     	Pri   	State          Dead Time	Address         Interface
6.6.6.6           	1   	FULL/BDR       00:00:33    	10.0.56.6       Ethernet0/3
4.4.4.4           	1   	FULL/BDR       00:00:36    	10.0.45.4       Ethernet0/2
    
RP/0/0/CPU0:P1#show ospf neighbor 
Neighbor ID     	Pri   	State           Dead Time   	Address         Interface
5.5.5.5         	1     	FULL/BDR        00:00:36    	10.0.56.6       GigabitEthernet0/0/0/3
    

Task 6: Verify OSPF Interfaces.

PE1#show ip ospf interface brief

Interface    PID      Area      IP Address/Mask          Cost    State       Nbrs F/C
Lo1          1        0         2.2.2.2/32               1       LOOP        0/0
Et0/2        1        0         10.0.23.2/24             10      DR          1/1
    
RP/0/0/CPU0:RR1#show ospf interface brief 
Interfaces for OSPF 1

Interface    PID      Area     IP Address/Mask          Cost     State       Nbrs F/C
Lo1          1        0        4.4.4.4/32               1        LOOP        0/0
Gi0/0/0/2    1        0        10.0.45.5/24             1        BDR         1/1
Gi0/0/0/3    1        0        10.0.34.4/24             1        DR          1/1
    
P2#show ip ospf interface brief

Interface    PID    Area      IP Address/Mask            Cost     State       Nbrs F/C
Lo1          1      0         5.5.5.5/32                 1        LOOP        0/0
Et0/3        1      0         10.0.56.5/24               10       BDR         1/1
Et0/2        1      0         10.0.45.5/24               10       DR          1/1
    
RP/0/0/CPU0:PE2#show ospf interface brief 
Interfaces for OSPF 1

Interface    PID      Area     IP Address/Mask           Cost     State       Nbrs F/C
Lo1          1        0        6.6.6.6/32                1        LOOP        0/0
Gi0/0/0/3    1        0        10.0.56.6/24              1        DR          1/1