EIGRP IPv4 - Load Balancing and Variance

Load balancing and Variance

EIGRP (Enhanced Interior Gateway Routing Protocol) IPv4 Load Balancing and Variance are features designed to optimize traffic distribution across multiple paths in a network. Load balancing in EIGRP allows routers to distribute traffic proportionally across multiple equal-cost paths, thereby maximizing link utilization and preventing congestion on a single route. The Variance feature comes into play when dealing with paths of unequal metrics. By configuring a variance value, administrators can influence EIGRP's decision-making process to include routes with metrics higher than the best path, enabling load balancing across paths with different metrics. This is particularly beneficial in networks with diverse links, as it ensures efficient utilization of available resources and improves overall network performance. EIGRP Load Balancing and Variance provide network administrators with tools to optimize traffic distribution, enhance redundancy, and achieve better utilization of available network paths.

Lab:

Disclaimer

This Configuration Guide is designed to assist members to enhance their skills in particular technology area. While every effort has been made to ensure that all material is as complete and accurate as possible, the enclosed material is presented on an Dzas isdz basis. Neither the authors nor Forum assume any liability or responsibility to any person or entity with respect to loss or damages incurred from the information contained in this guide. This configuration guide was developed by Forum. Any similarities between material presented in this configuration guide and any other material is completely coincidental.

Cisco IOS Software, Linux Software (I86BI_LINUX-ADVENTERPRISEK9-M), Version 15.2(4)M1, DEVELOPMENT TEST SOFTWARE

Task 1: Configure EIGRP Load balancing and variance

Step 1: Configure redundant path between two routers

R1:
interface Serial 2/0
ip address 12.0.0.1 255.255.255.0
no shutdown
interface Serial 2/3
ip address 21.0.0.1 255.255.255.0
no shutdown
interface loopback 1
ip address 11.0.1.1 255.255.255.0
interface loopback 2
ip address 11.0.2.1 255.255.255.0
interface loopback 3
ip address 11.0.3.1 255.255.255.0
exit
R2:
interface Ethernet 0/0
ip address 23.0.0.2 255.255.255.0
no shutdown
interface Serial 2/0
ip address 12.0.0.2 255.255.255.0
no shutdown
interface Serial 2/3
ip address 43.0.0.2 255.255.255.0
no shutdown
interface loopback 1
ip address 22.0.0.2 255.255.255.0
interface loopback 2
ip address 22.0.0.2 255.255.255.0
interface loopback 3
ip address 22.0.0.2 255.255.255.0
exit
R3:
interface Ethernet 0/0
ip address 23.0.0.3 255.255.255.0
no shutdown
interface Serial 2/0
ip address 34.0.0.3 255.255.255.0
no shutdown
interface Serial 2/3
ip address 21.0.0.3 255.255.255.0
no shutdown
interface loopback 1
ip address 33.0.1.3 255.255.255.0
interface loopback 2
ip address 33.0.2.3 255.255.255.0
interface loopback 3
ip address 33.0.3.3 255.255.255.0
exit
R4:
interface Serial2/3
ip address 43.0.0.4 255.255.255.0
no shutdown
interface Serial2/0
ip address 34.0.0.4 255.255.255.0
no shutdown
interface loopback 1
ip address 44.0.1.4 255.255.255.0
interface loopback 2
ip address 44.0.2.4 255.255.255.0
interface loopback 3
ip address 44.0.3.4 255.255.255.0
exit

Step 2: Configure EIGRP to learn routes over multiple paths

R1:
router eigrp 100
network 11.0.1.1 0.0.0.0
network 11.0.2.1 0.0.0.0
network 11.0.3.1 0.0.0.0
network 12.0.0.1 0.0.0.0
network 21.0.0.1 0.0.0.0
exit

R2:
router eigrp 100
network 12.0.0.2 0.0.0.0
network 22.0.1.2 0.0.0.0
network 22.0.2.2 0.0.0.0
network 22.0.3.2 0.0.0.0
network 23.0.0.2 0.0.0.0
network 43.0.0.2 0.0.0.0
exit
R3:
router eigrp 100
network 21.0.0.3 0.0.0.0
network 23.0.0.3 0.0.0.0
network 33.0.1.3 0.0.0.0
network 33.0.2.3 0.0.0.0
network 33.0.3.3 0.0.0.0
network 34.0.0.3 0.0.0.0
exit
R4:
router eigrp 100
network 34.0.0.4 0.0.0.0
network 43.0.0.4 0.0.0.0
network 44.0.1.4 0.0.0.0
network 44.0.2.4 0.0.0.0
network 44.0.3.4 0.0.0.0
exit

Step 3: Verify that routes are learnt from multiple path

R2# show ip eigrp topology
EIGRP-IPv4 Topology Table for AS(100)/ID(22.0.3.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 11.0.1.0/24, 1 successors, FD is 2297856
        via 12.0.0.1 (2297856/128256), Serial2/0
P 11.0.2.0/24, 1 successors, FD is 2297856
        via 12.0.0.1 (2297856/128256), Serial2/0
P 11.0.3.0/24, 1 successors, FD is 2297856
        via 12.0.0.1 (2297856/128256), Serial2/0
P 12.0.0.0/24, 1 successors, FD is 2169856
        via Connected, Serial2/0
P 21.0.0.0/24, 1 successors, FD is 2195456
        via 23.0.0.3 (2195456/2169856), Ethernet0/0
        via 12.0.0.1 (2681856/2169856), Serial2/0
P 22.0.1.0/24, 1 successors, FD is 128256
        via Connected, Loopback1
P 22.0.2.0/24, 1 successors, FD is 128256
        via Connected, Loopback2
P 22.0.3.0/24, 1 successors, FD is 128256
        via Connected, Loopback3
P 23.0.0.0/24, 1 successors, FD is 281600
        via Connected, Ethernet0/0
P 33.0.1.0/24, 1 successors, FD is 409600
        via 23.0.0.3 (409600/128256), Ethernet0/0
P 33.0.2.0/24, 1 successors, FD is 409600
        via 23.0.0.3 (409600/128256), Ethernet0/0
P 33.0.3.0/24, 1 successors, FD is 409600
        via 23.0.0.3 (409600/128256), Ethernet0/0
P 34.0.0.0/24, 1 successors, FD is 2195456
        via 23.0.0.3 (2195456/2169856), Ethernet0/0
        via 43.0.0.4 (2681856/2169856), Serial2/3
P 43.0.0.0/24, 1 successors, FD is 2169856
        via Connected, Serial2/3
P 44.0.1.0/24, 1 successors, FD is 2297856
        via 43.0.0.4 (2297856/128256), Serial2/3
P 44.0.2.0/24, 1 successors, FD is 2297856
        via 43.0.0.4 (2297856/128256), Serial2/3
P 44.0.3.0/24, 1 successors, FD is 2297856
        via 43.0.0.4 (2297856/128256), Serial2/3

Step 4: Analyze topology table and verify rules of DUAL

Rules of Diffusion Algorithm (DUAL)

  1. For a path to become Feasible Successor (FS) its Advertise Distance (AD) should be less than current Feasible Distance (FD)

     	FS = AD < current FD
    

Example:

P 34.0.0.0/24, 1 successors, FD is 2195456
        via 23.0.0.3 (2195456/2169856), Ethernet0/0
        via 43.0.0.4 (2681856/2169856), Serial2/3

FS = 2169856< 2195456

In router 1 topology table path to reach 34.0.0.0 there are two path via 23.0.0.3 & 43.0.0.4 both are feasible successor because their AD is less than current FD.

  1. For a path to be even consider as a valid path its AD should be less than 2 times current FD.

Valid path = AD < 2*current FD

Example:

P 34.0.0.0/24, 1 successors, FD is 2195456
        via 23.0.0.3 (2195456/2169856), Ethernet0/0
        via 43.0.0.4 (2681856/2169856), Serial2/3
Valid path = 2169856 <2*2195456

A routers topology table shows only valid path.

Here both the path to reach 33.0.1.0 are valid path because their AD is less than 2*current FD.

Step 5: Verify that only best routes are reflecting in routing table

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      11.0.0.0/24 is subnetted, 3 subnets
D        11.0.1.0 [90/2297856] via 12.0.0.1, 01:44:51, Serial2/0
D        11.0.2.0 [90/2297856] via 12.0.0.1, 01:44:51, Serial2/0
D        11.0.3.0 [90/2297856] via 12.0.0.1, 01:44:51, Serial2/0
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.0.0.0/24 is directly connected, Serial2/0
L        12.0.0.2/32 is directly connected, Serial2/0
      21.0.0.0/24 is subnetted, 1 subnets
D        21.0.0.0 [90/2195456] via 23.0.0.3, 01:44:45, Ethernet0/0
      22.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C        22.0.1.0/24 is directly connected, Loopback1
L        22.0.1.2/32 is directly connected, Loopback1
C        22.0.2.0/24 is directly connected, Loopback2
L        22.0.2.2/32 is directly connected, Loopback2
C        22.0.3.0/24 is directly connected, Loopback3
L        22.0.3.2/32 is directly connected, Loopback3
      23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        23.0.0.0/24 is directly connected, Ethernet0/0
L        23.0.0.2/32 is directly connected, Ethernet0/0
      33.0.0.0/24 is subnetted, 3 subnets
D        33.0.1.0 [90/409600] via 23.0.0.3, 01:44:45, Ethernet0/0
D        33.0.2.0 [90/409600] via 23.0.0.3, 01:44:45, Ethernet0/0
D        33.0.3.0 [90/409600] via 23.0.0.3, 01:44:45, Ethernet0/0
      34.0.0.0/24 is subnetted, 1 subnets
D        34.0.0.0 [90/2195456] via 23.0.0.3, 01:44:45, Ethernet0/0
      43.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        43.0.0.0/24 is directly connected, Serial2/3
L        43.0.0.2/32 is directly connected, Serial2/3
      44.0.0.0/24 is subnetted, 3 subnets
D        44.0.1.0 [90/2297856] via 43.0.0.4, 01:44:45, Serial2/3
D        44.0.2.0 [90/2297856] via 43.0.0.4, 01:44:45, Serial2/3
D        44.0.3.0 [90/2297856] via 43.0.0.4, 01:44:45, Serial2/3

Step 6: Configure Variance command in EIGRP Process

R1:
router eigrp 100
variance 2		
exit

EIGRP supports Unequal Metric Path Load Balancing with the help of Variance.

Step 7: Verify that multiple path are reflecting in routers routing table

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      11.0.0.0/24 is subnetted, 3 subnets
D        11.0.1.0 [90/2323456] via 23.0.0.3, 00:00:24, Ethernet0/0
                  [90/2297856] via 12.0.0.1, 00:00:24, Serial2/0
D        11.0.2.0 [90/2323456] via 23.0.0.3, 00:00:24, Ethernet0/0
                  [90/2297856] via 12.0.0.1, 00:00:24, Serial2/0
D        11.0.3.0 [90/2323456] via 23.0.0.3, 00:00:24, Ethernet0/0
                  [90/2297856] via 12.0.0.1, 00:00:24, Serial2/0
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.0.0.0/24 is directly connected, Serial2/0
L        12.0.0.2/32 is directly connected, Serial2/0
      21.0.0.0/24 is subnetted, 1 subnets
D        21.0.0.0 [90/3193856] via 43.0.0.4, 00:00:24, Serial2/3
                  [90/2195456] via 23.0.0.3, 00:00:24, Ethernet0/0
                  [90/2681856] via 12.0.0.1, 00:00:24, Serial2/0
      22.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C        22.0.1.0/24 is directly connected, Loopback1
L        22.0.1.2/32 is directly connected, Loopback1
C        22.0.2.0/24 is directly connected, Loopback2
L        22.0.2.2/32 is directly connected, Loopback2
C        22.0.3.0/24 is directly connected, Loopback3
L        22.0.3.2/32 is directly connected, Loopback3
      23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        23.0.0.0/24 is directly connected, Ethernet0/0
L        23.0.0.2/32 is directly connected, Ethernet0/0
      33.0.0.0/24 is subnetted, 3 subnets
D        33.0.1.0 [90/409600] via 23.0.0.3, 00:00:24, Ethernet0/0
D        33.0.2.0 [90/409600] via 23.0.0.3, 00:00:24, Ethernet0/0
D        33.0.3.0 [90/409600] via 23.0.0.3, 00:00:24, Ethernet0/0
      34.0.0.0/24 is subnetted, 1 subnets
D        34.0.0.0 [90/2681856] via 43.0.0.4, 00:00:24, Serial2/3
                  [90/2195456] via 23.0.0.3, 00:00:24, Ethernet0/0
                  [90/3193856] via 12.0.0.1, 00:00:24, Serial2/0
43.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        43.0.0.0/24 is directly connected, Serial2/3
L        43.0.0.2/32 is directly connected, Serial2/3
      44.0.0.0/24 is subnetted, 3 subnets
D        44.0.1.0 [90/2297856] via 43.0.0.4, 00:01:22, Serial2/3
                  [90/2323456] via 23.0.0.3, 00:01:22, Ethernet0/0
D        44.0.2.0 [90/2297856] via 43.0.0.4, 00:01:22, Serial2/3
                  [90/2323456] via 23.0.0.3, 00:01:22, Ethernet0/0
D        44.0.3.0 [90/2297856] via 43.0.0.4, 00:01:22, Serial2/3
                  [90/2323456] via 23.0.0.3, 00:01:22, Ethernet0/0

Variance commands will set the benchmark and EIGRP Router will Load Balancing the traffic between the paths within that benchmark which is reflected in router’s routing table.