EIGRP IPv6 - Load balancing and Variance

Load balancing and Variance

Enhanced Interior Gateway Routing Protocol (EIGRP) supports load balancing in IPv6 networks, offering an efficient way to distribute traffic across multiple paths. Load balancing in EIGRP for IPv6 is achieved by considering multiple equal-cost paths to a destination, allowing routers to share the traffic load and enhance network utilization. The variance parameter is a critical factor in EIGRP IPv6 load balancing, as it controls the degree to which the protocol considers unequal-cost paths. By adjusting the variance value, network administrators can influence the EIGRP algorithm's decision-making process, allowing it to include paths with different costs in the load-balancing equation. This dynamic load balancing based on the variance parameter helps optimize network resources and improve overall performance by utilizing diverse paths to reach IPv6 destinations. It is important for administrators to carefully configure the variance value to strike a balance between network efficiency and resource utilization in their specific IPv6 EIGRP environments.

Lab:

Disclaimer

This Configuration Guide is designed to assist members to enhance their skills in particular technology area. While every effort has been made to ensure that all material is as complete and accurate as possible, the enclosed material is presented on an Dzas isdz basis. Neither the authors nor Forum assume any liability or responsibility to any person or entity with respect to loss or damages incurred from the information contained in this guide. This configuration guide was developed by Forum. Any similarities between material presented in this configuration guide and any other material is completely coincidental.

Cisco IOS Software, Linux Software (I86BI_LINUX-ADVENTERPRISEK9-M), Version 15.2(4)M1, DEVELOPMENT TEST SOFTWARE

Task 1: Configure IPv6 EIGRP Load balancing and variance

Step 1: Configure redundant path between two routers

R1:
interface serial 2/0
ipv6 address 12::1/64 eui-64
no shutdown
interface serial 2/3
ipv6 address 21::1/64 eui-64
no shutdown
interface loopback 1
ipv6 address 11:0:1::1/64
interface loopback 2
ipv6 address 11:0:2::1/64
interface loopback 3
ipv6 address 11:0:3::1/64
exit
R2:
interface serial 2/0
ipv6 address 12::2/64 eui-64
no shutdown
interface serial 2/3
ipv6 address 43::2/64 eui-64
no shutdown
interface ethernet 0/0
ipv6 address 23::2/64 eui-64
no shutdown
interface loopback 1
ipv6 address 22:0:1::2/64
interface loopback 2
ipv6 address 22:0:2::2/64
interface loopback 3
ipv6 address 22:0:3::2/64
exit
R3:
interface serial 2/0
ipv6 address 34::3/64 eui-64
no shutdown
interface serial 2/3
ipv6 address 21::3/64 eui-64
no shutdown
interface ethernet 0/0
ipv6 address 23::3/64 eui-64
no shutdown
interface loopback 1
ipv6 address 33:0:1::3/64
interface loopback 2
ipv6 address 33:0:2::3/64
interface loopback 3
ipv6 address 33:0:3::3/64
exit
R4:
interface serial 2/0
ipv6 address 34::1/64 eui-64
no shutdown
interface serial 2/3
ipv6 address 43::4/64 eui-64
no shutdown
interface loopback 1
ipv6 address 44:0:1::4/64
interface loopback 2
ipv6 address 44:0:2::4/64
interface loopback 3
ipv6 address 44:0:3::4/64
exit

Step 2: Configure IPv6 EIGRP to learn routes over multiple paths

R1:
ipv6 unicast-routing
ipv6 router eigrp 100
interface serial 2/0
ipv6 eigrp 100
interface serial 2/3
ipv6 eigrp 100
interface loopback 1
ipv6 eigrp 100
interface loopback 2
ipv6 eigrp 100
interface loopback 3
ipv6 eigrp 100
exit
R2:
ipv6 unicast-routing
ipv6 router eigrp 100
interface serial 2/0
ipv6 eigrp 100
interface serial 2/3
ipv6 eigrp 100
interface ethernet 0/0
ipv6 eigrp 100
interface loopback 1
ipv6 eigrp 100
interface loopback 2
ipv6 eigrp 100
interface loopback 3
ipv6 eigrp 100
exit
R3:
ipv6 unicast-routing
ipv6 router eigrp 100
interface serial 2/0
ipv6 eigrp 100
interface serial 2/3
ipv6 eigrp 100
interface ethernet 0/0
ipv6 eigrp 100
interface loopback 1
ipv6 eigrp 100
interface loopback 2
ipv6 eigrp 100
interface loopback 3
ipv6 eigrp 100
exit
R4:
ipv6 unicast-routing
ipv6 router eigrp 100
interface serial 2/0
ipv6 eigrp 100
interface serial 2/3
ipv6 eigrp 100
interface loopback 1
ipv6 eigrp 100
interface loopback 2
ipv6 eigrp 100
interface loopback 3
ipv6 eigrp 100
exit

Step 3: Verify that routes are learnt from multiple path

R1#show ipv6 eigrp topology 
EIGRP-IPv6 Topology Table for AS(100)/ID(22.0.3.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 11:0:1::/64, 1 successors, FD is 2297856
        via FE80::A8BB:CCFF:FE00:100 (2297856/128256), Serial2/0
P 11:0:2::/64, 1 successors, FD is 2297856
        via FE80::A8BB:CCFF:FE00:100 (2297856/128256), Serial2/0
P 11:0:3::/64, 1 successors, FD is 2297856
        via FE80::A8BB:CCFF:FE00:100 (2297856/128256), Serial2/0
P 12::/64, 1 successors, FD is 2169856
        via Connected, Serial2/0
P 21::/64, 1 successors, FD is 2195456
        via FE80::A8BB:CCFF:FE00:300 (2195456/2169856), Ethernet0/0
        via FE80::A8BB:CCFF:FE00:100 (2681856/2169856), Serial2/0
P 22:0:1::/64, 1 successors, FD is 128256
        via Connected, Loopback1
P 22:0:2::/64, 1 successors, FD is 128256
        via Connected, Loopback2
P 22:0:3::/64, 1 successors, FD is 128256
        via Connected, Loopback3
P 23::/64, 1 successors, FD is 281600
        via Connected, Ethernet0/0
P 33:0:1::/64, 1 successors, FD is 409600
        via FE80::A8BB:CCFF:FE00:300 (409600/128256), Ethernet0/0
P 33:0:2::/64, 1 successors, FD is 409600
        via FE80::A8BB:CCFF:FE00:300 (409600/128256), Ethernet0/0
P 33:0:3::/64, 1 successors, FD is 409600
        via FE80::A8BB:CCFF:FE00:300 (409600/128256), Ethernet0/0
P 34::/64, 1 successors, FD is 2195456
        via FE80::A8BB:CCFF:FE00:300 (2195456/2169856), Ethernet0/0
        via FE80::A8BB:CCFF:FE00:400 (2681856/2169856), Serial2/3
P 43::/64, 1 successors, FD is 2169856
        via Connected, Serial2/3
P 44:0:1::/64, 1 successors, FD is 2297856
        via FE80::A8BB:CCFF:FE00:400 (2297856/128256), Serial2/3
P 44:0:2::/64, 1 successors, FD is 2297856
        via FE80::A8BB:CCFF:FE00:400 (2297856/128256), Serial2/3
P 44:0:3::/64, 1 successors, FD is 2297856
        via FE80::A8BB:CCFF:FE00:400 (2297856/128256), Serial2/3

Step 4: Analyze IPv6 EIGRP topology table and verify rules of DUAL

Rules of Diffusion Algorithm (DUAL)

  1. For a path to become Feasible Successor (FS) its Advertise Distance (AD) should be less than current Feasible Distance (FD) FS = AD < current FD Example:
P 34::/64, 1 successors, FD is 2195456
        via FE80::A8BB:CCFF:FE00:300 (2195456/2169856), Ethernet0/0
        via FE80::A8BB:CCFF:FE00:400 (2681856/2169856), Serial2/3

FS = 2169856 < 2195456

In router 1 topology table path to reach 34::/64 there are two path via via FE80::A8BB:CCFF:FE00:300 & via FE80::A8BB:CCFF:FE00:400 both are feasible successor because their AD is less than current FD

  1. For a path to be even consider as a valid path its AD should be less than 2 times current FD.

Valid path = AD < 2*current FD Example:

P 34::/64, 1 successors, FD is 2195456
        via FE80::A8BB:CCFF:FE00:300 (2195456/2169856), Ethernet0/0
        via FE80::A8BB:CCFF:FE00:400 (2681856/2169856), Serial2/3

Valid path = 2169856 < 2*2195456

A routers topology table shows only valid path. Here both the path to reach 34::/64 are valid path because their AD is less than 2*current FD