Point-to-Point Protocol (PPP)

PPP

Point-to-Point Protocol (PPP) is a widely used data link layer protocol in networking, designed for establishing a direct connection between two nodes. PPP operates over both synchronous and asynchronous communication links and is commonly employed in scenarios like dial-up connections over telephone lines. It provides a simple and efficient method for the encapsulation and transmission of data packets over a point-to-point link. PPP supports multiple network layer protocols, allowing it to be versatile in various networking environments. Key features of PPP include error detection through its encapsulation process, support for dynamic IP address assignment through protocols like PPPoE (PPP over Ethernet), and the ability to establish secure connections through authentication mechanisms like PAP (Password Authentication Protocol) and CHAP (Challenge Handshake Authentication Protocol). With its flexibility and reliability, PPP remains a fundamental protocol for establishing point-to-point connections in networking.

Lab:

Disclaimer

This CCIE Routing & Switching Lab Guide is designed to assist candidates in the preparation for Cisco Systems' CCIE Routing & Switching Lab exam. While every effort has been made to ensure that all material is as complete and accurate as possible, the enclosed material is presented on an "as is" basis. Neither the authors nor Forum assume any liability or responsibility to any person or entity with respect to loss or damages incurred from the information contained in this workbook. This workbook was developed by Forum. Any similarities between material presented in this workbook and actual CCIE TM lab material or any other material is completely coincidental.

PPP Multilink Configuration

Configuration:

R1: 
hostname R1 
! 
interface Serial2/0
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Serial2/1
 no ip address 
 encapsulation ppp 
ppp multilink 
 ppp multilink group 1 
 no shut
! 
interface Multilink1 
 ip address 10.0.0.1 255.255.255.252 
 ppp multilink 
 ppp multilink group 1 
R2: 
Hostname R2 
! 
interface Serial2/0
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Serial2/1
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Multilink1 
 ip address 10.0.0.2 255.255.255.252 
 ppp multilink 
ppp multilink group 1

Verification:

R1# Show ppp multilink 
Multilink1 
 Bundle name: R2 
 Remote Endpoint Discriminator: [1] R2 
 Local Endpoint Discriminator: [1] R1 
 Bundle up for 00:01:15, total bandwidth 3088, load 1/255 
 Receive buffer limit 24000 bytes, frag timeout 1000 ms 
 0/0 fragments/bytes in reassembly list 
 0 lost fragments, 0 reordered 
 0/0 discarded fragments/bytes, 0 lost received 
 0x14 received sequence, 0x1C sent sequence 
 Member links: 2 active, 0 inactive (max 255, min not set) 
 Se2/0, since 00:01:15 
 Se2/1, since 00:01:15 
No inactive multilink interfaces 

Verification:

R1#Ping 10.0.0.2 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds: 
! ! ! ! ! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 124/140/152 ms

Observation:

PPP uses CDPCP network control protocol if CDP is enabled between the two devices PPP uses IPCP network control protocol if IPv4 address is set on the Multilink

PPP Multilink Configuration with PAP Authentication

Configuration:

R1: 
hostname R1 
! 
username R2 password cisco 
! 
interface Serial 2/0
 no ip address 
 encapsulation ppp 
ppp multilink 
ppp multilink group 1 
 no shut 
! 
interface Serial 2/1
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
!
interface Multilink1 
 ip address 10.0.0.1 255.255.255.252 
 ppp authentication pap 
 ppp pap sent-username R1 password 0 cisco 
 ppp multilink 
 ppp multilink group 1
R2: 
Hostname R2 
! 
username R1 password cisco 
! 
interface Serial2/0
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Serial2/1
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Multilink1 
 ip address 10.0.0.2 255.255.255.252 
 ppp pap sent-username R2 password 0 cisco 
 ppp multilink 
ppp multilink group 1

Verification:

R1# Show ppp multilink 

Multilink1 
 Bundle name: R2 
 Remote Endpoint Discriminator: [1] R2 
 Local Endpoint Discriminator: [1] R1 
 Bundle up for 00:01:15, total bandwidth 3088, load 1/255 
 Receive buffer limit 24000 bytes, frag timeout 1000 ms 
 0/0 fragments/bytes in reassembly list 
 0 lost fragments, 0 reordered
  0x14 received sequence, 0x1C sent sequence 
 Member links: 2 active, 0 inactive (max 255, min not set) 
 Se2/0, since 00:01:15 
 Se2/1, since 00:01:15 
No inactive multilink interfaces 

Verification:

R1#Ping 10.0.0.2 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds: 
! ! ! ! ! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 124/140/152 ms

PPP Multilink Configuration with CHAP authentication

Configuration:

R1: 
hostname R1 
! 
username R2 password cisco 
! 
interface Serial 2/0
 no ip address 
 encapsulation ppp 
 ppp multilink 
ppp multilink group 1 
 no shut 
! 
interface Serial 2/1
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Multilink1 
 ip address 10.0.0.1 255.255.255.252 
 ppp authentication chap
 ppp multilink 
 ppp multilink group 1
R2: 
Hostname R2 
! 
username R1 password cisco 
! 
interface Serial2/0
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Serial2/1
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Multilink1 
 ip address 10.0.0.2 255.255.255.252 
 ppp multilink 
 ppp multilink group 1

Verification:

R1# Show ppp multilink 

Multilink1 
 Bundle name: R2 
 Remote Endpoint Discriminator: [1] R2 
 Local Endpoint Discriminator: [1] R1 
 Bundle up for 00:01:15, total bandwidth 3088, load 1/255 
 Receive buffer limit 24000 bytes, frag timeout 1000 ms 
    0/0 fragments/bytes in reassembly list 
    0 lost fragments, 0 reordered 
    0/0 discarded fragments/bytes, 0 lost received 
 0x14 received sequence, 0x1C sent sequence 
 Member links: 2 active, 0 inactive (max 255, min not set) 
    Se2/0, since 00:01:15 
    Se2/1, since 00:01:15 
No inactive multilink interfaces

Verification:

R1#Ping 10.0.0.2 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds: 
! ! ! ! ! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 124/140/152 ms

debug ppp negotiation

debug ppp authentication

PPP Multilink Configuration with CHAP Callin

Configuration:

R1: 
hostname R1 
! 
username R2 password cisco 
! 
interface Serial 2/0
 no ip address 
 encapsulation ppp 
 ppp multilink 
ppp multilink group 1 
 no shut 
! 
interface Serial 2/1
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Multilink1 
 ip address 10.0.0.1 255.255.255.252 
 ppp authentication chap callin 
 ppp multilink 
 ppp multilink group 1 
R2: 
hostname R2 
! 
username R1 password cisco 
! 
interface Serial2/0
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Serial2/1
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Multilink1 
 ip address 10.0.0.2 255.255.255.252 
 ppp chap hostname R2 
 ppp chap password 0 cisco 
 ppp multilink 
 ppp multilink group 1

Verification:

R1# Show ppp multilink 

Multilink1 
 Bundle name: R2 
 Remote Endpoint Discriminator: [1] R2 
 Local Endpoint Discriminator: [1] R1 
 Bundle up for 00:01:15, total bandwidth 3088, load 1/255 
 Receive buffer limit 24000 bytes, frag timeout 1000 ms 
    0/0 fragments/bytes in reassembly list 
    0 lost fragments, 0 reordered 
    0/0 discarded fragments/bytes, 0 lost received 
    0x14 received sequence, 0x1C sent sequence 
    Member links: 2 active, 0 inactive (max 255, min not set) 
    Se2/0, since 00:01:15 
    Se2/1, since 00:01:15 
No inactive multilink interfaces

Verification:

R1#Ping 10.0.0.2 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds: 
! ! ! ! ! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 124/140/152 ms 

debug ppp negotiation

debug ppp authentication

PPP Multilink Configuration with PAP Callin

Configuration:

R1: 
hostname R1 
! 
username R2 password cisco 
! 
interface Serial 2/0
 no ip address 
 encapsulation ppp 
ppp multilink 
ppp multilink group 1 
 no shut 
! 
interface Serial 2/1
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Multilink1 
 ip address 10.0.0.1 255.255.255.252 
 ppp authentication pap callin 
 ppp multilink 
 ppp multilink group 1
R2: 
hostname R2 
! 
username R1 password cisco 
! 
interface Serial2/0
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Serial2/1
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Multilink1 
 ip address 10.0.0.2 255.255.255.252 
 ppp pap sent-username R2 password 0 cisco 
 ppp multilink 
 ppp multilink group 1

Verification:

R1# Show ppp multilink 
Multilink1 
 Bundle name: R2 
 Remote Endpoint Discriminator: [1] R2 
 Local Endpoint Discriminator: [1] R1 
 Bundle up for 00:01:15, total bandwidth 3088, load 1/255 
 Receive buffer limit 24000 bytes, frag timeout 1000 ms 
    0/0 fragments/bytes in reassembly list 
    0 lost fragments, 0 reordered 
    0/0 discarded fragments/bytes, 0 lost received 
    0x14 received sequence, 0x1C sent sequence 
    Member links: 2 active, 0 inactive (max 255, min not set) 
    Se2/0, since 00:01:15 
    Se2/1, since 00:01:15 
No inactive multilink interfaces

Veriification:

R1#Ping 10.0.0.2 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds: 
! ! ! ! ! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 124/140/152 ms

debug ppp negotiation

debug ppp authentication

PPP Multilink Configuration with PAP Callin with different username

Configuration:

R1: 
hostname R1 
! 
username hello password cisco 
! 
interface Serial 2/0
 no ip address 
 encapsulation ppp 
 ppp multilink 
ppp multilink group 1 
 no shut 
! 
interface Serial 2/1
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Multilink1 
 ip address 10.0.0.1 255.255.255.252 
 ppp authentication pap callin 
 ppp multilink 
 ppp multilink group 1
R2: 
hostname R2 
! 
username R1 password cisco 
! 
interface Serial2/0
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Serial2/1
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Multilink1 
 ip address 10.0.0.2 255.255.255.252 
 ppp pap sent-username hello password 0 cisco 
 ppp multilink 
ppp multilink group 1

Verification:

R1# Show ppp multilink 
Multilink1 
 Bundle name: R2 
 Remote Endpoint Discriminator: [1] R2 
 Local Endpoint Discriminator: [1] R1 
 Bundle up for 00:01:15, total bandwidth 3088, load 1/255 
 Receive buffer limit 24000 bytes, frag timeout 1000 ms 
    0/0 fragments/bytes in reassembly list
    0 lost fragments, 0 reordered 
    0/0 discarded fragments/bytes, 0 lost received 
    0x14 received sequence, 0x1C sent sequence 
    Member links: 2 active, 0 inactive (max 255, min not set) 
    Se2/0, since 00:01:15 
    Se2/1, since 00:01:15 
No inactive multilink interfaces

Verification:

R1#Ping 10.0.0.2 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds: 
! ! ! ! ! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 124/140/152 ms 

debug ppp negotiation

debug ppp authentication

PPP Multilink Configuration with CHAP Callin with different username

Configuration:

R1: 
hostname R1 
! 
username hello password cisco 
! 
interface Serial 2/0
 no ip address 
 encapsulation ppp 
 ppp multilink 
ppp multilink group 1 
 no shut 
! 
interface Serial 2/1
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Multilink1 
 ip address 10.0.0.1 255.255.255.252 
 ppp authentication chap callin 
 ppp multilink 
 ppp multilink group 1
R2: 
hostname R2 
! 
username R1 password cisco 
! 
interface Serial2/0
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Serial2/1
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Multilink1 
 ip address 10.0.0.2 255.255.255.252 
 ppp chap hostname hello 
 ppp chap password 0 cisco 
 ppp multilink 
 ppp multilink group 1

Verification:

R1# Show ppp multilink 
Multilink1 
 Bundle name: R2 
 Remote Endpoint Discriminator: [1] R2 
 Local Endpoint Discriminator: [1] R1 
 Bundle up for 00:01:15, total bandwidth 3088, load 1/255 
 Receive buffer limit 24000 bytes, frag timeout 1000 ms 
    0/0 fragments/bytes in reassembly list
    0 lost fragments, 0 reordered 
    0/0 discarded fragments/bytes, 0 lost received 
    0x14 received sequence, 0x1C sent sequence 
    Member links: 2 active, 0 inactive (max 255, min not set) 
    Se2/0, since 00:01:15 
    Se2/1, since 00:01:15 
No inactive multilink interfaces

Verification:

R1#Ping 10.0.0.2 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds: 
! ! ! ! ! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 124/140/152 ms

debug ppp negotiation

debug ppp authentication

PPP Multilink Configuration with IPv6 using PAP Callin

Configuration:

R1: 
hostname R1 
! 
username R2 password cisco 
! 
interface Serial 2/0
 no ip address 
 encapsulation ppp 
 ppp multilink 
ppp multilink group 1 
 no shut 
! 
interface Serial 2/1
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Multilink1 
 ipv6 address 2001:1234:ABCD:1::/64 eui-64
 ipv6 enable 
 ppp authentication pap callin 
 ppp multilink 
ppp multilink group 1
R2: 
hostname R2 
! 
username R1 password cisco 
! 
interface Serial2/0
 no ip address 
 encapsulation ppp 
 ppp multilink 
 ppp multilink group 1 
 no shut 
! 
interface Serial2/1
 no ip address 
 encapsulation ppp 
 ppp multilink 
ppp multilink group 1 
 no shut 
! 
interface Multilink1 
 ipv6 address 2001:1234:ABCD:1::/64 eui-64
 ipv6 enable 
 ppp pap sent-username R2 password 0 cisco 
 ppp multilink 
 ppp multilink group 1

Verification:

R1# Show ppp multilink 
Multilink1 
 Bundle name: R2
 Remote Endpoint Discriminator: [1] R2 
 Local Endpoint Discriminator: [1] R1 
 Bundle up for 00:01:15, total bandwidth 3088, load 1/255 
 Receive buffer limit 24000 bytes, frag timeout 1000 ms 
    0/0 fragments/bytes in reassembly list 
    0 lost fragments, 0 reordered 
    0/0 discarded fragments/bytes, 0 lost received 
    0x14 received sequence, 0x1C sent sequence 
    Member links: 2 active, 0 inactive (max 255, min not set) 
    Se2/0, since 00:01:15 
    Se2/1, since 00:01:15 
No inactive multilink interfaces

Verification:

R1#Ping 10.0.0.2 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds: 
! ! ! ! ! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 124/140/152 ms 

debug ppp negotiation

debug ppp authentication