EIGRP IPv4 - Redistribution

Redistribution

EIGRP (Enhanced Interior Gateway Routing Protocol) IPv4 Redistribution is a process that enables the exchange of routing information between EIGRP and other routing protocols in a network. In complex network environments where multiple routing protocols coexist, redistribution allows routers to share and integrate route information seamlessly. EIGRP supports redistribution with various protocols, such as OSPF or RIP, facilitating communication and routing decision-making across different domains. During redistribution, administrators need to carefully map and filter routes to avoid potential issues such as routing loops or suboptimal path selection. Proper configuration of redistribution ensures that routers running different routing protocols can collaborate effectively, leading to optimal path selection and improved network connectivity. EIGRP IPv4 Redistribution provides a flexible solution for network administrators to integrate diverse routing protocols and maintain a cohesive and efficient routing infrastructure.

Lab:

Disclaimer

This Configuration Guide is designed to assist members to enhance their skills in particular technology area. While every effort has been made to ensure that all material is as complete and accurate as possible, the enclosed material is presented on an Dzas isdz basis. Neither the authors nor Forum assume any liability or responsibility to any person or entity with respect to loss or damages incurred from the information contained in this guide. This configuration guide was developed by Forum. Any similarities between material presented in this configuration guide and any other material is completely coincidental.

Cisco IOS Software, Linux Software (I86BI_LINUX-ADVENTERPRISEK9-M), Version 15.2(4)M1, DEVELOPMENT TEST SOFTWARE

Task 1: Configure IPv4 EIGRP Redistribution

Step 1: In the configuration mode of router configure 4 loopbacks with network address in sequence

R1:
interface loopback 101
ip address 101.101.101.101 255.255.255.0
exit
interface loopback 102
ip address 102.102.102.102 255.255.255.0
exit
interface loopback 103
ip address 103.103.103.103 255.255.255.0
exit
interface loopback 104
ip address 104.104.104.104 255.255.255.0
exit

Step 2: Redistribute these connected network in EIGRP process

R1:
router eigrp 100
redistribute connected
exit

It will redistribute connected network on which EIGRP is not sending updates

Task 2: Verification:

Step 1: Verify route in neighbors routing table by following command:

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override
Gateway of last resort is not set
      11.0.0.0/24 is subnetted, 3 subnets
D        11.0.1.0 [90/2297856] via 12.0.0.1, 00:13:20, Serial2/0
D        11.0.2.0 [90/2297856] via 12.0.0.1, 00:13:20, Serial2/0
D        11.0.3.0 [90/2297856] via 12.0.0.1, 00:13:20, Serial2/0
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.0.0.0/24 is directly connected, Serial2/0
L        12.0.0.2/32 is directly connected, Serial2/0
      22.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C        22.0.1.0/24 is directly connected, Loopback1
L        22.0.1.2/32 is directly connected, Loopback1
C        22.0.2.0/24 is directly connected, Loopback2
L        22.0.2.2/32 is directly connected, Loopback2
C        22.0.3.0/24 is directly connected, Loopback3
L        22.0.3.2/32 is directly connected, Loopback3
      23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        23.0.0.0/24 is directly connected, Ethernet0/0
L        23.0.0.2/32 is directly connected, Ethernet0/0
      33.0.0.0/24 is subnetted, 3 subnets
D        33.0.1.0 [90/409600] via 23.0.0.3, 00:13:19, Ethernet0/0
D        33.0.2.0 [90/409600] via 23.0.0.3, 00:13:19, Ethernet0/0
D        33.0.3.0 [90/409600] via 23.0.0.3, 00:13:19, Ethernet0/0
      34.0.0.0/24 is subnetted, 1 subnets
D        34.0.0.0 [90/2195456] via 23.0.0.3, 00:13:16, Ethernet0/0
      44.0.0.0/24 is subnetted, 3 subnets
D        44.0.1.0 [90/2323456] via 23.0.0.3, 00:13:19, Ethernet0/0
D        44.0.2.0 [90/2323456] via 23.0.0.3, 00:13:19, Ethernet0/0
D        44.0.3.0 [90/2323456] via 23.0.0.3, 00:13:19, Ethernet0/0
      101.0.0.0/24 is subnetted, 1 subnets
D EX     101.101.101.0 [170/2297856] via 12.0.0.1, 00:00:09, Serial2/0
      102.0.0.0/24 is subnetted, 1 subnets
D EX     102.102.102.0 [170/2297856] via 12.0.0.1, 00:00:09, Serial2/0
      103.0.0.0/24 is subnetted, 1 subnets
D EX     103.103.103.0 [170/2297856] via 12.0.0.1, 00:00:09, Serial2/0
      104.0.0.0/24 is subnetted, 1 subnets
D EX     104.104.104.0 [170/2297856] via 12.0.0.1, 00:00:09, Serial2/0

Step 2: Analyze administrative distance of redistribution route in neighbor router

D EX     101.101.101.0 [170/2297856] via 12.0.0.1, 00:08:37, Serial2/0

Step 3: Analyze network type as “Dex” in neighbor router routing table.

D EX     101.101.101.0 [170/2297856] via 12.0.0.1, 00:08:37, Serial2/0

D EX means EIGRP External routes redistributed by the neighbor router & EIGRP external routes AD value is 170