EIGRP Named - Summarization

Summarization

EIGRP Named Summarization is a feature within Enhanced Interior Gateway Routing Protocol (EIGRP) that allows for the efficient aggregation of routing information. With the introduction of named mode, administrators can leverage named summarization to selectively group and summarize specific routes based on naming conventions. This provides a more fine-grained control over the summarization process, allowing for the creation of customized summarization policies. By defining named summarization configurations, network administrators can effectively reduce the size of routing tables, optimize bandwidth usage, and enhance network scalability. EIGRP Named Summarization plays a vital role in maintaining a streamlined and efficient routing infrastructure in complex network environments.

Lab:

Disclaimer

This Configuration Guide is designed to assist members to enhance their skills in particular technology area. While every effort has been made to ensure that all material is as complete and accurate as possible, the enclosed material is presented on an Dzas isdz basis. Neither the authors nor Forum assume any liability or responsibility to any person or entity with respect to loss or damages incurred from the information contained in this guide. This configuration guide was developed by Forum. Any similarities between material presented in this configuration guide and any other material is completely coincidental.

Cisco IOS Software, Linux Software (I86BI_LINUX-ADVENTERPRISEK9-M), Version 15.2(4)M1, DEVELOPMENT TEST SOFTWARE

Task 1: Configure IPv4 EIGRP Summarization using named configuration

Step 1: In the configuration mode of router configure IPv4 EIGRP process with a name

R1:
interface serial2/0
ip address 12.0.0.1 255.255.255.0
no shutdown
interface loopback 1
ip address 11.0.0.1 255.255.255.0
exit
interface loopback 2
ip address 11.0.1.1 255.255.255.0
exit
interface loopback 3
ip address 11.0.2.1 255.255.255.0
exit
interface loopback 4
ip address 11.0.3.1 255.255.255.0
exit

router eigrp cisco
address-family ipv4 autonomous-system 100
network 12.0.0.1 0.0.0.0
network 11.0.0.1 0.0.0.0
network 11.0.1.1 0.0.0.0
network 11.0.2.1 0.0.0.0
network 11.0.3.1 0.0.0.0
exit

Step 2: Enter address-family interface mode and summarize EIGRP routes on outgoing interfaces

R1:
af-interface serial 2/0
summary-address 11.0.0.0 255.255.252.0
exit

Task 2: Verification:

Step 1: Verify receipt of summary route in neighbors routing table by following command:

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      11.0.0.0/22 is subnetted, 1 subnets
D        11.0.0.0 [90/13556702] via 12.0.0.1, 00:10:18, Serial2/0
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.0.0.0/24 is directly connected, Serial2/0
L        12.0.0.2/32 is directly connected, Serial2/0
      22.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C        22.0.1.0/24 is directly connected, Loopback1
L        22.0.1.2/32 is directly connected, Loopback1
C        22.0.2.0/24 is directly connected, Loopback2
L        22.0.2.2/32 is directly connected, Loopback2
C        22.0.3.0/24 is directly connected, Loopback3
L        22.0.3.2/32 is directly connected, Loopback3
      23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        23.0.0.0/24 is directly connected, Ethernet0/0
L        23.0.0.2/32 is directly connected, Ethernet0/0
     33.0.0.0/24 is subnetted, 3 subnets
D        33.0.1.0 [90/1024640] via 23.0.0.3, 00:02:51, Ethernet0/0
D        33.0.2.0 [90/1024640] via 23.0.0.3, 00:02:41, Ethernet0/0
D        33.0.3.0 [90/1024640] via 23.0.0.3, 00:02:32, Ethernet0/0
      34.0.0.0/24 is subnetted, 1 subnets
D        34.0.0.0 [90/14068062] via 23.0.0.3, 00:03:02, Ethernet0/0
      44.0.0.0/24 is subnetted, 3 subnets
D        44.0.1.0 [90/14068702] via 23.0.0.3, 00:00:43, Ethernet0/0
D        44.0.2.0 [90/14068702] via 23.0.0.3, 00:00:37, Ethernet0/0
D        44.0.3.0 [90/14068702] via 23.0.0.3, 00:00:31, Ethernet0/0

Step 2: Verify creation of null interface in routing table by following command:

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      11.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
D        11.0.0.0/22 is a summary, 00:19:00, Null0
C        11.0.1.0/24 is directly connected, Loopback1
L        11.0.1.1/32 is directly connected, Loopback1
C        11.0.2.0/24 is directly connected, Loopback2
L        11.0.2.1/32 is directly connected, Loopback2
C        11.0.3.0/24 is directly connected, Loopback3
L        11.0.3.1/32 is directly connected, Loopback3
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.0.0.0/24 is directly connected, Serial2/0
L        12.0.0.1/32 is directly connected, Serial2/0
      22.0.0.0/24 is subnetted, 3 subnets
D        22.0.1.0 [90/13556702] via 12.0.0.2, 01:15:20, Serial2/0
D        22.0.2.0 [90/13556702] via 12.0.0.2, 01:15:15, Serial2/0
D        22.0.3.0 [90/13556702] via 12.0.0.2, 01:15:11, Serial2/0
      23.0.0.0/24 is subnetted, 1 subnets
D        23.0.0.0 [90/14068062] via 12.0.0.2, 01:15:28, Serial2/0
     33.0.0.0/24 is subnetted, 3 subnets
D        33.0.1.0 [90/1024640] via 23.0.0.3, 00:02:51, Ethernet0/0
D        33.0.2.0 [90/1024640] via 23.0.0.3, 00:02:41, Ethernet0/0
D        33.0.3.0 [90/1024640] via 23.0.0.3, 00:02:32, Ethernet0/0
      34.0.0.0/24 is subnetted, 1 subnets
D        34.0.0.0 [90/14068062] via 23.0.0.3, 00:03:02, Ethernet0/0
      44.0.0.0/24 is subnetted, 3 subnets
D        44.0.1.0 [90/14068702] via 23.0.0.3, 00:00:43, Ethernet0/0
D        44.0.2.0 [90/14068702] via 23.0.0.3, 00:00:37, Ethernet0/0
D        44.0.3.0 [90/14068702] via 23.0.0.3, 00:00:31, Ethernet0/0