OSPF IPv4 - Summarization on ASBR

Summarization on ASBR

OSPF (Open Shortest Path First) for IPv4 summarization on ASBR (Autonomous System Border Router) involves aggregating route information to reduce the size and complexity of OSPF routing tables at the network's boundary. ASBRs, which connect OSPF domains to external networks or other OSPF Autonomous Systems, play a crucial role in summarization. Summarization at the ASBR consolidates detailed OSPF routing information into more concise and manageable summaries, optimizing network efficiency. This process is particularly beneficial when interfacing with external routing domains to prevent the injection of excessive or unnecessary routing details. By configuring summarization on the ASBR, network administrators can control the granularity of the routing information disseminated into the OSPF domain, striking a balance between minimizing routing table size and preserving essential topology details for efficient OSPF routing.

Lab:

Task 1: Configure IPv4 OSPF Summarization

Step 1: In the configuration mode of router configure 4 loopbacks with network address in sequence

R1:
interface loopback 100
ip address 100.0.0.1 255.255.255.0
exit
interface loopback 101
ip address 100.0.1.1 255.255.255.0
exit
interface loopback 102
ip address 100.0.2.1 255.255.255.0
exit
interface loopback 103
ip address 100.0.3.1 255.255.255.0
exit

Step 2: Redistribute external 100 network on ASBR.

R1:
router ospf 1
redistribute connected subnets

(Redistributed connected will redistribute its connected network. Subnet will allow classless routes in OSPF process.)

Step 3: Verify routes on neighbor router routing table

R2#show ip route
! (Shows router’s routing table and IPv4 entries)
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
 D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
 N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
 E1 – OSPF external type 1, E2 – OSPF external type 2
 i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
 ia – IS-IS inter area, * - candidate default, U – per-user static route
 o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
 + - replicated route, % - next hop override

Gateway of last resort is not set

 11.0.0.0/32 is subnetted, 3 subnets
O 11.0.1.1 [110/65] via 12.0.0.1, 00:15:52, Serial2/0
O 11.0.2.1 [110/65] via 12.0.0.1, 00:15:52, Serial2/0
O 11.0.3.1 [110/65] via 12.0.0.1, 00:15:52, Serial2/0
 12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.0.0.0/24 is directly connected, Serial2/0
L 12.0.0.2/32 is directly connected, Serial2/0
 22.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C 22.0.1.0/24 is directly connected, Loopback1
L 22.0.1.2/32 is directly connected, Loopback1
C 22.0.2.0/24 is directly connected, Loopback2
L 22.0.2.2/32 is directly connected, Loopback2
C 22.0.3.0/24 is directly connected, Loopback3
L 22.0.3.2/32 is directly connected, Loopback3
 23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.0.0.0/24 is directly connected, Ethernet0/0
L 23.0.0.2/32 is directly connected, Ethernet0/0
 33.0.0.0/32 is subnetted, 3 subnets
O 33.0.1.3 [110/11] via 23.0.0.3, 00:15:10, Ethernet0/0
O 33.0.2.3 [110/11] via 23.0.0.3, 00:15:10, Ethernet0/0
O 33.0.3.3 [110/11] via 23.0.0.3, 00:15:10, Ethernet0/0
 34.0.0.0/24 is subnetted, 1 subnets
O IA 34.0.0.0 [110/74] via 23.0.0.3, 00:15:10, Ethernet0/0
 44.0.0.0/32 is subnetted, 3 subnets
O IA 44.0.1.4 [110/75] via 23.0.0.3, 00:15:10, Ethernet0/0
O IA 44.0.2.4 [110/75] via 23.0.0.3, 00:15:10, Ethernet0/0
O IA 44.0.3.4 [110/75] via 23.0.0.3, 00:15:10, Ethernet0/0
 100.0.0.0/24 is subnetted, 4 subnets
O E2 100.0.0.0 [110/20] via 12.0.0.1, 00:00:53, Serial2/0
O E2 100.0.1.0 [110/20] via 12.0.0.1, 00:00:58, Serial2/0
O E2 100.0.2.0 [110/20] via 12.0.0.1, 00:00:58, Serial2/0
O E2 100.0.3.0 [110/20] via 12.0.0.1, 00:00:58, Serial2/0

(E2 means External route type 2, in which will not change cost after every hop throughout the OSPF.)

Step 4: Summarize external routes on ASBR router

! (In external route summary is always done on Autonomous System Border Router (ASBR))

R1:
router ospf 1
summary-address 100.0.0.0 255.255.252.0
exit

Task 2: Verification:

Step 1: Verify receipt of summary route in neighbor routing table & verify creation of null interface in routing table by following command:

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
 + - replicated route, % - next hop override

Gateway of last resort is not set

 11.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C 11.0.1.0/24 is directly connected, Loopback1
L 11.0.1.1/32 is directly connected, Loopback1
C 11.0.2.0/24 is directly connected, Loopback2
L 11.0.2.1/32 is directly connected, Loopback2
C 11.0.3.0/24 is directly connected, Loopback3
L 11.0.3.1/32 is directly connected, Loopback3
 12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.0.0.0/24 is directly connected, Serial2/0
L 12.0.0.1/32 is directly connected, Serial2/0
 22.0.0.0/32 is subnetted, 3 subnets
O IA 22.0.1.2 [110/65] via 12.0.0.2, 00:29:15, Serial2/0
O IA 22.0.2.2 [110/65] via 12.0.0.2, 00:29:15, Serial2/0
O IA 22.0.3.2 [110/65] via 12.0.0.2, 00:29:15, Serial2/0
 23.0.0.0/24 is subnetted, 1 subnets
O IA 23.0.0.0 [110/74] via 12.0.0.2, 00:29:15, Serial2/0
 33.0.0.0/32 is subnetted, 3 subnets
O IA 33.0.1.3 [110/75] via 12.0.0.2, 00:28:33, Serial2/0
O IA 33.0.2.3 [110/75] via 12.0.0.2, 00:28:33, Serial2/0
O IA 33.0.3.3 [110/75] via 12.0.0.2, 00:28:33, Serial2/0
 34.0.0.0/24 is subnetted, 1 subnets
O IA 34.0.0.0 [110/138] via 12.0.0.2, 00:28:33, Serial2/0
 44.0.0.0/32 is subnetted, 3 subnets
O IA 44.0.1.4 [110/139] via 12.0.0.2, 00:28:33, Serial2/0
O IA 44.0.2.4 [110/139] via 12.0.0.2, 00:28:33, Serial2/0
O IA 44.0.3.4 [110/139] via 12.0.0.2, 00:28:33, Serial2/0
 100.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
O 100.0.0.0/22 is a summary, 00:00:05, Null0
C 100.0.0.0/24 is directly connected, Loopback100
L 100.0.0.1/32 is directly connected, Loopback100
C 100.0.1.0/24 is directly connected, Loopback101
L 100.0.1.1/32 is directly connected, Loopback101
C 100.0.2.0/24 is directly connected, Loopback102
L 100.0.2.1/32 is directly connected, Loopback102
C 100.0.3.0/24 is directly connected, Loopback103
L 100.0.3.1/32 is directly connected, Loopback103

(When summarization is configured on a router; same router immediately created a routing point to Null 0 for loop prevention.)

R2#show ip route
! (Shows router’s routing table and IPv6 routes entries)
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
 + - replicated route, % - next hop override

Gateway of last resort is not set

 11.0.0.0/32 is subnetted, 3 subnets
O 11.0.1.1 [110/65] via 12.0.0.1, 00:29:30, Serial2/0
O 11.0.2.1 [110/65] via 12.0.0.1, 00:29:30, Serial2/0
O 11.0.3.1 [110/65] via 12.0.0.1, 00:29:30, Serial2/0
 12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.0.0.0/24 is directly connected, Serial2/0
L 12.0.0.2/32 is directly connected, Serial2/0
 22.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C 22.0.1.0/24 is directly connected, Loopback1
L 22.0.1.2/32 is directly connected, Loopback1
C 22.0.2.0/24 is directly connected, Loopback2
L 22.0.2.2/32 is directly connected, Loopback2
C 22.0.3.0/24 is directly connected, Loopback3
L 22.0.3.2/32 is directly connected, Loopback3
 23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.0.0.0/24 is directly connected, Ethernet0/0
L 23.0.0.2/32 is directly connected, Ethernet0/0
 33.0.0.0/32 is subnetted, 3 subnets
O 33.0.1.3 [110/11] via 23.0.0.3, 00:28:48, Ethernet0/0
O 33.0.2.3 [110/11] via 23.0.0.3, 00:28:48, Ethernet0/0
O 33.0.3.3 [110/11] via 23.0.0.3, 00:28:48, Ethernet0/0
 34.0.0.0/24 is subnetted, 1 subnets
O IA 34.0.0.0 [110/74] via 23.0.0.3, 00:28:48, Ethernet0/0
 44.0.0.0/32 is subnetted, 3 subnets
O IA 44.0.1.4 [110/75] via 23.0.0.3, 00:28:48, Ethernet0/0
O IA 44.0.2.4 [110/75] via 23.0.0.3, 00:28:48, Ethernet0/0
O IA 44.0.3.4 [110/75] via 23.0.0.3, 00:28:48, Ethernet0/0
 100.0.0.0/22 is subnetted, 1 subnets
O E2 100.0.0.0 [110/20] via 12.0.0.1, 00:00:15, Serial2/0

(Summarized routes are received from external route.)